none
Unable to install .Net Framework 3.5 on Windows 10 1607.1 - error

    Question

  • I'm running off of a captured image we are trying to implement. I've tried through add/remove programs, tried DISM, tried uninstalling 4.6 first then trying both add/remove and DISM. Nothing seems to work! I also tried adding it by using the cab. I ran cleanup-image to try a restore the CBS without any result. Am I missing something here?

    Dism /online /enable-feature /featurename:NetFX3 /All /Source:D:\sources\sxs /LimitAccess
    
    DISM.EXE /Online /Add-Package /PackagePath:C:\Features\Microsoft-Windows-NetFx3-OnDemand-Package.cab
    
    Dism /Online /Cleanup-Image /StartComponentCleanup
    
    Dism /Online /Cleanup-Image /RestoreHealth



    • Edited by IAMGR00T Tuesday, March 14, 2017 7:09 PM
    Tuesday, March 14, 2017 7:07 PM

Answers

  • Hi,

    To do further troubleshooting, please post the DISM.log under %windir%\Logs\DISM and CBS.log under %windir%\Logs\CBS onto OneDrive and share the Link here for our research.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Oddly enough, it was Symantec that wasn't allowing me to install. After disabling it, I was capable of running DISM.
    • Marked as answer by IAMGR00T Wednesday, March 15, 2017 5:27 PM
    Wednesday, March 15, 2017 5:27 PM

All replies

  • Hi,

    To do further troubleshooting, please post the DISM.log under %windir%\Logs\DISM and CBS.log under %windir%\Logs\CBS onto OneDrive and share the Link here for our research.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 15, 2017 7:52 AM
    Moderator
  • Hi,

    To do further troubleshooting, please post the DISM.log under %windir%\Logs\DISM and CBS.log under %windir%\Logs\CBS onto OneDrive and share the Link here for our research.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Oddly enough, it was Symantec that wasn't allowing me to install. After disabling it, I was capable of running DISM.
    • Marked as answer by IAMGR00T Wednesday, March 15, 2017 5:27 PM
    Wednesday, March 15, 2017 5:27 PM