none
Durations keep changing RRS feed

  • Question

  • I recently created a new project file from scratch, I made sure all of the options/settings were the same. A new Global.MPT file has been created as well.

    Our Project file is currently being shared between 20-25 people. I have a separate Global.mpt file from all of them.

    Problem:

    This does not happen on my computer but whenever anyone else tries to copy, move or delete a subtask, the durations of several other subtasks get shortened. In some cases the first subtask in the section gets moved to an earlier time in the schedule along with the durations of the others tasks linked to it. This happens all throughout the schedule.

    What I have tried?:

    I have tried opening the project file on other peoples computers using my Global.MPT file. No success

    I have adjusted the options settings and task settings (Effort Driven/Not Effort Driven, Estimated) No success

    Any suggestions will be greatly appreciated.

    Thanks,

    Chris

    **Update**

    Messing around with it some more, I have found a partial work around.

    If I delete the resources on the tasks that the durations change then I can freely make changes to any tasks but if I copy and paste any task then the whole schedule goes out of whack.

    I have all of the tasks with the same constraint (Start as soon as possible) except for the first one in each group is set to "Start on date".

    Also, all of the data gets bolded when the durations are affected.

    • Edited by chrisr3011 Friday, April 27, 2012 8:29 PM
    Friday, April 27, 2012 5:56 PM

Answers

  • Chris,

    I doubt this has anything to do with the issue, but when you say you shared your Global, did you replace the active Global or simply put the Global into the same folder as Project? THe active working Global will be located at:

    Windows XP C:\Documents and Settings\[PC name]\Application Data\Microsoft\MS Project\12\1033

    WIndows 7 C:\Users\[PC name]\App Data\Roaming\Microsoft\MS Project\12\1033

    I don't see anything unusual about your resources other than some of the labor (work) resources are on a different calendar (i.e. 24 hour), but that shouldn't affect whether a given file works on one PC and not on another.

    You indicate you are moving tasks around. That begs a couple more questions.

    1. Do you have any resources assigned to summary lines? If so, bad practice, remove those resources

    2. Do you have any links (predecessors or successors) on summary lines? If so, also bad practice, get rid of those and link only subtasks.

    3. I assume calculation is set to automatic for all PCs. True?

    I have no idea is SP3 will resolve your issue, but unless all PCs are updated to the latest service pack, you are probably wasting time chasing this.

    John


    • Marked as answer by chrisr3011 Thursday, May 10, 2012 12:05 PM
    Tuesday, May 1, 2012 6:03 PM
  • Well guys, I have found a fix for what was happening.

    On one of the computers with SP1, I opened the schedule, copied all of the start dates/durations/finish dates of every task. I then pasted it directly on top 2 times as the first paste messes all of the dates/durations up. After the second paste, it added a constraint to every task of "should not start earlier than" and had a date of what was pasted. I changed all of the constraints, except for the first subtask, to "start as soon as possible" so they would link together properly and move as expected.

    File was saved and tested on several other computers with SP1 still and it works perfectly.

    The update for SP3 is still being pushed out and should be on everyones computer within a week.

    I dont completely understand how or why this fix worked but I am glad it did.

    Thank you everyone for your comments and ideas as they helped me to finally get our schedule to work properly.

    Chris

    • Marked as answer by chrisr3011 Thursday, May 10, 2012 12:05 PM
    Wednesday, May 9, 2012 8:02 PM

All replies

  • Chris,

    Okay, let's take a look at some basics.

    1. What version of Project are you using? (I assume all 20-25 users have the same version. Mixing versions is not recommended.)

    2. Do you have the latest service pack installed? (see: http://technet.microsoft.com/en-us/office/ee748587)

    3. What exactly do you mean by "a new Global has been created"?

    4. Are you or any users using resource leveling?

    5. What exactly do you mean by "except for the first one in each group is set to start on date"?

    When re-arranging your schedule, generally drag and drop is better than copy and paste.

    John

    Friday, April 27, 2012 9:02 PM
  • Chris,

    As you note that removing resources changes things -- my guess is that you have automatic leveling enabled.  Assuming you are using Project 2010 go to the Resource tab, and select "Leveling Options".  In the leveling options dialog, ensure you leveling calculation is set to manual.

    I hope this helps.

    Julie

    Saturday, April 28, 2012 9:09 PM
    Moderator
  • 1. I am using MS Project 2007 Std.

    2. I have service pack 3, most others have SP2.

    3. The old project file had a Global.mpt file that was created and shared with everyone, when I created the new project file, I removed the shared one, saved the file, and a new one was automatically created which did not have any of the settings from the previous one.

    4. I will try to disable this and see if it fixes the problem.

    5. We use project for our drilling schedule, in this schedule we have rigs, under each rig is a well (subtask). The first subtask is set to start on a certain date while the next ones have a constraint to start as soon as possible and are linked so there are no gaps in between tasks within a rigline.

    Drag and drop is used when moving tasks around and I make sure they are linked and moved correctly, the copy and paste is used when we are adding new subtasks which have all of the same information except for the name.

    I will update if changing the resource leveling option fixes it.

    Thanks for your response.

    Monday, April 30, 2012 2:57 PM
  • Chris,

    Thanks for the additional information. My first suggestion is to make sure all users install the SP3 update. It's main focus is to improve compatibility with Project 2010, but it also has some fixes unique to Project 2007 and it is always good practice when sharing files to have all users on the save updated version.

    With regard to the Global file, if you indeed located the active Global and trashed it, then a new default Global was created when you re-started Project. However, did all users do that? If not they should. Nothing wrong with having a custom Global, in fact most users have one although they may not know it. However, whatever Global file is used, all users should have the same Global.

    Julie assumed Project 2010 when she provided directions for addressing a possible resource leveling issue. You probably already know how to check that in Project 2007 but just in case, have all users go to Tools/Level Resources and make sure it is set to "manual".

    John

    Monday, April 30, 2012 3:49 PM
  • Thank you for your response.

    I have checked the resource leveling option and is was set to manual.

    I also shared my global.mpt file and opened the project file on the problem computers.

    Problem is still occuring.

    A request has been sent in to update one of the computers to SP3 from SP1 to see if this resolves the issue.

    The resources are set as follows:

    Type: Material

    Material Label: feet/unit

    Initials: 1-10. FC or FS

    Std. Rate 1

    Cost/Use: 0

    Accrue at: Start

    Base Calendar: this is blank

    Several resources have been added incorrectly which have the following:

    Type: Work

    Max Units: 100%

    Std. Rate: 0/hr

    Ovt. Rate: 0/hr

    Cost/Use: 0

    Accrue at: Prorated

    Base Calendar: Standard or 24 Hours

    I have tried deleting the added resources but can only do so on my computer without all of the dates/durations messing up. I also reassigned the resources to all of the tasks from my computer and reopened the file on the problem computer and tried moving a task to duplicate the error and a lot less durations/dates were affected compared to before with the incorrect resources.

    I hope this is clear and will update as to whether or not installing SP3 will fix.

    Thank you very much for your input,

    Chris

    Tuesday, May 1, 2012 3:24 PM
  • Chris,

    I doubt this has anything to do with the issue, but when you say you shared your Global, did you replace the active Global or simply put the Global into the same folder as Project? THe active working Global will be located at:

    Windows XP C:\Documents and Settings\[PC name]\Application Data\Microsoft\MS Project\12\1033

    WIndows 7 C:\Users\[PC name]\App Data\Roaming\Microsoft\MS Project\12\1033

    I don't see anything unusual about your resources other than some of the labor (work) resources are on a different calendar (i.e. 24 hour), but that shouldn't affect whether a given file works on one PC and not on another.

    You indicate you are moving tasks around. That begs a couple more questions.

    1. Do you have any resources assigned to summary lines? If so, bad practice, remove those resources

    2. Do you have any links (predecessors or successors) on summary lines? If so, also bad practice, get rid of those and link only subtasks.

    3. I assume calculation is set to automatic for all PCs. True?

    I have no idea is SP3 will resolve your issue, but unless all PCs are updated to the latest service pack, you are probably wasting time chasing this.

    John


    • Marked as answer by chrisr3011 Thursday, May 10, 2012 12:05 PM
    Tuesday, May 1, 2012 6:03 PM
  • I would look into the installation of the latest service packs.  You are using material resources and they should not be affecting task durations.
    Wednesday, May 2, 2012 3:30 PM
    Moderator
  • Well guys, I have found a fix for what was happening.

    On one of the computers with SP1, I opened the schedule, copied all of the start dates/durations/finish dates of every task. I then pasted it directly on top 2 times as the first paste messes all of the dates/durations up. After the second paste, it added a constraint to every task of "should not start earlier than" and had a date of what was pasted. I changed all of the constraints, except for the first subtask, to "start as soon as possible" so they would link together properly and move as expected.

    File was saved and tested on several other computers with SP1 still and it works perfectly.

    The update for SP3 is still being pushed out and should be on everyones computer within a week.

    I dont completely understand how or why this fix worked but I am glad it did.

    Thank you everyone for your comments and ideas as they helped me to finally get our schedule to work properly.

    Chris

    • Marked as answer by chrisr3011 Thursday, May 10, 2012 12:05 PM
    Wednesday, May 9, 2012 8:02 PM
  • Chris,

    Glad you got it fixed. If I had to venture a guess I'd say there was file corruption, possibly due to multiple users with different version updates, working on the file. If that is the case, your "fix" may only be as temporary as the next update.

    Anyway, you're welcome and thanks for the feedback. If you feel we've addressed your problem please mark your post as answered.

    John

    Wednesday, May 9, 2012 9:29 PM