none
Customize Columns displayed on Computers Page list RRS feed

  • Question

  • So I have added computers to the FIM portal to allow IT admins modify computer attributes and project them back to AD.

    I am unable to modify the columns displayed on the pages I have created though. I customized the columns in the All Users it was easy, I followed the same steps and modified the columns in the search scope for all Computers but no luck.

    Any assistance on this would be helpful.


    Russell Lema

    Thursday, July 9, 2015 4:07 PM

Answers

  • Because the configuration is not correct. You are presented with the default.

    I would take a shortcut.  Customize the view you are being presented with "ALL Computers Resources" instead.


    Nosh Mernacaj, Identity Management Specialist

    • Marked as answer by Russ Lema Thursday, July 16, 2015 9:51 PM
    Friday, July 10, 2015 4:26 PM
  • Well Nosh,

    I appreciate all your help, after looking and deleting all sets, and search scopes and starting over, I found the issue.

    I had defined the Usage Keyword for both search scope and Navigation Bar, but forgot to give read right to the search scope keyword, just had given it to the Navigation Bar Keyword Set.

    I feel like a dummy.

    I appreciate all your help on this.


    Russell Lema

    • Marked as answer by Russ Lema Tuesday, July 14, 2015 2:33 PM
    Tuesday, July 14, 2015 2:33 PM

All replies

  • Any chance you can provide some more background.
    what did you do to create Computers in portal. New Objects, New Group, or what. Some screen shots would help.

    Which view you are trying to change? where is that you want the columns reordered?


    Nosh Mernacaj, Identity Management Specialist

    Thursday, July 9, 2015 7:30 PM
  • No problem.

    New Schema Resource

    Name - Computers

     Binded Attributes -

    cn
    sAMAccountName
    operatingSystem
    operatingSystemServicePack
    operatingSystemVersion
    Division
    Department
    DepartmentNumber
    camComputerSiteID
    location
    managedBy
    serialNumber
    BusinessCategory
    co
    st
    StreetAddress
    l
    postalCode
    ExtensionAttribute1
    ExtensionAttribute2
    ExtensionAttribute3
    ExtensionAttribute4
    ExtensionAttribute5
    ExtensionAttribute6
    ExtensionAttribute7
    ExtensionAttribute8
    ExtensionAttribute9
    ExtensionAttribute10
    ExtensionAttribute11
    ExtensionAttribute12
    ExtensionAttribute13
    ExtensionAttribute14

    ExtensionAttribute15

    New Set - Computers

    Criteria Based Members

    Select (computers) that match (all) of the following conditions

    No conditions

    New Navigation Bar Resource

    All Computers

    URL - ~/IdentityManagement/aspx/customized/CustomizedObjects.aspx?type=Computer&display=Computers

    Usage Keyword- 

    IT Administrators

    New Set -

    IT Administrators

    Manually Selected Membership

    New Set -

    Computer Usage Keyword

    Criteria Based members

    Nav bar resource -

    Keyword contains computers

    or

    IT Administrators

    Manually managed membership

    Search scope -

    Keyword

    IT Administrators

    Computers

    Search Scope -

    All Computers

    Usage Keyword - 

    IT Administrators

    Computers

    Resource Type - Computer

    Attribute - DisplayName;Description;dnsHostName

    Redirect URL - ~/IdentityManagement/aspx/customized/CustomizedObjects.aspx?type=Computer&display=Computers

    MPR -

    IT Administrators can read all computer objects

    IT Administrators can modify some computer objects

    IT administrators can read computer UI

    Still only get


    Russell Lema

    Friday, July 10, 2015 3:01 PM
  • On your search scope, you need to add the attributes you want to show up under "Attributes to Display" and do an ISSRESET

    Nosh Mernacaj, Identity Management Specialist

    Friday, July 10, 2015 3:05 PM

  • I do have them there, sorry search attributes are display name


    • Edited by Russ Lema Friday, July 10, 2015 3:22 PM
    Friday, July 10, 2015 3:21 PM
  • You are not getting the same searchScope.  Your search scope is not applied.  Check the searchScope name at the right upport corner. 


    Nosh Mernacaj, Identity Management Specialist

    Friday, July 10, 2015 3:27 PM
  • you are right, it doesn't even show on the home page in search within, I don't know why.

    Russell Lema

    Friday, July 10, 2015 3:39 PM
  • 1. Did you do an IISRESET? If no Do it, if yes

    2. Check the Navigation Resource. Is it pointing to the right Search Scope?


    Nosh Mernacaj, Identity Management Specialist

    Friday, July 10, 2015 3:43 PM
  • Done several IIS resets, got the portal done and everything configured, the only thing not working is this.

    I am pointing it to the search scope GUID.

    ~/IdentityManagement/aspx/customized/CustomizedObjects.aspx?type=Computer&searchtype=b4bf17a3-9299-425f-b0aa-3a073e25dd89

    All Computers Search Scope GUID

    b4bf17a3-9299-425f-b0aa-3a073e25dd89


    Russell Lema


    • Edited by Russ Lema Friday, July 10, 2015 3:46 PM
    Friday, July 10, 2015 3:45 PM
  • Do you even have access to ready the search Scope objects??

    And please answer this "DID YOU DO AN ISSRESET". Third time I am asking. :)


    Nosh Mernacaj, Identity Management Specialist

    Friday, July 10, 2015 3:47 PM
  • Above I answered...

    Done several IIS resets, got the portal done and everything configured, the only thing not working is this.

    I am checking now, I don't see why not, I modified the ALL Users search scope. with no issues.


    Russell Lema

    Friday, July 10, 2015 3:52 PM
  • So I added a new set "All Search Scope Object" and Gave ADMINS full control, but nothing, still the same.

    In the "Computers Page" under search within the only option there is  listed is "ALL Computers Resources" I do not know why.

    I do not have any search scope with this definition.

    I appreciate all your help.

    I am wondering if I might just have to start over and re do the whole design of Computer Objects.


    Russell Lema

    Friday, July 10, 2015 3:57 PM
  • Because the configuration is not correct. You are presented with the default.

    I would take a shortcut.  Customize the view you are being presented with "ALL Computers Resources" instead.


    Nosh Mernacaj, Identity Management Specialist

    • Marked as answer by Russ Lema Thursday, July 16, 2015 9:51 PM
    Friday, July 10, 2015 4:26 PM
  • Nosh,

    Thanks for the info but I have tried to find the "ALL Computers Resources"

    But I cannot seem to find that search scope, could it be somewhere else?


    Russell Lema

    Friday, July 10, 2015 5:43 PM
  • Russell,

    I have not logged in to FIM for months and I am just trying to remember.  This is not a resource I have used ever, but the logic is all the same. 

    You can always look for Under All Resources, - Administration - All Resources? I believe that is the path.


    Nosh Mernacaj, Identity Management Specialist

    Friday, July 10, 2015 5:51 PM
  • I found it there, I also compared it to USER resource, I found that there are no usage Keywords associated with this resource.

    Maybe that is the issue.


    Russell Lema

    Friday, July 10, 2015 5:56 PM
  • That is ok. It just means everyone has access. Now compare the settings, Attributes (that is where your issue is)

    Nosh Mernacaj, Identity Management Specialist

    Friday, July 10, 2015 6:03 PM
  • The Bindings?


    Russell Lema

    Friday, July 10, 2015 6:46 PM
  • Search Scope.  Binding is on the object type. The issue you have is displaying it. Similar to your other search scope


    Nosh Mernacaj, Identity Management Specialist

    Friday, July 10, 2015 7:01 PM
  • I have tried using the system name for the attributes and the display name for the attributes.

    We can view the attributes and modify them fine in the computer objects. But I just cannot display them on the search scope. Is there some access to the search scope that is required.


    Russell Lema

    Friday, July 10, 2015 7:14 PM
  • You have established that the data displayed, comes from a search scope called "ALL Computers Resources". You already have the access since you are seeing it.  The only thing to do is to go to that searchScope and under Results tab, add the attributes you want in Attributes field as shown on previous comment

    Nosh Mernacaj, Identity Management Specialist

    Friday, July 10, 2015 7:44 PM
  • That is the problem, there is no search scope called "ALL Computers Resources"

    There is only the Resource of computers. I tried to create one with the same name, no change.

    I have been searching everywhere on followed the steps provided here
    https://technet.microsoft.com/en-us/library/ff608270(v=ws.10).aspx
    https://technet.microsoft.com/en-us/library/ee534913(v=ws.10).aspx
    https://technet.microsoft.com/en-us/library/ee534912(v=ws.10).aspx

    Still no luck..


    Russell Lema

    Friday, July 10, 2015 8:07 PM
  • Well Nosh,

    I appreciate all your help, after looking and deleting all sets, and search scopes and starting over, I found the issue.

    I had defined the Usage Keyword for both search scope and Navigation Bar, but forgot to give read right to the search scope keyword, just had given it to the Navigation Bar Keyword Set.

    I feel like a dummy.

    I appreciate all your help on this.


    Russell Lema

    • Marked as answer by Russ Lema Tuesday, July 14, 2015 2:33 PM
    Tuesday, July 14, 2015 2:33 PM
  • Hi Russ,

    1. Glad you got it working

    2. Nothing to feel stupid for.  It is always in the details.


    Nosh Mernacaj, Identity Management Specialist

    Tuesday, July 14, 2015 3:17 PM
  • Russ,

    It sounds like Nosh worked hard to help you out even though his answers weren't the exact thing you needed. I suggest that it is still appropriate to mark one or more of his responses as an answer indicating that they were part  of the answer. Or at least you can vote them as helpful.


    David Lundell, Get your copy of FIM Best Practices Volume 1 http://blog.ilmbestpractices.com/2010/08/book-is-here-fim-best-practices-volume.html

    Thursday, July 16, 2015 9:36 PM
  • David, 

    You are absolutely correct, thanks for pointing it out. I hadn't even thought about marking more than one correct. I have marked Nosh's answer correct. 

    Nosh, 

    I want to apologize for not giving you credit sooner. You were key in helping point me in the correct direction to get this solved. I appreciate all your hard work on this. 

    Thanks

    Russ


    Russell Lema

    Thursday, July 16, 2015 10:14 PM
  • Russ,

    Thanks for being a good sport.


    David Lundell, Get your copy of FIM Best Practices Volume 1 http://blog.ilmbestpractices.com/2010/08/book-is-here-fim-best-practices-volume.html

    Thursday, July 16, 2015 10:24 PM