locked
Import FOPE users from CSV-file RRS feed

  • Question

  • Hi,

    I'm trying add users by using the csv-import file feature. I've used the instructions here:

    http://technet.microsoft.com/en-us/library/ff715286.aspx

    I always get a confirmation email like this (I've changed the actual usernames to firstname and lastname for this forum post):

    Thank you for uploading your user list. Following is the summary for the recent user list that was uploaded.

     

    Start time: 4/5/2011 1:46:13 PM

    End time: 4/5/2011 1:46:13 PM

    Completion status: Success

     

    Users received: 2

    Users rejected: 2

     

    The following invalid entries were reported during the upload process: 

     

    [Submitted Data Collection]

    Invalid e-mail addresses:

    firstname.lastname@aptic.se;Firstname;Lastname (Invalid format)

    firstname.lastname@aptic.se;Firstname;Lastname (Invalid format)

    It seems like a such a simple operation but it's not working. I am using validated domains for the email addresses. I'm using Excel 2010 to make the CSV. Tried all three CSV save-as types.


    • Edited by Andreas Erson - Work Wednesday, April 6, 2011 7:11 AM add information about Excel 2010 and CSV save-as types
    Tuesday, April 5, 2011 1:53 PM

Answers

  • Hi,

    It looks like you have semi-colons in place of comma's,  you'll need to have comma's for the import to work.
    once you save the csv file from Excsl, open it in notepad and it should look like

    testuser@contoso.com,test,user
    testuser2@contoso.com,test,user2

     

    Kemper - MSFT

    Thursday, April 7, 2011 8:03 PM

All replies

  • Hi,

    It looks like you have semi-colons in place of comma's,  you'll need to have comma's for the import to work.
    once you save the csv file from Excsl, open it in notepad and it should look like

    testuser@contoso.com,test,user
    testuser2@contoso.com,test,user2

     

    Kemper - MSFT

    Thursday, April 7, 2011 8:03 PM
  • Thanks!

    That solved it. I'm using the English version of Excel 2010 and region and language set to Swedish and when I save to CSV from Excel the delimiter is not a comma (which it should be) but a semi-colon.

    Since Swedish (Sweden) has a different list separator (;) than English (United States) (,) per default in the Region and Language --> Tab Formats --> Additional Settings --> List separator perhaps this should be noted in the documentation for FOPE import for other languages for sure has this difference as well. Ability to choose list separator in the dialog box for "Import Users From File" in FOPE would be a great option as well.

    Excel 2010 displaying the file type as "CSV (Comma delimited) (*.csv)" despite it in my case being ";" doesn't help.

    Monday, April 11, 2011 6:30 AM