locked
High ISR & DPC RRS feed

  • Question

  • This was posted on the Windows Performance Tools forum but maybe that was the wrong place to post it.

    I'm looking for suggestions on how to resolve the following problem of slow PC performance.

    I have a problem with the CPU running at 20 – 25% even when the PC is “idle”. The PC runs fine for a minute or two after I log in and then the number of ISR & DPC suddenly goes through the roof and the CPU usage jumps to 20 – 25% and stays there.

    The problem is worse whenever there is any disk activity like virus scan, searching, creating shadow copies, etc.

    I've made no changes to the PC recently other than installing Windows updates & defragging/cleaning the HDD but my daughters are always installing new software for their photography. There have been no hardware changes prior to the problem occurring.

    Xperf trace, DPCLAT, LatencyMon, Process Explorer, Resource Monitor and Performance Information system health reports all point to USBPort.sys as the main culprit with13 million ISR’s a minute recorded by LatencyMon. This is followed by ATAport.sys & HAL.dll in the ISR count but the ISR counts for these are nowhere near as high as USBPort.sys. For DPC’s ATAport is  highest followed by USBPort.sys and dxgkrnl.sys.

    With USBPort.sys, 90% of the ISR count is against USBPort_Xdpc_worker but I don’t know what this is.

    With ATAPort.sys, most of the DPC count is against IDEPortCompletionDpc. Again I don’t know what this is.

    LatencyMon won’t run in Safe mode so I can’t tell if the high ISR/DPC counts are occurring then but in Safe mode the CPU usage at idle is 0% so I assume the high ISR/DPC isn’t happening.

    There are only a few hard pagefaults reported by LatencyMon but usually the maximum latencyfor these is off the scale. DPCLAT doesn’t show any spikes outside of the green.

    The latest Windows 7 updates are installed and I’ve virus/malware checked the disk using AVG, Malwarebytes & Avast (not all installed at once), cleaned & defragged the disk (I keep it pretty clean & tidy anyway), installed the latest BIOS, LAN, audio & chipset drivers from the Gigabyte web site, updated the Radeon drivers to the latest versions, run SFC /scannow (no problems reported), removed the WD Smartware software, made sure that the HDD is running in AHCI mode (it was IDE), have the Windows power plan set to High Performance with USB Selective Suspend disabled, unplugged all external USB devices apart from the mouse, disabled all the startup programs, used autoruns to clean up some programs running in the background, disabled various devices, services & scheduled tasks like USB hubs, Ritmo multi-card reader, indexing, search, shadow service, Windows Media Network Sharing Service … and tried uninstalling the USB hubs and rebooting to let Windows reinstall the drivers. I didn’t install the latest disk drivers as I wasn’t entirely sure which ones to use (I guess the SATA 2 since I don’t use the SATA 3 ports ??). Device Manager tells me I have the latest drivers installed for every device but then it was telling me that before I updated the drivers.

    Nothing made a difference until I disabled the USB 3.0 ports in Device Manager. Instantly the CPU usage dropped to 5 – 10 % however the high ISR counts continue as outlined above. Reinstalling the NEC USB 3.0 drivers from the Gigabyte site made no difference (that is still 20 – 25% CPU usage when enabled and 5 – 10% CPU usage when disabled, high ISR/DPC counts all the time). Uninstalling the USB 3.0 ports and rebooting resulted in them not being recognised by Windows i.e. they appear in Device Manager as Unknown Device i.e. Windows has stopped this device because it has reported problems.

    Resource Monitor and Process Explorer both show Interrupts and DPC accounting for (almost) all the 5 - 10% CPU usage.

    I've checked all the Event Logs but I can't really interpret what they are telling me apart from there are the occasional Critical & Warning message  ........ and lots of informational stuff.

    My PC specs are:

    . Gigabyte GA-P55a-UD3L Rev 1.0 mobo, Intel i5 760 quad core CPU, 4Gb RAM (26% used when idle).

    . Seagate Barracuda 7200 1.5 Tb HDD

    . Sony DL DVD

    . Ritmo internal multi-card reader (appears as multiple USB HDD in Device Manager)

    . Radeon HD 5700 graphics card

    . external WD MyBook 1.5Tb HDD (used for backups only)

    . Windows 7 Ultimate 64-bit.

    Any help would be appreciated.
    Wednesday, July 18, 2012 12:05 PM

All replies

  • Hi,

    First let me know if this issues persist when you take a Clean Boot. If no use, you should check if your IDE channel running in the “PIO Mode”. This properties can be found in the Device Management->IDE ATA/ATAPI controllers->ATA Channel(0-?)->Advanced Setting. If it’s, click driver tab uninstall it and then restart your computer.

    More information please refers the below link:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;817472

    Also you can try to uninstall all the USB controller by keyboard, then restart box to check if the problem be resolved.

    Thursday, July 19, 2012 7:28 AM
  • Thanks for your suggestions Spencer.

    I'll try them this evening and post the results.

    I have tried uninstalling the USB controllers and rebooting previously but the problem always persisted afterwards.

    The latest development is that .....

    After reading of high ISR/DPC problems associated with ATI HD audio drivers I installed the ATI HD audio drivers from the Realtek web site as suggested on those forums. On reboot USBPort.sys was still showing millions of ISR's. However on the reboot Windows 7 recognised that the USB 3.0 ports had a problem and prompted me to download & install the driver from the Gigabyte web page. It's been a few days since Windows failed to recognise the USB 3.0 ports after an uninstall & reboot and I had left the ports disabled since then. In that time Windows had never prompted me to install the USB 3.0 drivers despite multiple reboots.  Since I had the Gigabyte drivers already I ran the install again, Windows then said it was checking for updates and then I rebooted the PC once more. This time after the reboot USBPort.sys wasn't getting millions of ISR's a minute ... more like hundreds. I've reinstalled the USB 3.0 drivers a dozen times before and it never made a difference. So maybe it's all a co-incidence, maybe installing the Realtek ATI HD audio did make a difference ... or maybe it was just a temporary return to normality and to-night it will be back to it's usual problem.

    The problems with ATAPort.sys, HAL.dll and Dxgkrnl.sys were still the same but fingers crossed that the USBPort.sys problem is fixed.

    Friday, July 20, 2012 12:00 AM
  • Spencer,

    The USBPort.sys problem hasn't been resolved.

    A clean boot doesn't make any identifiable difference. I disabled all startup programs and non-Microsoft services and rebooted and the problems remain.

    In Ultra DMA Mode 6 the problems still exist as before. The channel was set to Multiword DMA Mode-2 and uninstalling and rebooting made no difference. Turns out that in AHCI mode SATA ports 0 & 1 default to Multiword DMA Mode-2 (mine was in port 0). Moving it to another port resulted in it setting to Ultra DMA Mode 6. I changed from IDE to AHCI mode a month or so ago to try and resolve the current problems so it must have been in Multiword ever since then.

    I confirmed that the problems don't occur in Safe mode with the CPU sitting on 0% or 1% usage for 10 minutes after login. When booting normally CPU usage sits on 0 - 5% for about 2 minutes after login and then jumps to 5 - 10% where it stays.

    Disabling the USB 3.0 port is no longer required to get the CPU usage down from 20%. In fact disabling the USB 3.0 port now makes no difference to the CPU usage so that at least has improved.

    After 1 minute of recording LatencyMon currently  shows:

    USBPort.sys   12.9  million ISR's

    ATAPort.sys   171,000 ISR's

    Hal.dll           60,200 ISR's

    Friday, July 20, 2012 11:03 AM
  • Hi,

    Based on my research for your issues, I found this problem may be caused by the graphics driver. The way you can try to uninstall your graphics driver and restart your computer to check if the issues persist.  If the problem can’t be solved, you can try following method step by step:

    1. locate the files named USBehci.sys, USBHUB.sysc, USBohci.sys and USBport.sys in C:>windows>system32> drives, delete all of them.
    2. Locate the .dll file named USBUI.DLL in C:>windows>system32, delete it.
    3. Restart your computer.

    Also remember to unplugged all your USB external device when you take a troubleshooting.

    Finally, let me know if this problem persist when you disable wireless card.

    After all above that, try to update your BIOS again even you already did it.  

    Monday, July 23, 2012 3:24 AM
  • Hi Spencer,

    I'm using a desktop and it doesn't have a wireless LAN card.

    I ran the Catalyst uninstall program to remove the Radeon drivers. As soon as it had finished, Windows reinstalled the drivers. After a reboot things were worse than before with just over 17 million ISR's recorded for USBPort.sys in 1 minute. CPU usage was still 5 - 10% when "idle".

    I assigned myself access to the USB files you specified and the nremoved them however these files weren't reinstalled on reboot which left me without USB devices including mouse. Is that what you expected ? Attempts to reinstall them weren't successful so I booted into Safe mode and restored the image I'd taken before I started which gave me the USB devices again. ISR/DPC's & CPU usage was also back as it was.

    I then reinstalled the Realtek ATI HD audio in place of the AMD ATI HD audio  to see if I could get the same result as last week. Once installation had finished, Windows ran an update from Microsoft for this and on reboot the ISR probem with USBPort.sys was much less than it usually is. This is the same process and result as previously (see Friday 12:00AM post above). The LatencyMon readings after 1 minute of recording were:

                                             ISR's                 DPC's

    USBPort.sys                     3200                   11000

    ATAPort.sys                   94000                   12000

    HAL.dll                          60000                          0

    Like last week a second reboot saw the readings return to similar numbers to usual:

                                          ISR's                  DPC's

    USBPort.sys                  14.3 million           10000

    ATAPort.sys                   179000                21000

    HAL.dll                           44000                        0

    It seems that installing the Realtek HD audio/Microsoft update improves things considerably but after the initial reboot any further reboot sees things somehow go back to the way they were.

    I have all USB devices apart from the mouse unplugged during testing.

    I reinstalled the latest BIOS but this hasn't made any difference that I can detect. The BIOS installed is the same version/date as the version I installed previously.

    Tuesday, July 24, 2012 5:59 AM
  • Hi,

    I doubt if this high usage of ISR is caused by ‘audiodg.exe’, try to following suggestions:

    1.Right click on the 'volume mixer' icon in the system tray and select 'playback devices'.

    2.In the ensuing dialogue, there should be a list of playback devices. Double click on the one selected, i.e., the one with the big green tick beside it.

    3.In the resulting 'speaker properties' dialogue, select the enhancements tab and check 'Disable all sound effects' and click OK on all the dialogues to save the updated settings.

    Tuesday, July 24, 2012 6:17 AM
  • Hi Spencer,

    Nothing was selected/ticked on the Enhancements tab when I brought it up. I ticked "disable all enhancements" anyway and clicked Ok to get out.

    When I checked LatencyMon the ISR/DPC counts were as low as they were before I ticked "disable all enhancements" (nothing had changed) i.e.

                                           ISR's                 DPC's

    USBPort.sys                     3200                   11000

    ATAPort.sys                   94000                   12000

    HAL.dll                          60000                          0

    I rebooted the PC to see if that made a difference and then got the BSOD when I went to login to Technet. On reboot the ISR/DPC numbers (1 minute sample) were high again i.e.

                                       ISR's                  DPC's

    USBPort.sys                  16.6 million           10000

    ATAPort.sys                   194000                23000

    HAL.dll                           43000                        0

    I then ran the Realtek HD audio install again (which involves two reboots - 1 after removing the current driver and 1 after installing the new driver) and the "low" ISR/DPC numbers were back (again 1 minute sample) i.e.

                                         ISR's                 DPC's               Highest Execution (ms) 

    USBPort.sys                     3064                10000                    0.219

    ATAPort.sys                  115000               15000                    0.162

    HAL.dll                          60000                       0                    0.090

    However disabling HD audio makes no difference to the ISR/DPC counts.

    CPU usage with the "low" ISR/DPC counts varies between 0% - 10% when at "idle".

    Just on other files in LatencyMon  in case it means anything.

    ACPI.sys usually shows small numbers of ISR's i.e. 20 - 30 with 0 DPC's. USBPort.sys, ATAPort.sys, HAL.dll and ACPI.sys are the only drivers/files showing any ISR's in LatencyMon.

    NTOSKRNL.exe shows 0 ISR's and 8300 DPC's and dxgkrnl.sys shows 0 ISR's and 2200 DPC's. These and USBPort.sys and ATAPort.sys are the only driver/files showing more than 500 DPC's. There are 19 others with less than 500 DPC's.

    I've been focussing on USBPort.sys and ATAPort.sys as they are the two files with high ISR & high DPC counts.




    • Edited by GunnMan Tuesday, July 24, 2012 10:48 PM
    Tuesday, July 24, 2012 12:53 PM
  • Spencer,

    OK so it's not just the reinstall of the HD audio that affects the ISR/DPC counts.

    As a test I re-ran the Gigabyte LAN driver update. I measured the ISR & DPC readings before the update and they were the high readings. I ran the LAN update (no reboot required) and then measured the ISR & DPC readings again. This time they were the "low" readings. I rebooted the PC and checked the readings again and they were high once more.

    Wednesday, July 25, 2012 10:02 AM
  • Hi,

    One important thing you mentioned is that the symptom  would not reappear when you start your OS in safe mode. You can rule out the default settings and minimum device drivers as possible causes. Then try to find which driver cause the issue. Uninstall them and restart the computer in normal.

    Thursday, July 26, 2012 7:16 AM
  • Thanks Spencer.

    I did try this once before but will try it again. My approach is to identify & get a list of, the drivers running when in safe mode then reboot and start normally and compare the running drivers with the safe mode driver list. Given disabling the non-Microsoft services in msconfig previously didn't affect the problemI'm thinking that it seems I should focus on the Microsoft side of things.

    One thing I've noticed is that running the LAN driver install is a short-term cure not a preventative. That is I need to wait for the high ISR/DPC problem to appear, run the LAN driver install and then the USBPort.sys problem is fixed and the ATAPort.sys problem is almost halved. If I run the LAN driver install in the first few minutes after login (before the high ISR/DPC counts start) then it makes no difference and the high counts will start as usual after a few minutes.

    I don't understand the driver install process well enough to identify possible reasons why this is. Can you offer any clues ?



    • Edited by GunnMan Friday, July 27, 2012 12:23 AM
    Friday, July 27, 2012 12:22 AM
  • Hi,<o:p></o:p>

    To check if this issue is caused by your LAN driver, first you should disable the network adapter(Network and sharing center->in the left pannel you would see change the adapter setting->right click your local area connection and disable it). Then let me know if the issue persist. Also try to use the third part driver
    manager to check your drivers. Such like Driverldentifier(free) or Driver Genius(not free).<o:p></o:p>


    Friday, July 27, 2012 7:55 AM
  • Hi Spencer,

    Disabling the LAN driver as you describe above made no difference as the ISR/DPC readings stayed high.

    As a check, I ran the Intel website driver update program which didn't find any later drivers for my PC.

    I then ran DriverIdentifier which only nominated the Realtek USB 2.0 Card Reader and Renesas USB 3.0 drivers as being out of date ( ... but not by much ... ) so I downloaded & installed updates for these. When I then checked the ISR/DPC readings they were low. However on reboot the readings were high again. I repeated the check, update, check, reboot, check, cycle several times and it was the same each time. As seen previously when I updated the LAN or audio drivers, the ISR/DPC count drops when I updated the card reader & USB 3.0 drivers but on reboot goes back to the high readings. On reboot Device Manager shows the latest version of the drivers is still installed.

    I'm still to try identifying which Microsoft drivers run in normal startup but which don't run in Safe mode.

    Monday, July 30, 2012 12:19 PM
  • I had an almost identical problem. Turned out that my DVD-ROM drive was causing some sort of driver issue. Not sure the cause, but while my machine powered down I removed the power from the drive. I powered it back up and this resolved my issue. The funny thing is LatencyMon showed almost identical results as what you've posted. I was going insane until I went back to the basics and removed each component from my machine, one device at a time.

    Removing power, or disconnecting the sata cable while powered on and in Windows yields no results. My machine had to boot into windows with the drive disconnected.

    Also, you may want to try using a different mouse and keyboard if that doesn't work. I once came across a mouse (I work in IT) that would prevent any *Dell* computer it was plugged into from powering on. Crazy stuff, anyway I hope my suggestion helps.

    Thursday, August 9, 2012 6:18 PM
  • SlimChaney,

    Thanks for the suggestion. I'll give that a try to-night.

    I've tried disabling the DVD in Device Manager and uninstalling it to let it reinstall but those didn't make any difference. I also tried keeping a disk permanently in the DVD after reading that worked for someone with a similar issue (again no success for me).

    I've tried physically removing all devices but I don't think I tried disconnectiong those directly attached to the mobo. I did try connecting it to different ports on the mobo which didn't solve the problem.

    I also have a Ritmo multi-card reader attached to the mobo so if disconnecting the DVD doesn't work I'll try disconnecting that.

    Thursday, August 9, 2012 11:05 PM
  • Disconnecting the SATA/USB cables for the DVD and then the card reader from the mobo when the PC was powered down and then rebooting didn't fix the problem. If anything it made issues worse as the CPU usage is back at 15% - 20% when "idle". In a 1 minute sample the ISR's for USBPort.sys = 17 million and for ATAPort.sys are 200,000. The CPU usuage is almost entirely attributed to "System Interrupts" in Resource Manager.

    With the DVD SATA cable disconnected hard pagefaults jumped to around 600 in the 1 minute. Before I disconnected it and after I reconnected it there were 0 - 5 in 1 minute.

    I haven't tried a different keyboard as yet.

    Friday, August 10, 2012 8:49 AM
  • I know this is a necro thread, but if anyone is still looking for a solution after all this, my problem was dirty power. I was plugged into a failing surge protector, and as soon as I replaced it, my latency was gone. Note, I also unplugged extraneous USB connectors from the motherboard while I had it unplugged, but as I was doing that I bumped the outlet and my monitor powered off from the protector. So I replaced it, powered up, and bam! After tearing my hair out for a week, running latencymon and replacing drivers, changing MSI registry keys, reinstalling windows, changing bios settings, audio settings, display and network settings, and whatever else, the crackling is totally gone. And to be clear, I had the same symptoms as other people on here, crackling under CPU load, high ISR and DCP counts for drivers, random but infrequent BSODs, so it definitely felt like I had a bad board after all that diagnosing, but nope!

    So if none of these other solutions have been able to help, try another outlet or surge protector.
    Thursday, March 26, 2020 6:56 PM