locked
Hyperlinks blocked in Outlook 2010 Beta RRS feed

  • Question

  • Envoronment: Win7 Home Premium 64-bit, Outlook 2010 Beta 32-bit.
    I get the message "This operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator." One such message allows me to open the message in a browser to get around the problem, another message doesn't give me that option. I have reported that to the Office Beta team. The real curious thing is that the same message on a Win7 Starter 32-bit and Win7 Professional 64-bit w/ same Outlook version and settings does not have the links blocked at all. Although it could be an Outlook problem, I am guessing it is a Win7 security problem. I found a post with a similar problem w/ Outlook 2007 but none of the suggested solutions solved my problem. I looked at my local security policy on my Win7 Professional system but couldn't find any settings that would effect this behavior. Any suggestions?
    Monday, December 7, 2009 9:17 PM

Answers

  • Hi, thanks for your information sharing! However, the Windows 7 forum is for general Windows 7 OS troubleshooting only. You’d better make sure to choose the appropriate forum before submitting an inquiry in the future. For your information, please submit the thread to Office 2010. Thanks for your understanding.

    • Marked as answer by Andy Song Monday, December 14, 2009 10:31 AM
    Tuesday, December 8, 2009 6:09 AM

All replies

  • Never mind, I found the answer. The computer came with Google Chrome pre-installed which I had uninstalled. The uninstall left some file associations screwed up. I found various solutions but the best one is to use Control Panel-Default Programs to set IE as the default browser. That fixes the associations. You can then switch to a different browser if you want.
    Monday, December 7, 2009 9:58 PM
  • Hi, thanks for your information sharing! However, the Windows 7 forum is for general Windows 7 OS troubleshooting only. You’d better make sure to choose the appropriate forum before submitting an inquiry in the future. For your information, please submit the thread to Office 2010. Thanks for your understanding.

    • Marked as answer by Andy Song Monday, December 14, 2009 10:31 AM
    Tuesday, December 8, 2009 6:09 AM
  • If you reread the original post, I believed the problem to be with Win7 security, not Office 2010, which is why I posted it where I did. If you reread my followup you can see that the problem was with neither; it was caused by a bad uninstall script for Google Chrome. In any case posting it to Office 2010 was no more appropriate or inappropriate than where I posted.
    Tuesday, December 8, 2009 2:56 PM
  • How do you know that this is not a Windows 7 problem? If it is a problem with hyperlinks, it could be an Outlook problem, or a Win 7 problem, or an IE problem.
    Saturday, April 3, 2010 12:55 AM
  • Hi,

    I'm reading this thread because I am having the same problem with my new windows 7 hp laptop, using outlook 2010 beta. Google Chrome is my default browser - and i want to keep it that way.

    When I click on a hyperlink in Outlook Beta, google chrome browser comes up but there is an error message: "Aw Snap" - something went wrong - click here for information - the problem is nothing works.  the browser is like dead in the water.

    2 work arounds I've found:

    1.   right click and choose "copy Hyperlink" in your outlook 2010 beta email - then open up google chrome separately and paste the link into the address bar and go.  that works fine - but is a little cumbersone.

     

    2.  Interestingly - i've just discovered that if Google Chrome is already open - then the hyperlinks DO work.  So i think the better workaround is just to open up google chrome before you read your email messages - so when you click on the email hyperlinks they work fine.

     

    As far as why the problem exists - I'm not a techie - but it suggests to me there is a problem with the signal to open up the browser originating either from outlook or the windows 7 operating system (i suppose someone could install outlook 2010 beta on their xp to see if same problem occurs).  As the browser is opening - the connection functionality to the internet must be disabled - because google chrome won't work at all - you have to shut it down and open it separately.  I hope i've expressed this thought clearly enough - some process is deliberately disabling the function of google chrome when it is opened from within outlook 2010 beta hyperlinks.

     

    hope this helps.  

     

    Ps: Andy - this is a good thread, and the only one i've found helpful in my (brief) search on google - when the solution is found you could post the answer and refer future inquiries to the office 2010 help forum if that turns out to be more appropriate.  IMHO.

    Friday, May 14, 2010 3:13 AM
  • Exactly the same situation as makahajo - anyone yet found a solution?   Outlook 2010 Beta will not open links directly (you get the 'Aw Snap' page) unless Chrome is already open.  Very annoying!
    Tuesday, June 22, 2010 8:20 AM
  • I have Windows 7 and Outlook 2010.  I was having same problem with hyperlinks.  I found that just putting Internet explorer as your default program didnt work.  You need to go into "Choose Defaults for this Program" and then chose ALL of the file associations.

     

     

    Tuesday, July 6, 2010 1:13 PM
  • I have IE 8 and also had Google Chrome which I uninstalled yesterday...now I can't open hyperlinks in Outlook 2010...I get error  "This operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator." so I followed your advice and set IE to be the default in control panel and to "Choose Defaults for this Program" and then chose ALL of the file associations"....still not working....still getting same error...now what? Any other suggestions?
    Friday, July 9, 2010 3:36 PM
  • I had this same problem with Win7 64bit and Outlook 2010. Fixed it with setting IE as the default browser (in the Default programs) and setting Chrome back to default.

    It has something to do with the .lnk association, because setting that to Chrome makes this work also. BUT I don't recommend setting that association, otherwise you'll end up using Unassoc.exe :)

    Friday, August 20, 2010 8:14 AM
  • You pompous ____, answer his question...
    Wednesday, September 22, 2010 10:00 PM
  • Why has this thread been flagged as answered when I don't see a solution here? I have been happily using Outlook 2003 on Windows 7 64bit Pro since April with no problems. Since I use Internet Explorer all the time I uninstalled Google Chrome yesterday. Now I get the "This operation has been canceled due to restrictions in effect on this computer. Please contact your system administrator." message when I click on any hyperlink in an email. I have reset Internet Explorer, checked file associations, repaired Office 2003, and looked at every security related option I could find and have been unable to fix the problem. From what I have read it would seem that Google Chrome screws up some settings when uninstalled. I have spent hours on this problem and having been in the IT industry for 40 years find Windows 7 the most frustrating version of Windows to work with. The security is over the top for power users and I have a very strong feeling from the message displayed, and the fact that nothing tried so far has worked, that this problem is related to some security issue with Windows 7. Is there anyone that has an answer to this problem or can point me in another direction other than resetting Internet Explorer again?
    Saturday, September 25, 2010 5:38 PM
  • It has been ages since I started this thread (and got my butt chewed out by Mr. Song for doing so) but what worked for me is in the third post post in this thread. After uninstalling Chrome, did you set IE to be the default browser via Control Panel-Default programs in order to fix the file associations? If that fails, another thing that might work is to install the IE 9 Beta which I hope would make things right but I really don't know that for a fact.

    Saturday, September 25, 2010 9:07 PM
  • I found this in another post on the same issue (I installed, then uninstalled Chrome, and had the same issue):

    http://www.slipstick.com/problems/link_restrict.htm#reg2

    The problem is with the Chrome uninstall script - you need to update the registry.

    Wednesday, October 13, 2010 9:06 PM
  • I've read all of this and tried the remedies but to no avail. I too had Chrome and uninstalled it. I also tried Explorer 9 Beta and uninstalled it. I'm now back to Explorer 8, have windows 7 64bit and am running Office 2010 Professional. I still keep getting the "This operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator." message. Quite frustrating! John
    Sunday, October 31, 2010 5:38 PM
  • Dear All

    i just try the following solution and all thing are working perfectly,  by making some changes to your registry keys (please only edit reg keys if you are familiar/comfortable with your system). Thanks to 'Nakro' and 'nondescript' for their helpful instructions provided below!

     

     Restore registry settings in the User Profile:

    1. Click Start, click Run, type Regedit in the Open box, and then click OK.
    2. Locate the following subkey: HKEY_CURRENT_USER\Software\Classes\.html
    3. On the File menu, click Export.
    4. In the Export Registry File dialog box, enter HKCU_Classes_HTML_Backup.reg and click Save.

    Note: This will create a backup of this registry key in the My Documents folder by default.

    5. Right click the (Default) value for the .html key and select Modify...
    6. Change the value from "ChromeHTML" to "htmlfile"

    Repeat steps 1-6 for .htm and .shtml keys if they exist, remember to change the name of your backup file for each export.

    Regards

     

    Anas El_Wahdan

    • Proposed as answer by Lundq Sunday, December 12, 2010 9:06 PM
    Friday, November 12, 2010 2:13 PM
  • Guys,

    I was having the same problems with Outlook 2010 and none of the supplied solutions seemed to work for me.  So, I reinstalled Chrome and took a look to see what it hijacked.  It looks like you need to re-associate the following extensions with IE after you remove Chrome:

    .htm

    .html

    .shtml

    .xht

    .xhtml

    Once I did that, removed Google Chrome, and restarted Outlook, everything worked like a charm.

    Josh

    Monday, December 6, 2010 3:24 PM
  • Ta-daaaah! Thanks, Anas; finally a solution that worked. I thought this was a Win 7 issue. I have a Norwegian language Win 7 Ultimate with Outlook 2010 (64-bit, version 14.0.5128.5000). What puzzled me for long, and made me suspect a OS security bug, was that Google Chrome is not installed. But it seems that I hace tried it out sometime, although I have forgotten on which computer. Obviously this one, then, since I hope nothing else can edit my registry to "ChromeHTML" in the subkey mentioned by Anas? I would like to point out that Microsoft Fix It has a fix for the problem discussed here, although (of course) not for my version/language.

    Sunday, December 12, 2010 9:13 PM
  • All - thanks for the suggested fix, this seems to do the trick.  To be specific, should all extensions be changed from "ChromeHTML" to "htmlfile", or should the new change match the extensions - "htmfile", "htmlfile", "shtmlfile", "xhtfile", and "xhtmlfile"?

    Thanks, Fred

    Monday, December 13, 2010 2:39 PM
  • Thank you to everyone for your kindness and help, except Andy.  Registry was still under Chrome.  Very frustrating.  But I think it is OK now.  Happy Holidays to you all!
    • Proposed as answer by gordonrl Sunday, January 2, 2011 7:00 PM
    Monday, December 13, 2010 11:53 PM
  • Reset Defaults :::

    Control Panel
    Default Programs
    Set Program Access
    Custom.
    Explorer
    OK


    Worked For Me.. on Outlook 2007 & Word Hyperlinks.
     
     Probably in Office / Outlook 2010 ALso
    Simple Fix after all the Many Suggestions..
    Sunday, January 2, 2011 7:02 PM
  • ensuring IE is the default program and all file associations are set to IE didn't fix it for me.  I had to manually edit the reg as noted above.  You would think Microsoft would have IE do this when it realizes it isn't the default program anymore and asks you if you want to set it as default again.  If mine did, I missed it.  At least, they should have a tech bulletin on this as it is a known issue and it would make sense to at least add it to outlook's help file to make it easier to find instead of having to Goggle it!  After manually changing my reg, I noticed that there might be an easier way to change them...  under 'associate a file type or protocol with a program' you can click on the heading 'current default' and scroll to Goggle Chrome and access the reg entries that way without having to go in and manually change the keys.  Since I already changed mine, I can't verify this works but I would assume so.

    Win7 64 bit

    Office Home and Business 2010

    IE9 beta 

    Good Luck.

    • Proposed as answer by vizacar Thursday, February 24, 2011 1:45 PM
    Thursday, February 24, 2011 1:29 PM
  • Anas, thank-you very much, finally a solution that worked!!!

    Your instructions were very clear, thanks for your consideration!

    PS, Fred, i changed every instance of ChromeHTML to HtmlFile, not by their respective registry extension

    and i only changed the 3 that Anas suggested, .html, .htm, .shtml   all is working great immediately after the change!!!

    Saturday, February 26, 2011 12:24 AM
  • Anas, thank-you very much, finally a solution that worked!!!

    Your instructions were very clear, thanks for your consideration!

    PS, Fred, i changed every instance of ChromeHTML to HtmlFile, not by their respective registry extension

    and i only changed the 3 that Anas suggested, .html, .htm, .shtml   all is working great immediately after the change!!!


    Did exactly as above and all works great, so thanks very much to Anas and Zion7 and all other contributors!!!!

     

    n.b I did notice that Chrome was mentioned in the xht xhtml extensions but as advised did not bother to change these. I don't suppose anyone knows what if anything they may affect?

    Friday, April 1, 2011 9:10 AM
  • I would bet a Dunkin Donuts coffee that you recently downloaded Google Eart. Included is the Chrome HTML which automatically changed your PC's HTML settings. You have to go to start, run "Regedit" and modify Chrome html settings to html file. It works!  It took me 6 hours to figure thius one out.

    Saturday, June 18, 2011 1:46 PM
  • Your answer was perfect, did the trick!!! Thanks.
    Sunday, July 3, 2011 4:13 PM