locked
Outlook in cached mode putting mail in Outbox when sent from third party app RRS feed

  • Question

  • I'm running Outlook 2013 in a 2008 R2 terminal server environment.  Since we're in the process of changing over to Office 365 from on prem Exchange, Outlook is configured to run in cached mode since our location is a different country to where the Office 365 datacenters are.  This part is working fine.

    The issue is that when Outlook is in cached mode and not running, but a user tries to share something via email that makes use of Outlook (such as Adobe Reader or Word) the email sits in the outbox until they manually open Outlook and click send and recieve. If Outlook is running at the time then the share feature in other apps sends emails just fine.

    If I switch Outlook back to Online mode and disable cache mode then this function works perfectly.  I'd like to keep cached mode on however as Outlook is very sluggish for those migrated to 365 when using online only mode.

    Thursday, September 14, 2017 5:11 AM

All replies

  • Hi Obraik,

    >> The issue is that when Outlook is in cached mode and not running, but a user tries to share something via email that makes use of Outlook (such as Adobe Reader or Word) the email sits in the outbox until they manually open Outlook and click send and recieve.

    As per the issue that emails sent from other app won't send when Outlook is closed, this is the expected behavior as Outlook need to be running when sending email from other programs. 

    Generally, the messages will be sent by Outlook the moment Outlook is opened. In your situation, please go to File > Options > Advanced, make sure the checkbox of Send immediately when connected is selected:

    Hope this can be helpful.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, September 15, 2017 8:18 AM
  • Hi Obraik,

    >> The issue is that when Outlook is in cached mode and not running, but a user tries to share something via email that makes use of Outlook (such as Adobe Reader or Word) the email sits in the outbox until they manually open Outlook and click send and recieve.

    As per the issue that emails sent from other app won't send when Outlook is closed, this is the expected behavior as Outlook need to be running when sending email from other programs. 

    Generally, the messages will be sent by Outlook the moment Outlook is opened. In your situation, please go to File > Options > Advanced, make sure the checkbox of Send immediately when connected is selected:

    Hope this can be helpful.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Is that only true when Outlook is in cached mode?  Because Outlook will send the email while closed just fine if cached mode is disabled and sending from a third party app.

    I did make sure that option in your screenshot was enabled.

    Friday, September 15, 2017 8:35 AM
  • Hi Obraik,

    Sorry for the negligence in my initial reply and yes, this is only happening in Cached mode. 

    Regarding the outbox part, how about waiting for several minutes to see if the message can be sent out as expected? Is there a Send/Receive progressing bar at the bottom when opening Outlook?

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, September 15, 2017 8:53 AM
  • We have a similar configuration - Outlook 2013 on Windows Server 2008R2, Cached Mode is active (1 Month Cache). Server side is Exchange Server from Microsoft (Office365).

    Unfortunately the mail will not be sent until Outlook is opened even if the "Send immediately" option is activated.
    It looks like that setting is ignored and the connection to the Microsoft mail server simply is not established in that case before Outlook is closed again in the background.

    I also added that setting (send mail immediately, value 1) to HKCU\SOFTWARE\Microsoft\Office\15.0\Outlook\Options\Mail but it still has no effect.

    Do you have any solutions for that?

    Thursday, April 5, 2018 11:29 AM