none
DHCPMGMT.MSC in Remote Server Administration Tools (RSAT) won't remember DHCP server

    Question

  • I'm running Remote Server Administration Tools (RSAT) on Windows 7 Professional 64-bit and I've noticed that when I run the DHCP Management tool (DHCPMGMT.MSC) and I add our DHCP Authorised server then close the console, it forgets the DHCP server and I have to re-select it next time I use the console. 

    On the other hand, the DNS console remembers that I've used a particular DNS server even after I close the console.

    Wondering why the DHCP Management console is so forgetful?

    Thursday, November 4, 2010 1:19 AM

Answers

All replies

  • Make sure you have the latest version of RSAT, if needed uninstall and reinstall.  The link below will provide more information on this.

     

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=7d2f6ad7-656b-4313-a005-4e344e43997d 


    Network Systems Engineer * Zvetco Biometrics * Windows Server 2008 R2 * Core2 6600 @ 3.30GHz * 16 GIGS RAM * NVIDIA 9400GT * ** " Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, November 4, 2010 2:06 PM
  • I believe I do have the latest version installed (I only downloaded and installed it fresh on my new laptop about 3 months ago).

    Does anyone else on Windows 7 64-bit with RSAT notice this same behaviour with DHCP (forgetting the server that you have added to the console)?  Or is it just my install?

    Thursday, November 4, 2010 9:16 PM
  • Hi,

    This is by design.

    Monday, November 8, 2010 8:29 AM
    Moderator
  • OK, so I expect then that everyone is seeing this, including yourself.  That's fine ... but I am curious ... why would they do this? ... and why don't they do the same thing with the DNS management applet? ... sometimes the lack of consistency with Microsoft software really, really annoys me.
    Monday, November 8, 2010 9:21 PM
  • Where there's a will there's a way. Here's what I did because it annoyed me so much to have to re-add the server each time.

    1. Open the DHCP Managment console in author mode using the following command:

    mmc /a c:\windows\system32\dhcpmgmt.msc

    2. Add the server(s) you want to see

    3. Click File > Save As...

    4. Save the .msc console in the c:\windows\system32\ folder with a unique name like dhcpmgmt2.msc (don't use the old name: dhcpmgmt.msc)

    5. Edit your adminstrative menu shortcut by:
           a. Browsing to Control Panel > Administrative Tools (you may have to change the view to small icons to see all items).
           b. Right click on DHCP > Choose Properties
           c. Change the Target to:

    %windir%\system32\dhcpmgmt2.msc 

    (be sure you point it at whatever you named the new DHCP console my example was dhcpmgmt2.msc)

    Cheers-
    Josh

     

    • Proposed as answer by JoshBell88 Thursday, March 24, 2011 11:25 PM
    • Unproposed as answer by JoshBell88 Thursday, March 24, 2011 11:28 PM
    • Proposed as answer by JoshBell88 Thursday, March 24, 2011 11:28 PM
    Wednesday, March 9, 2011 1:00 AM
  • Frosty - I am unable to get Windows 7 Pro to connect to the DHCP Administrative Tool.  It finds the authorized server and adds the server to the console.  Once I click on the console it gives me an error. "Cannot find DHCP server"

    "The DHCP server you specified cannot be located. The DHCP server might be down, there may be network problems, or the DHCP service might not be installed".

    "The error was: The authentication service is unknown."

    The strange thing is, I have another computer running Windows XP Pro sitting directly next to my Windows 7 Pro computer.  The XP machine is able to connect to the DHCP console fine.  The Windows 7 machine cannot.  I have gone into the registry and added the LMCompatability and set the value to 1, I have also ensured that the Winsock and Winsock2 registry permissions grant my user full access.

     

    Was there anything else you did to get this to work or did it work directly after the installation of the DHCP component under the Administrative Tools?

    Friday, September 16, 2011 9:31 PM
  • Mine does the same thing. I am interested in trying the solution presented by JoshBell88 below.
    Wednesday, September 28, 2011 2:16 PM
  • Thanks for the work around! I too was annoyed at having to do this but wasn't so annoyed to modify the shortcut.
    Wednesday, September 28, 2011 2:44 PM
  • This is by design ... flaw ;-)
    Thursday, October 23, 2014 5:34 PM
  • Hi,

    you can add a params in the shortcut to open a server by default.

    add "/computername your_dhcp_server_name" in the shortcut target.

    Ludovic.

    • Proposed as answer by ReckyX Monday, February 5, 2018 8:30 AM
    Tuesday, January 10, 2017 10:28 AM
  • I am using RSAT on W7 Ent x64. I opened the DHCP management in Author mode, added my DHCP servers and saved with a new name. I close and open the saved MMC and my servers are listed but I can't manage them.

    How do I create, save, and use the RSAT DHCP MMC without having to add my servers every time?

    I just want to manage my DHCP without having to login to the DC or add my servers. That is the whole purpose of RSAT.

    Friday, April 7, 2017 3:02 PM