none
SCCM 2012 Reporting Services Permissions Issue.

    Question

  • Hello all.  Currently I am getting an SCCM 2012 server ready for production.  I have everything working as expected except for the reporting services feature.  The SQL backend is SQL Server 2008 R2 CU6.  For testing purposes I have given my SMSReports users full admin access to the reporting site.  When I login to the reporting site I can get reporting to work temporarily by checking "Impersonate the authenticated user after a connection has been made to the data source".  However, SCCM detects the changes and reverts it back.  Is there an area inside SCCM that I should be looking at to make this change?

    Thanks in advance,

    Matt

    Friday, September 14, 2012 6:20 PM

Answers

All replies

  • You only need to add the user to the site system role in the ConfigMgr. console. After that, Configmgr. will automatically grant the correct permission in SQL. When I have found a few times, is that I need to delete the account in the Console, delete it in SQL and create it Again.


    Kent Agerlund | My blogs: blog.coretech.dk/kea and SCUG.dk/ | Twitter: @Agerlund | Linkedin: Kent Agerlund | Mastering ConfigMgr 2012 The Fundamentals

    Friday, September 14, 2012 8:29 PM
    Moderator
  • I have also observed issue with SSRS permissions not being applied correctly by CM for administrative users and having to delete and add admin users again in CM (didn't delete in SQL) even after removing and re-adding reporting services point role.  This was experienced in RTM, have not re-tested with SP1.

    Wednesday, March 20, 2013 12:16 PM