none
Create Protection Group Hyper-V Virtual Machines Not Listed RRS feed

  • Question

  • Hello,

    We are in the process of testing DPM 2012 R2 and we are trying to backup our Hyper-V virtual machines on both cluster hosts and stand-alone Hyper-V hosts.  We have deployed the DPM agent to all cluster hosts and the stand-alone hosts, but when we go to create a protection group, we do not see Hyper-V Virtual Machines listed under "HyperV".  We are expecting Virtual Machines to show up as shown in Step 7 of this guide: http://blogs.technet.com/b/kevinholman/archive/2013/11/07/dpm-2012-r2-quickstart-deployment-guide.aspx.  We have DPM 2012 R2 UR4 installed and Hyper-V role is enabled on the DPM server.

    Is there something extra we need to do or something we are doing wrong?

    Thank you.

    Thursday, November 20, 2014 3:36 PM

Answers

  • A couple of things to check..

    Check that Windows Server Backup is installed on host

    Check that there is no restart pending for  source ( management --> Agents --> Agent status

    Use "Clear cache" button in Protection Group wizard to force update of source info


    Gleb.

    Thursday, November 20, 2014 9:17 PM

All replies

  • A couple of things to check..

    Check that Windows Server Backup is installed on host

    Check that there is no restart pending for  source ( management --> Agents --> Agent status

    Use "Clear cache" button in Protection Group wizard to force update of source info


    Gleb.

    Thursday, November 20, 2014 9:17 PM
  • Gleb,

    Thank you for your help.  For our cluster, we realized we weren't seeing any VM's under the Cluster Node because an agent was not installed on our of the Hyper-V hosts in the cluster.  As for the stand-alone Hyper-V host and the cluster node listing within the "Create New Protection Group" wizard, it looks like MOST of the VM's have the "Backup Using Child Partition Snapshot" option, but no longer show as "Online" or "Offline".  I believe this is due to the way the Hyper-V backups are done w/ DPM which was changed either in R2 or one of the Update Rollups.  

    Friday, November 21, 2014 2:49 PM