locked
Sharepoint Anonymous problem when enter IP address and Servername RRS feed

  • Question

  • hi,

    i had created one web application with port 1234  and site collection. then i extend the web application to internet zone with port 80. And i had set the enable anonymous users. When i key in the server name in web browser, i can able to access the site(public site) without login in... when i key in the ip address in the web browser, the login box prompt out to ask for login, after login it will go to intranet site, not internet site http://servername:1234/....(intranet site)..

    may i know how to solve this???
    Thursday, July 9, 2009 10:48 AM

All replies

  • Are you trying to access the site from a remote machine?  I am a little confused with your statement. To my understanding you are getting a login pop up which you should'nt be getting!!!

    Try this out....

    Go to the Internet explorer -> Tools -> Internet Options -> Security -> Click on Custom Level Button. It opens a new pop up. Scroll down to the bottom.

    Check if Prompt for Username and Password is selected

    Hope this helps :)

    • Edited by Mike Walsh FIN Thursday, July 9, 2009 11:46 AM Thanks ----------------------------------------------------------- If this post helps you, please mark it as helpful or resolved. please don't request that people mark your posts. Let them do it but don't have it in your sig
    Thursday, July 9, 2009 11:32 AM
  • hi,

    i'm not using remote machine... i'm in my server now

    below is the step i create my WCM web portal...

    1. create web application from creat or extend a web application page. (anonymous access no, port 1234)

    2. after created page, i click on the link to create site collection, http://servername:1234

    3. i go to extend a web application page, after i click on extend an existing web application, i select http://servername:1234 web application, then i create a new IIS web site with port 80 and in load balance url, i select internet

    4. i go to authentication provider link, i click on internet zone, then i select enable anonymous access and click save

    5 go to policy for web application and add admin user with full control for default and internet zone(all zone)

    6. click on http://servername then login in pop up, after login, displayed default page, i click on enable anonymous access and select entire web site..

    7. so now when i click on http://servername then page only display sign in on top

    8. when i go to http://servername:1234, there is able to amend page with site action

    9. when i enter http://ip address(eg http://10.11.11.11) then login pop up, after i login, it showed http://servername:1234/Pages/default.aspx

    I thot when i enter ip address, it go to http://servername and without login pop up, cos i already using port 80.

    Thanks.

    Thursday, July 9, 2009 11:47 AM
  • Have you tried this?
    Internet explorer -> Tools -> Internet Options -> Security -> Click on Custom Level Button. It opens a new pop up. Scroll down to the bottom.


    It is always better not to touch the port 80, as it is used by the default website. Use a different port number and if required create a host name for the same.

    After the the 7th point that you mentioned, open the internet site Site Actions -> Site Settings -> Advanced Permissions -> Settings.

    Here you find anonymous option. Please enable that and test again

    Thanks
    Sridhar
    • Edited by SridharV Thursday, July 9, 2009 11:55 AM Modified the signature
    Thursday, July 9, 2009 11:54 AM
  • >Edited bySridharV 9 minutes agoModified the signature

    Thanks Sridharv !

    Mike  (Moderator)

    WSS FAQ sites: http://wssv2faq.mindsharp.com and http://wssv3faq.mindsharp.com
    Total list of WSS 3.0 / MOSS 2007 Books (including foreign language) http://wssv3faq.mindsharp.com/Lists/v3%20WSS%20FAQ/V%20Books.aspx
    Thursday, July 9, 2009 12:06 PM
  • hi,

    i deleted the web application.. and try to recreate it.... problem as same...

    when enter ip address, it will go to default zone page, wil not go to internet zone page...

    i have to use port 80, because it is the port that when user key in www.xxx.com, then i will redirect them to our IP address...

    Thanks.
    Thursday, July 9, 2009 12:36 PM
  • Can you test this by removing any additional web parts which you might have in the home page?
    Friday, July 10, 2009 7:26 AM