none
SCCM UDI Issue RRS feed

  • Question

  • Hi all,

    Is there any guidance for client fresh installation with SCCM 2012+MDT+UDI? I cannot find more info about this. Currently, I encounter a problem about UDI user state capture issue. I have create a TS using client task sequence template and set the capture task in UDI. But the TS never run the capture user state task during deployment. The user state always failed.

    Do I miss something?

    Thanks.

    Saturday, June 1, 2013 8:02 AM

All replies

  • UDI is great, but it doesn't actually do any of the work.  It just sets Task Sequence variables based on the Panes and what is selected.  The logic of the Task Sequence is still followed afterward and if you didn't modify any steps or change Conditions based on values you got back from UDI, then nothing in the Task Sequence would change.  Please ensure that the Step in your Task Sequence that isn't firing (in your case a USMT Capture it sounds like) is accessible by the default Condition logic AND whatever you are setting in UDI to make it happen.

    Basically, if you inject UDI into the process and collect a bunch of custom variable information, but never use that information to determine Conditions for Tasks, then the UDI didn't actually modify the workflow of the Task Sequence at all.  It's a combination of the two actions: using UDI and collecting responses from the user, then using the values you got from it in later steps as either scripts or conditions.


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Saturday, June 1, 2013 2:16 PM
    Answerer