locked
problem in sending email in sharepoint RRS feed

  • Question

  • Hi

    I have configured smtp server settings in central admin in operations tab.

    But emails are not going while adding any users to people and groups or adding any designer workflow to send emails.

     

    Thanks

    Keerthi

    • Changed type Mike Walsh FIN Tuesday, March 15, 2011 6:54 AM q
    • Moved by Mike Walsh FIN Tuesday, March 15, 2011 6:55 AM more admin than workflow (From:SharePoint - Workflow (pre-SharePoint 2010))
    Tuesday, March 15, 2011 6:42 AM

Answers

All replies

  • Hi Keerti

    The information you have provided is very limited to Troubleshoot.

    Also you can prefer the below mentioned post which resembles the same issue as yours.

    http://social.msdn.microsoft.com/forums/en-US/sharepointworkflow/thread/2a0d8f1e-a481-42da-8d93-ec2c33af7c30/

    http://social.msdn.microsoft.com/forums/en-US/tfssetup/thread/895b4f3f-63d8-4b5a-888a-6eb13798b8b9/

     

     


    Warm Regards Vishal Joshi| Senior SharePoint Administrator| http://sharepoint2007administration.blogspot.com/
    Tuesday, March 15, 2011 8:44 AM
  • Hi Vicky

    When adding users to a project site

    The following is the message shown

    "The user or users have been added successfully, but there was an error in sending the e-mail message. The server may not be set up correctly to send e-mail"

    Thanks

    Keerthi

    Tuesday, March 15, 2011 9:15 AM
  • Hi Keerthi

    Is your SMTP Server Configured on the same server where you have your SharePoint Server Installed, Or is it on different Server?

    Also We need to check whether you have properly allowed relay for the MOSS
    server, please perform the following steps:

    1. Logon locally to the MOSS server.

    2. From Start-->Run-->cmd.

    3. On the command line window, enter the command: telnet smtpservername(or
    its IP address) 25. (For example: telnet smtphost 25 or telnet 192.168.0.1
    25).

    4. Type "hello" (without the quotation marks) and press ENTER.

    5. Type "mail from:email@domain.com" (without the quotation marks) and
    press ENTER.

    6. Type "rcpt to:youremail@yourdomain.com" (without the quotation marks)
    and press ENTER.

    7. Type "Data" (without the quotation marks) and press ENTER.

    8. Type "Subject:This is a test" (without the quotation marks) and press
    ENTER twice.

    9. Type "Testing" (without the quotation marks) and press ENTER.

    10. Press ENTER, type a period (.), and press ENTER.

    11. Type "quit" (without the quotation marks) and press ENTER.

    If we can successfully perform the above steps and receive an email, then
    the relay was properly set on the SMTP server. If the above steps fail, you
    may want to check with your Exchange Administrator (if you're using
    Exchange) and re-allow relays for the WSS Server's IP address.


    Warm Regards Vishal Joshi| Senior SharePoint Administrator| http://sharepoint2007administration.blogspot.com/
    Tuesday, March 15, 2011 10:27 AM
  • Hi Vicky

    Thanks for your reply

    But command Prompt is not recognising telnet command.

     

    Thanks

    Keerthi

     

    Tuesday, March 15, 2011 11:45 AM
  • Hi Keerthi Did you ran that Command as an Administrator? If Not, Kindly Try to Open Command Prompt as an Administrator. Then Run the Commands Thanks
    Warm Regards Vishal Joshi| Senior SharePoint Administrator| http://sharepoint2007administration.blogspot.com/
    Tuesday, March 15, 2011 12:22 PM
  • Hi keerthi,

    Please check the SMTP settings:
    1. Set Authentication to Anonymous access.
    2. Select All except the list below in Relay restrictions.
    3. To accept relaying from one or more specific servers, you also need to add computers/domains in relay list.
    For the details, please go to
    Configure outgoing e-mail settings (SharePoint Server).

    If this settings all correct, please try to trouble shooting your SMTP follow this great blog.
    SharePoint 2007 Outgoing E-mail Troubleshooting Tips

    Best regards,
    Emir

    • Marked as answer by David HM Wednesday, March 23, 2011 7:06 AM
    Thursday, March 17, 2011 10:03 AM