locked
Error integrating a reporting services report RRS feed

  • Question

  • I am trying to integrate a SSRS report in a PPS dashboard and get this error:

    "This report requires a default or user-defined value for the report parameter"....

    The report has a default value bound to the parameter in SSRS. I have to invoke the report with no values for this parameter.

    Any ideas how I can get past this ?

    BTW - Reporting Server running in Integrated Mode and the report runs fine in SP and SSRS Preview mode.

    thanks

    Naveen

    Tuesday, April 27, 2010 2:46 AM

Answers

  • The report works just fine in SSRS preview mode and from within MOSS.

    I figured out the problem - apparently, PPS has a problem deciphering default values defined as constants within the report variable declaration. So, I changed the default value in SSRS to an expression with the same constant value and it worked !

    thanks

    Naveen

    • Marked as answer by Naveen Das Thursday, April 29, 2010 5:06 AM
    Tuesday, April 27, 2010 3:18 PM

All replies

  • This is not a PPS error.. correct me if I am wrong but I think the error is from SSRS.

    Have you tried viewing report without using PPS?

     

    Tuesday, April 27, 2010 8:55 AM
  • The report works just fine in SSRS preview mode and from within MOSS.

    I figured out the problem - apparently, PPS has a problem deciphering default values defined as constants within the report variable declaration. So, I changed the default value in SSRS to an expression with the same constant value and it worked !

    thanks

    Naveen

    • Marked as answer by Naveen Das Thursday, April 29, 2010 5:06 AM
    Tuesday, April 27, 2010 3:18 PM