locked
Exchange2007 - Shared mailbox as primary for multiple users RRS feed

  • Question

  • Our management has set the policy that members from the sales department can only have acees to the mailbox of the department.
    So I've created a shared mailbox named "Sales", gave full access rights to the security group "SalesBE" and put all the users from that department into this group.
    How do I set this shared mailbox as their primary e-mail address. When I tried to do this in the Exchange Management Console I could only select one user to have this mailbox as his primary e-mail address and when I tried to assign it to a second user I got the message that I had to choos e another address because this one was already assigned.Can anyone help me with this ?

    regrads,

    Dirk.

    Monday, July 16, 2012 9:58 AM

Answers

  • Hi,

    If you open the shared mailbox as the primary mailbox for each user (and their personal mailbox as the secondary) most if not all of your issues will be solved.

    Leif

    • Marked as answer by DirkVW62 Monday, July 16, 2012 12:04 PM
    Monday, July 16, 2012 11:13 AM
  • Agreed, as they have full mailbox access already they should log in to the shared mailbox first and connect to their own as an additional.

    Steve

    • Marked as answer by DirkVW62 Monday, July 16, 2012 12:04 PM
    Monday, July 16, 2012 11:17 AM
  • Hi,

    This technet article explains how to create an Outlook profile:

    http://support.microsoft.com/kb/829918

    You will need to do this on the terminal server if that is what the users are connecting to.

    Leif

    • Marked as answer by DirkVW62 Monday, July 16, 2012 11:59 AM
    Monday, July 16, 2012 11:46 AM

All replies

  • You cannot use an email address in more than one user. If you wish to see all emails addressed to that group in one mailbox, you can set forwarding address on those user's mailbox to forward to this shared mailbox
    Monday, July 16, 2012 10:11 AM
  • Hi

    You should rather configure Send-as for those users to that mailbox: http://technet.microsoft.com/en-us/library/aa998291(v=exchg.80).aspx

    Steve

    Monday, July 16, 2012 10:14 AM
  • So, I've created individual mailboxes for each member of the group (I'll have to do some explaining to the management on this one !); set the forwarding option on each individual mailbox; granted send-as rights to the shared mailbox and added the shared mailbox as an additional mailbox to each member.
    I've done a test with one of the users (who's on holiday right now, so I can abuse his account without getting bad reactions ) and sned myself an e-mail from the shared mailbox (added the from option in the outlook client). So far, so good.

    I still have the following issues :

    - Each member has to choose the 'send from' option manually. Can this be set as a default ?

    - When I send an e-mail from the shared mailbox it looks like it comes from the "shared user" but the e-mail is stored in the sent folder from the member who has sent it. Others members cannot see that an e-mail has been sent from the shared mailbox.

    - I can reply to the e-mail that has been sent but it doesn't show in the shared inbox although I've granted full access to each member.
    Only whe I do an explicit open of that mailbox I can see the reply that I've sent.

    Dirk.

    Monday, July 16, 2012 11:04 AM
  • - Each member has to choose the 'send from' option manually. Can this be set as a default ?

    You cannot set it as default but one time you sent the option to Show From then each time a new message window is opened it opens with From added

    - When I send an e-mail from the shared mailbox it looks like it comes from the "shared user" but the e-mail is stored in the sent folder from the member who has sent it. Others members cannot see that an e-mail has been sent from the shared mailbox.

    http://social.technet.microsoft.com/Forums/en/outlook/thread/4d38fdb9-e85b-4eac-b1b1-553e01bf168e

    - I can reply to the e-mail that has been sent but it doesn't show in the shared inbox although I've granted full access to each member.
    Only whe I do an explicit open of that mailbox I can see the reply that I've sent.

    Can you please elaborate this?

    Monday, July 16, 2012 11:10 AM
  • Hi,

    If you open the shared mailbox as the primary mailbox for each user (and their personal mailbox as the secondary) most if not all of your issues will be solved.

    Leif

    • Marked as answer by DirkVW62 Monday, July 16, 2012 12:04 PM
    Monday, July 16, 2012 11:13 AM
  • Agreed, as they have full mailbox access already they should log in to the shared mailbox first and connect to their own as an additional.

    Steve

    • Marked as answer by DirkVW62 Monday, July 16, 2012 12:04 PM
    Monday, July 16, 2012 11:17 AM
  • - Each member has to choose the 'send from' option manually. Can this be set as a default ?

    You cannot set it as default but one time you sent the option to Show From then each time a new message window is opened it opens with From added

    What I meant was : Can I set the shared mailbox as the default 'reply-to' address ?

    - I can reply to the e-mail that has been sent but it doesn't show in the shared inbox although I've granted full access to each member.
    Only whe I do an explicit open of that mailbox I can see the reply that I've sent.

    Can you please elaborate this?

    I've added the shared mailbox as an additional mailbox to each member in their outlook client so it automatically opens with their individual mailbox. I've done the same with the mailbox of a former colleague and each time a mail is ent to his mailbox I can see that immediatly.

    Monday, July 16, 2012 11:19 AM
  • @Leif and Steve,

    That's what I am looking for but I don't know how to do that.

    I've tried to set the shared mailbox as the primary mailbox for each memeber using the management console but I can only assign it to 1 member.
    How can I make them all login to the shared mailbox first (automatically) and add their individual mailbox as an additional one ?

    Dirk.

    Monday, July 16, 2012 11:21 AM
  • Hi,

    You are talking about the SMTP address (I believe). I am talking about creating a new Outlook profile for each user.

    You create this Outlook profile with the shared mailbox and then you add the personal mailbox as an additional mailbox to the profile

    Leif

    Monday, July 16, 2012 11:27 AM
  • I have to confess that I am totaly inexperienced with Active Directory, Exchange server and Outlook profile. I'm afraid you'll have to take me by the hand and go through each step.
    I'll try to give you a complete picture of the situation.
    These users are located in a branch office and will start to use the network functionality and applications by connecting to an existing  Terminal Server.
    When I created the shared mailbox a disabled Active Directory profile was created.
    I've created an Active Directory profile for each user, made him/her a member of a security group, granted the security group full access to the shared mailbox and set the forwarding option for each member to the shared mailbox.
    Started the terminal server session and configured the outlook client for each member, added the shared mailbox as an additional mailbox.

    This is the situation right now. Where did I go wrong and what can I do to go to your solution ?

    Dirk.

    Monday, July 16, 2012 11:37 AM
  • Hi,

    This technet article explains how to create an Outlook profile:

    http://support.microsoft.com/kb/829918

    You will need to do this on the terminal server if that is what the users are connecting to.

    Leif

    • Marked as answer by DirkVW62 Monday, July 16, 2012 11:59 AM
    Monday, July 16, 2012 11:46 AM
  • Hi Leif,

    After a few attemps ( one has to get familiar with the way Microsoft shows you the right path, their are many ways that look the same but only one gives you the solution ) I managed to let one of the members in the group start his outlook client with the shared mailbox as the primary one.
    Let's hope I can remember what I did to replicate that for the other members in the group.

    Thank you all for your contributions in trying the help a blind man to see some light !

    Dirk.

    Monday, July 16, 2012 12:04 PM