locked
WSUS 2016 use on port 80 RRS feed

  • Question

  • Hi,

    du you have a hint for me. I tried to replace my existing WSUS (2012R2) with Server 2016. Everything was working until i changed to port 80 (wsusutil usecustomwebsite false). After that clients will show up in the console but they dont report.

    I also set up a clean test environment with DC (a win 7, 8.1, 10 and server 2012 R2 Clients) but even there it does not work after i chage the port to 80.

    does someone know a fix for this ?

    thanks

    Tuesday, November 22, 2016 9:40 AM

Answers

  • Hi,

    i would suggest to add additional binding to 80 because changing 8530 to 80 will break wsusutil checkhealth for instance.

    I changed now the default website to 81, added the 80 to WSUS Administration. (there is also a bug in IIS Manager that will prevent you from adding the binding. You have to type something in the Host Name field and delete it that will allow you to press OK…)

    • Marked as answer by FloSchn Monday, November 28, 2016 8:38 AM
    Monday, November 28, 2016 8:38 AM

All replies

  • Hi FloSchn,

    Please check if the port is on http 80 both on WSUS console overview, IIS site.

    Check if related firewall settings is turned on;

    On the clients that do not report to the WSUS console, please try reset windows updates components, check if it could help:

    https://support.microsoft.com/en-us/kb/971058

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 23, 2016 6:26 AM
  • Hi Anne,

    ports are both OK. It is the “wsusutil usecustomwebsite false” that breaks the WSUS Service.

    The error is easy to replicate.

    >Download Server 2016 Eval
    >Add WSUS role
    >
    Do initial setup
    >Access http://127.0.0.1:8530/ClientWebService/client.asmx (works)
    >Chage to 80 with wsusutil
    >Try to access http://127.0.0.1/ClientWebService/client.asmx (does not work anymore, see attached error)

    You will get an ASP error:

    Server Error in '/ClientWebService' Application.

    Could not find a base address that matches scheme https for the endpoint with binding BasicHttpBinding. Registered base address schemes are [http].

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.InvalidOperationException: Could not find a base address that matches scheme https for the endpoint with binding BasicHttpBinding. Registered base address schemes are [http].

    Source Error:
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:
    [InvalidOperationException: Could not find a base address that matches scheme https for the endpoint with binding BasicHttpBinding. Registered base address schemes are [http].]
       System.ServiceModel.ServiceHostBase.MakeAbsoluteUri(Uri relativeOrAbsoluteUri, Binding binding, UriSchemeKeyedCollection baseAddresses) +16532968
       System.ServiceModel.Description.ConfigLoader.LoadServiceDescription(ServiceHostBase host, ServiceDescription description, ServiceElement serviceElement, Action`1 addBaseAddress, Boolean skipHost) +733
       System.ServiceModel.ServiceHostBase.LoadConfigurationSectionInternal(ConfigLoader configLoader, ServiceDescription description, ServiceElement serviceSection) +106
       System.ServiceModel.ServiceHostBase.ApplyConfiguration() +234
       System.ServiceModel.ServiceHostBase.InitializeDescription(UriSchemeKeyedCollection baseAddresses) +206
       System.ServiceModel.ServiceHost..ctor(Type serviceType, Uri[] baseAddresses) +170
       System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(Type serviceType, Uri[] baseAddresses) +45
       System.ServiceModel.HostingManager.CreateService(String normalizedVirtualPath, EventTraceActivity eventTraceActivity) +1849
       System.ServiceModel.HostingManager.ActivateService(ServiceActivationInfo serviceActivationInfo, EventTraceActivity eventTraceActivity) +66
       System.ServiceModel.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath, EventTraceActivity eventTraceActivity) +738
    
    [ServiceActivationException: The service '/ClientWebService/client.asmx' cannot be activated due to an exception during compilation.  The exception message is: Could not find a base address that matches scheme https for the endpoint with binding BasicHttpBinding. Registered base address schemes are [http]..]
       System.Runtime.AsyncResult.End(IAsyncResult result) +594083
       System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) +238
       System.Web.CallHandlerExecutionStep.OnAsyncHandlerCompletion(IAsyncResult ar) +178
    


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.1586.0 

    Wednesday, November 23, 2016 9:20 AM
  • Hi FlsSchn,

    I tested it in my lab, and got the same result with you. After using the default site, it unable to access ClientWebService of WSUS.

    If you want to use http port 80 for WSUS server, here is a workaround:

    1. Change the binding setting in WSUS site:

    Then stop the default Web Site, since default Web site also use http port 80, there is a conflict, so we stop the default Web Site to make WSUS site in use.

    Then we can access the file in port 80:

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 28, 2016 5:53 AM
  • Hi,

    i would suggest to add additional binding to 80 because changing 8530 to 80 will break wsusutil checkhealth for instance.

    I changed now the default website to 81, added the 80 to WSUS Administration. (there is also a bug in IIS Manager that will prevent you from adding the binding. You have to type something in the Host Name field and delete it that will allow you to press OK…)

    • Marked as answer by FloSchn Monday, November 28, 2016 8:38 AM
    Monday, November 28, 2016 8:38 AM
  • hi Geek,

    got same problem here. After trying your method, client still occur error code....

    anyone has other workaround to get update from WSUS with port 80?


    Monday, February 6, 2017 10:40 AM
  • Hi,

    did you first run the "wsusutil usecustomwebsite true" to get back to the working version ?

    regards

    Monday, February 6, 2017 10:58 AM
  • I don't know if this fix will solve your problem, but, I had the same issue on a Windows Server 2012 R2 WSUS and solved the problem reinstalling .NET Framework. Follow the guidelines in this article:

    http://pedrofln.blogspot.com.br/2017/10/restoring-failed-wsus-server.html

    Friday, October 6, 2017 3:04 PM