locked
Word document table of contents broken when opening document in Read-Only mode RRS feed

  • Question

  • Hello,

    I have a Word document on my SharePoint 2007 site which has a table of contents generated from the various style headings in the document.

    When users, who only have Read-Only permissions to the document, open it from the document library, the table of contents is broken, all the pages in the index appear with the same page number, although clicking the links does move the user to the correct page in the document.

    If, however, the document is opened in edit mode, the table of contents appears correctly, i.e. all the page numbers show correctly.

    Anyone ever heard of anything like this before?

    • Moved by Mike Walsh FIN Friday, June 10, 2011 2:30 PM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Friday, June 10, 2011 11:16 AM

Answers

  • It did turn out to be a property of the file rather than anything sharepoint was doing.

    Basically we discovered that there is an issue with Table of Contents (TOC) if the document is opened in Reading View by default. Turning this off as the default option (Tools > Options > General tab > untick "Allow starting in Reading Layout") resolved the issue.

    • Marked as answer by etala Friday, June 10, 2011 2:57 PM
    Friday, June 10, 2011 2:57 PM

All replies

  • Try saving the file down to your local computer and see what attributes are checked in the properties of that file.

    Make sure it's not marked as read only.

    Then save it back to the SharePoint site.

    Certain permissions in this document may be broken, not the permissions of the SharePoint site.

    • Marked as answer by etala Friday, June 10, 2011 2:57 PM
    • Unmarked as answer by Mike Walsh FIN Friday, June 10, 2011 5:34 PM
    Friday, June 10, 2011 1:59 PM
  • It did turn out to be a property of the file rather than anything sharepoint was doing.

    Basically we discovered that there is an issue with Table of Contents (TOC) if the document is opened in Reading View by default. Turning this off as the default option (Tools > Options > General tab > untick "Allow starting in Reading Layout") resolved the issue.

    • Marked as answer by etala Friday, June 10, 2011 2:57 PM
    Friday, June 10, 2011 2:57 PM