none
Provisioning of Database taking long time in project server 2010. RRS feed

  • Question

  • HI,

    My environment is Project server 2010 APP01, APP02 , Sqldb01,Sqldb02.

    When i try to created New PWA it was taking nearly 6 to 8 hours for creating what may be the issue i am not getting.

    As i checked USL logs its showing as time taking between provisioning of databases is some 2hours for all 4 databases.

    04/22/2014 20:09:03.42     OWSTIMER.EXE (0x2BF0)    0x2B80    Project Server    Provisioning     6411    Information    Provisioned database 192.168.81.100.ProjectServer_Published_test123 as Published.    
    04/22/2014 20:09:03.42     OWSTIMER.EXE (0x2BF0)    0x2B80    Project Server    Provisioning     6410    Information    Provisioning database 192.168.81.100.ProjectServer_Draft_test123 as Draft.    



    04/22/2014 22:12:45.40     OWSTIMER.EXE (0x2BF0)    0x2B80    Project Server   Provisioning     6411     Information    Provisioned database 192.168.81.100.ProjectServer_Draft_test123 as Draft.    
    04/22/2014 22:12:45.40     OWSTIMER.EXE (0x2BF0)    0x2B80    Project Server   Provisioning     6410    Information    Provisioning database 192.168.81.100.ProjectServer_Archive_test123 as Archive.   

    In the usl logs i have found this also.

    The previous instance of the timer job 'Project Server Synchronizing Job for 'Project Server'', id '{798E2B4F-0ECB-478C-8D8C-B84CB25AC333}' for service '{4CE31555-EB1C-4835-A184-8777E88A5ACE}' is still running, so the current instance will be skipped.  Consider increasing the interval between jobs.

    You can check my previous post as well:( http://social.microsoft.com/Forums/en-US/57d6ec20-16d9-40a6-8512-164ac85d18d1/unable-to-create-pwa-in-project-server-2010?forum=projserv2010setup )

    Can Any one help me what may be the issue creation of PWA was taking nearly 8 hours.


    vijay kommireddi

    Wednesday, April 23, 2014 10:52 AM

All replies

  • Hi Vijay,

    When you start provisioning a new PWA, how much time does it take to come to Provisioning Databases state?

    When you see the Provisioning Databases, do you see the databases getting created in DB Server.

    Also, please let us know the last CU which was installed for Project Server.


    Cheers! Happy troubleshooting !!! Dinesh S. Rai - MSFT Enterprise Project Management Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can be beneficial to other community members reading the thread.

    Wednesday, April 23, 2014 5:45 PM
    Moderator
  • Hi Dinesh,

    When i start provisioning a new PWA, It is taking some 5 to 10 minutes to come to Provisioning Databases state.

    Yes 4 databases were also created in less time only.

    My Farm is at 2010 with Sp2.

    But for changing from Provisioning Databases to Provisioned its taking 6 to 8 hours time.

    Vijay Kumar.


    vijay kommireddi

    Wednesday, April 23, 2014 5:56 PM
  • Vijay,

    Try to check the memory while provisioning the pwa instance.

    Try to use the same account which is running SharePoint Timer Service Application and also make sure to use the same account to run the web applications application pool.

    Also make sure that the user account with which the SharePoint Timer Service is running is having the appropriate permissions in the SQL.

    What is the provisioning status after 8 hours?

    Is their any events in the event viewer during this period?

    Cheers!!! Happy Troubleshooting!!!

    Shiva Prasad B C

    Wednesday, April 23, 2014 6:30 PM
    Moderator
  • Hello vijay

    This is a classic performance problem and you will have to look at many areas.

    I would start with analyzing SQL server and be sure it is properly configured.   Check you processor affinity.

    My first suspicion is disk drive issues.  Are you seeing any logs with disk drives starting to fail? Plenty of disk space, etc.

    Is it cluster and are the nodes in the same building?

    Are the processors page faulting?

    Are you running VMs?  Are they properly tuned and configured

    Turn off any virus protection on server and see if it improves provisioning.

    Cheers!


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Thursday, April 24, 2014 3:26 AM
    Moderator