locked
Lync call drops after 30 seconds RRS feed

  • Question

  • Hi@all

    Calls from an external Telephone to a Lync Client Drops after 30 seconds. If I hang up the telephone before 30 seconds, the Lync Client keeps connected and doesn't hang up. I reinstalled the whole Lync 2013-Infrastructure with Skype for Business 2015 and have now the same issues. I use a Sip-Trunk for the Enterprise Voice calls.

    The Client-Logfile says:

    ms-diagnostics-public: 10001;reason="Gateway did not respond in a timely manner (timeout)";component="MediationServer"

    I tried everything I found on the net for weeks now, without a clue. OCS-Logger and Firewall Logs doesn't fire any Errors.

    The Mediation Server is Standalone.

    I have to build the productive Infrastructre soon, every help would be very appreciated.

    Tanks!

    Tuesday, July 28, 2015 12:17 PM

Answers

  • Checking back in. Are you using NAT on the traffic?  Or does the mediation server have a private IP assigned to it?   If you have a NAT, you'll need to use a private IP instead or an SBC.  This can be the cause of your issue.

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, September 9, 2015 6:39 PM

All replies

  • How are you connecting to the SIP trunk?  Are you directly connecting from the mediation server or going through and SBC?  If you're not using an SBC, are you using a firewall to pass or NAT the traffic?  If so, this is a possible source of the issue.


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Tuesday, July 28, 2015 6:50 PM
  • I don't go thru a SBC. It's a normal Nat with ist Firewall rules (Pfsense Router).

    What do you mean with possible Source of the issue? There should be no Problem with the Nat. Or am I wrong?

    Tuesday, July 28, 2015 9:10 PM
  • You can't simply NAT sip traffic because there is additional IP information within the data portion of the packet that is not affected by the NAT, he MADDR field for example. My guess is that this is the issue and your telco may confirm. Using an SBC, sip aware proxy or firewall, or having a public ip directly on your mediation role may resolve the issue. If you call your telco provider the may be able to modify on their end as well. I may be wrong but the telco can help you diagnose.

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Proposed as answer by Eason Huang Wednesday, July 29, 2015 8:15 AM
    Tuesday, July 28, 2015 9:34 PM
  • Hi,

    Please check the "Enable outbound routing failover timer” Setting on the Lync Server 2013 Trunk. If it is enabled, please try to disable it and then test the issue again.

    Best Regards,
    Eason Huang  


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Eason Huang
    TechNet Community Support

    Wednesday, July 29, 2015 8:15 AM
  • This doesn't make a difference.

    I really tried every hint I found on the net (this included)

    Nat ports were not overwritten.

    Sound works in both ways. I'm really out of ideas

    => I see  in Wireshark, that the Lync-Mediation sends a Goodbye after 30 seconds...

    Wednesday, July 29, 2015 9:45 AM
  • What do you mean NAT ports were not overwritten? If you're using a firewall to NAT, and it's not doing application level natting within the packet, you can have issues... have you tried without the NAT? Is the sip trunk provider qualified for Lync?

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, July 29, 2015 4:17 PM
  • Yes, the trunk provider is Lync-Certified. It seems that the Mediation Server sends a BYE-Package after 30 seconds. I really have no clue and i'm running out of ideas.
    Tuesday, August 4, 2015 11:56 AM
  • ..


    Sunday, August 9, 2015 7:41 PM
  • Are you using NAT on the traffic?  Or does the mediation server have a private IP assigned to it? 

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Monday, August 31, 2015 6:45 PM
  • Checking back in. Are you using NAT on the traffic?  Or does the mediation server have a private IP assigned to it?   If you have a NAT, you'll need to use a private IP instead or an SBC.  This can be the cause of your issue.

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, September 9, 2015 6:39 PM