none
Windows 2012 Verification of prerequisites for Domain Controller promotion failed RRS feed

  • Question

  • Windows 2012 Verification of prerequisites for Domain Controller promotion failed and gave the below error(In computer management local group and user option is not there as suggested by a solution!)

    "Verification of prerequisites for Domain Controller promotion failed. The local Administrator account becomes the domain Administrator account when you create a new domain. The new domain cannot be created because the local Administrator account password does not meet requirements.

    Currently, the local Administrator password is blank, which might lead to security issues. We recommend that you press Ctrl+Alt+Delete, use the net user command-line tool, or use Local Users and Groups to set a strong password for the local Administrator account before you create the new domain."
    Saturday, January 10, 2015 11:04 PM

Answers

  • type this in cmd=

    net user Administrator /passwordreq:yes

    Thursday, March 31, 2016 9:22 PM
  • You need to have a password before you begin. 

    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sunday, January 11, 2015 6:53 AM
    Moderator

All replies

  • You need to have a password before you begin. 

    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sunday, January 11, 2015 6:53 AM
    Moderator
  • OK, the reason you see this error is because when you set up and configured your Windows R2 environment you may have logged into the OS with an account other than Administrator. So, if you created your log in account named Bob, this is throwing off the Server.

    So, hit Ctrl-Alt-Delete, and look who you are logged in as, and then change the account you are logging in as and use the local Administrator account. What you may find is that the default Admin account password has not been set.

    Check that out and see if that is what you are experiencing.

    Best wishes

    • Proposed as answer by drmcgee2000 Thursday, March 26, 2015 1:43 AM
    Thursday, March 26, 2015 1:42 AM
  • Hi, I am in Nepal and trying to set this server up for disaster relief, and I am stuck here: 

    Verification of prerequisites for Domain Controller promotion failed. The local Administrator account becomes the domain Administrator account when you create a new domain. The new domain cannot be created because the local Administrator account password does not meet requirements.

    Currently, a password is not required for the local Administrator account. We recommend that you use the net user command-line tool with the /passwordreq:yes option to require a password for this account before you create the new domain; otherwise, a password will not be required for the domain Administrator account.

    I am not a server admin, and following this tutorial: http://social.technet.microsoft.com/wiki/contents/articles/22622.building-your-first-domain-controller-on-2012-r2.aspx and I AM ALMOST THERE, but for this. There are three or four users for this server, and I am not sure which one is the problem, but they all have the same password with a schema of Abcdefgh1i which should be good enough. 

    Not sure what to do, confused and shaken by earthquakes... I ran net user and it shows what I thought was the admin account to be a guest account. Do I need to log into another account and run the domain tut again there? 

    Thx!!!

    Jigs in Kathmandu



    Jiggy Gaton, Trainer and Media Consultant for Nepal and S. Asia

    Sunday, May 17, 2015 3:59 PM
  • The issue is probably that there is still an account with the username "administrator" even though you aren't using it (instead you are using your own account name). No need to log out, you can fix this in the same user session.

    Run PowerShell as an Administrator and type:

    net user administrator [THE NEW PASSWORD YOU WANT TO SET HERE WITHOUT THE BRACKETS]

    It should then say "The command completed successfully".  At this point you can rerun the prerequisite check.

    Tuesday, June 23, 2015 6:58 PM
  • type this in cmd=

    net user Administrator /passwordreq:yes

    Thursday, March 31, 2016 9:22 PM
  • thxxxxxxxxxxxxx
    Tuesday, May 31, 2016 11:22 PM
  • It worked! Thank you very much!
    Monday, August 8, 2016 6:43 PM
  • Thank U
    Friday, October 14, 2016 9:03 AM
  • thanks a lot

    Friday, November 11, 2016 9:24 AM
  • It worked. Thank you
    Friday, March 29, 2019 2:05 PM
  • Thanks it's working !
    Sunday, August 11, 2019 12:58 PM
  • Thats running .. thanks
    • Proposed as answer by DJCool06276 Saturday, August 17, 2019 12:22 PM
    Saturday, August 17, 2019 12:21 PM
  • I found this really helpful. Thank you!!
    Saturday, October 12, 2019 9:52 AM