locked
Option "Find Certificate" is missed when I try to edit certificate on another computer using mmc. RRS feed

  • Question

  • Option "Find Certificate" is missed when I try to edit certificate on another computer using mmc.Could you please let me know how can I solve that? I'm sure I'm admin on the remote machine.

    Tuesday, October 6, 2015 3:16 PM

Answers

  • Hi,

    Do you run MMC.exe as administrator? If you doesn’t, please run it as administrator for test.

    If it doesn’t work, go to MMC interface and click “File” > “Options”, then choose “Author mode” in “Console Mode” column.

    In addition to that, we have found an issue which is similar to yours. Maybe you need to join the domain and then check the issue again.

    http://www.pcreview.co.uk/threads/request-new-certificate-is-missed-from-certificates-snap-in.3155440/

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Please kindly let us know whether it works.

    Best Regards

    Simon  


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, October 14, 2015 9:11 AM

All replies

  •  Have you tried following Microsoft's forum of configuring the MMC snap-in?

    The forum can be found here: https://msdn.microsoft.com/en-us/library/ms788967(v=vs.110).aspx

    In Step 7, you have the option of choosing different types of accounts. Choosing a computer account will allow you to see all of your installed certificates. Also, it never hurts to double check that you are on an account with Administrative privileges, because this will hide some of the installed certs.

    Right clicking on “certificates” under the console root should bring up an option to “Find Certificates” and will search all of the ones that you have added to the snap-in.

    If you have tried all of these with still no luck, try editing your certificates with Internet Explorer. The instructions are found on the same forum as above.

    Good luck, 

    -kpatzke

    Tuesday, October 6, 2015 4:37 PM
  • Hello kpatzke!

    For sure, I have choosed Computer account. My questions is related to managing certificate on a remote PC.

    Let me show you difference between view options when I'm looking certificates from my PC and from a remote PC. Unfortunately I cannot upload images here.

    The difference is that when I go for example to personal certificate on my PC, I can right-click and choose in the menu option

    All tasks -> Request new certificate.

    When I go to personal of remote PC I don't have option Request new certificate.

    Thanks in advance.


    • Edited by Roman Sirotkin Friday, October 9, 2015 12:07 PM add explanation
    Friday, October 9, 2015 12:02 PM
  • Hi,

    Do you run MMC.exe as administrator? If you doesn’t, please run it as administrator for test.

    If it doesn’t work, go to MMC interface and click “File” > “Options”, then choose “Author mode” in “Console Mode” column.

    In addition to that, we have found an issue which is similar to yours. Maybe you need to join the domain and then check the issue again.

    http://www.pcreview.co.uk/threads/request-new-certificate-is-missed-from-certificates-snap-in.3155440/

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Please kindly let us know whether it works.

    Best Regards

    Simon  


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, October 14, 2015 9:11 AM