locked
Unable to delete connector RRS feed

  • Question

  • Hi

    We have an orphan Exchange-connector we are unable to delete.

    There are no Delete-link in the connectors view in the scsm console, so i thought I may delete it from powershell

    I've trid both the Powershell-link from the console and the Powersehell (x86)-version (as administrator)
    I've also restated the SCSM services


    When I run:

    Get-SCSMConnector | where{ $_.displayname -eq "Exchange Connector" -and $_.enabled} the result is:

    Enabled    DisplayName               DataProviderDisplayName                                                                               
    -------    -----------               -----------------------                                                                                                                                                          
    True       Exchange Connector        Exchange Connector

     

    Then I run:
    Get-SCSMConnector | where{ $_.displayname -eq "Exchange Connector" -and $_.enabled}|Remove-SCSMConnector                                                                                   

    The prompt gets back, without any errors


    But when I run Get-scsmconnector again it is still there

     

    How may I delete this connector?

    thanks.

    Monday, November 26, 2012 10:05 AM

Answers