none
Using deployment with hybrid hard drive RRS feed

  • Question

  • Hi there,

    I'm currently having trouble using MDT 2012 to deploy an operating system on a computer with a hybrid hard drive.

    The problem seems to be that the Solution Accelerator wizard installs the operating system on the tiny flash drive inside the hybrid hard drive, which cannot be found even by the bios. After the copying and installation of the operating system has finished, the system restarts as planned, but it boots the original Windows version, located on the hard drive. The flash drive containing the new files is only available after the system started.

    My task sequence formats and partitions disk number 0 by default, but it seems that it takes the flash drive for disk 0. However, disk 0 is fine for most of the computers I deploy, so changing this option permanently is no solution for me.

    Is there a way to open up some kind of partition wizard when setting the options for the current deployment (computer name, software...), so i could choose partitions and the disk for installing the operating system manually?

    Thanks in advance for the help!

    Tuesday, June 9, 2015 1:48 PM

Answers

  • If you are using one task sequence for multiple devices but this only affects one, you could use a WMI query to make it use a different step for the partitioning of the drives only for that model.

    Something like this should work for you: (just set the condition to none or any depending)

    Options tab, add a Query WMI condition: SELECT * FROM Win32_ComputerSystem WHERE Model LIKE '%HP EliteBook 8560w%'

    Thanks

    NN

    • Marked as answer by Marcel RB Wednesday, June 10, 2015 1:17 PM
    Tuesday, June 9, 2015 3:18 PM

All replies

  • Curious what model hard drive are you dealing with?

    If this post is helpful please vote it as Helpful or click Mark for answer.

    Tuesday, June 9, 2015 2:58 PM
  • If you are using one task sequence for multiple devices but this only affects one, you could use a WMI query to make it use a different step for the partitioning of the drives only for that model.

    Something like this should work for you: (just set the condition to none or any depending)

    Options tab, add a Query WMI condition: SELECT * FROM Win32_ComputerSystem WHERE Model LIKE '%HP EliteBook 8560w%'

    Thanks

    NN

    • Marked as answer by Marcel RB Wednesday, June 10, 2015 1:17 PM
    Tuesday, June 9, 2015 3:18 PM
  • When in WinPE can you output what diskpart shows when you list disk?

    Also when you are in the full OS. 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, June 9, 2015 8:14 PM
    Moderator
  • Don't know the actual model and can't take a look at the moment because the notebook is in use by an employee. The Laptop is a Fujitsu Lifebook S782, equipped with the 32GB SSD option. 
    Wednesday, June 10, 2015 1:16 PM
  • That's a nice workaround, didn't think of it. Thanks, I will try that!
    Wednesday, June 10, 2015 1:17 PM