locked
Excel row height changes when it should not change RRS feed

  • Question

  • I have a client using Office 2010 on a Citrix server. They are using Windows XP Pro SP3 for the desktop and the server is running Windows Server 2003 R2 STD.

    I have two users working in a spreadsheet in Excel 2010. The spreadsheet opens fine and they can perform their updates by either adding manually or doing a cut and paste. The problem comes up when all of the sudden a number of rows in the spreadsheet change height for not reason. The spreadheet has the row height set to 14.5 but for some reason the rows that change height sent the height to 405.9. Usually all the user has to do is go back and reset the row height on these cells and save before they can go back to making changes.

    It's more annoying then anything else so if someone could provide any solutions, it would be greatly apppreciated.

    thanks, Joe Trainor

     


    Joseph Trainor jtrainor@hammer.net Weidenhammer Systems Wyomissing, PA
    Wednesday, October 20, 2010 8:52 PM

Answers

  • Hello,

    Please try the following to resolve the issue:
    1. Boot Excel 2010
    2. Open [Excel Options] dialog. ([File]-[Options])
    3. Select [Advanced] tab, turn on [Cut, copy and sort inserted objects with their parent cells] option. (In [Cut, copy and paste] section)

    *This will not resize rows that are currently set to 409.5 but I would like to know if this keeps rows from doing this in the future.

    *Please vote as helpful if this is resolving your issue.

    Best Regards,
    Chad


    Chad Mathiason
    Monday, December 13, 2010 8:53 PM

All replies

  • Hi,

    When you paste in Excel 2010, you can see the paste option which is next to the text you paste.

    And click the drop-down arrow of this option and choose "Keep Source Column Width".

    Or you can right click the cell and choose "Paste Special" to select "Keep Source Column Width".

    Hope that helps.

    Thursday, October 21, 2010 3:07 AM
  • Jennifer,

    The problem is not with the width but with the height of entire rows changing, and the rows that change are not even being accessed at the

    time, they could be 10 or more rows down that change height.

     


    Joseph Trainor jtrainor@hammer.net Weidenhammer Systems Wyomissing, PA
    Thursday, October 21, 2010 4:36 PM
  • Hi,

    "For no reason"?  Does this mean that the user is doing nothing when this happens?  And by nothing I mean they don't even have their hands on the mouse or keyboard.  If the user is doing something what is it?  Are they copying and pasting, formatting a cell or saving or something else?


    If this answer solves your problem, please check Mark as Answered. If this answer helps, please click the Vote as Helpful button. Cheers, Shane Devenshire
    Thursday, October 21, 2010 7:07 PM
  • Shane,

    I have sat with an open remote session watching her work. The user can work on the spreadsheet entering data. minimize Excel and come back to it after a few minutes and 3-4 rows will have changed height. The rows that change height are usually not the same place where the user may have been entering or pasting data, usually the change happens a few rows down.

    This is affecting only two users that work on the same worksheet and as far as i know no one else in the organization is affected.

    Joe.


    Joseph Trainor jtrainor@hammer.net Weidenhammer Systems Wyomissing, PA
    Friday, October 22, 2010 8:11 PM
  • This may be a consequence of wrapping. If for example some distant (thin width) column contains

    w
    ra
    p
    p
    in
    g

    then it will jack up the row height when you do something completely unrelated, 50 columns away from that cell, but on the same row.

    A strong clue that this is the culprit is if you mark an entire row and hit the delete key (relax, you'll 'undo' this immediately) and the row instantly returns to default height.

    • Proposed as answer by Iripino Friday, August 31, 2012 3:10 PM
    Wednesday, November 3, 2010 2:04 AM
  • I am also having this problem. It seems the row height is changing to 405.9 when I open the documents.  It usually occurs with rows beginning toward the middle of the document.
    Monday, November 29, 2010 7:48 PM
  • I too am having the problem with Excel 2010 where the row height of just some rows randomly resets to 409.5.  Just this week started using 2010 and this is driving me nuts because it is showing up on nearly every file that I open (about 50 files daily).  Repairing and saving does not fix the problem.  AARGH!
    Tuesday, December 7, 2010 2:21 PM
  • I too am having the problem with Excel 2010 where the row height of just some rows randomly resets to 409.5.  Just this week started using 2010 and this is driving me nuts because it is showing up on nearly every file that I open (about 50 files daily).  Repairing and saving does not fix the problem.  AARGH!

    I had a user report this Monday that row heighths were not being copied when selecting a range in a source worksheet and copying to a blank target worksheet.  My reply was "impossible", but when I select a range in his worksheet and paste special / all to a blank sheet, the row heights are totally messed up, and would you believe, many of them are 409.5????  What is going on?  This is in excel 2007.
    Wednesday, December 8, 2010 9:46 PM
  • I believe I am having the same problem, although I haven't checked to see if it is resetting to size 409.5.  To correct you have to manually reset those row heights - I have tried several times to auto-set the row heights but then it hides the rows / sets their height to zero.  I thought this was a corrupt file, but decided to google the problem before migrating everything to a new file - that's how I stumbled across this...I have also just remembered I migrated this particular file to a new file to try and fix this problem in the past, and it did nothing.

    All I can say is that I work in 2010 and 2007 and this doesn't happen to any other files, just this one file in particular (although nothing special about it).  I work in both the 64bit and 32 bit version of Excel and have noticed it more in the 64bit, although that's anecdotal, I haven't specifically been trying to remember which version was causing more problems.

    Come on MS - Any feedback on this?  I'm glad I'm not the only one with the problem, some feedback would be useful.

    Regards

    Monday, December 13, 2010 3:04 PM
  • Hello,

    Please try the following to resolve the issue:
    1. Boot Excel 2010
    2. Open [Excel Options] dialog. ([File]-[Options])
    3. Select [Advanced] tab, turn on [Cut, copy and sort inserted objects with their parent cells] option. (In [Cut, copy and paste] section)

    *This will not resize rows that are currently set to 409.5 but I would like to know if this keeps rows from doing this in the future.

    *Please vote as helpful if this is resolving your issue.

    Best Regards,
    Chad


    Chad Mathiason
    Monday, December 13, 2010 8:53 PM
  • Chad - 

    That change seems to have solved the Fat Rows issue.

    Thanks

    Tuesday, December 14, 2010 1:29 PM
  • Hi Chad,

    Sorry for being slow to respond to this - that option is already set in the file.  Will try deactivating it and then reactivating it, but not sure it's going to achieve what you wanted.

    Regards,

    Digittt

    Monday, January 3, 2011 8:31 PM
  • I am also experiencing a problem where the row height of several rows (also below the area that I am working on) has the row height changing by itself to 409.5.  I am using Excel 2010 on one computer and Excel 2007 on another computer.  I'm using Sugarsync to keep the data on both machines synchronized.  I noticed that I can't just fix the problem by resetting the row height back to 12.75.  Sometimes I have to delete the rows.

    I also figured out that the problem goes away when I turn off Sugarsync or so it seems so far.  Anyone else using any kind of synchronization software?

    Monday, January 31, 2011 10:29 PM
  • Chad,

    Ok, I just confirmed that my Excel options were set as you asked.  It was already set that way.  I also wanted to let you know that even after manually resetting the row heights of the affected cells back to their proper height (11.25 in my case), some of the cells lost their numbering on the right side.  For example, I could see the cell numbering for 3xx and then the next 10 or so cells had no numbering and then the numbering resumed.  I also discovered that I get the row height formatting automatically changing to 409.5 even when I disable the SUgarsynch program so now I'm thinking that it is unrelated.

    When I save the fiel and reopen it, the cell numbering is back to normal.  I hope this information helps since this problem is driving me crazy.

    Tuesday, February 1, 2011 4:30 PM
  • Hi Mad.Cow...

    FYI...  I am experiencing the same issue at one of my clients as you are.  They have the problem with Excel 2010, and it occurs on both Windows XP Pro & Windows 7 Pro workstations.

    So far, I am not able to determine how it occurs.  I have tried the recommended steps above too without luck.  And it is strange that it appears to take random rows & max them out for no rhyme or reason.

    Well, if I find the solution, I'll post it, but in the mean time, maybe the more people that post that they are having the issue, the sooner Microsoft can get a solution for us.

     

    Tuesday, February 1, 2011 7:37 PM
  • Hi. 

    I have the same problem where randomly two or three of the row heights have changed to max when I scroll down. I am using Excel 2010 and Win 7.  With Excel 2007 and Vista there was no problem with the same files.  Also occurring is same problem as mentioned by 'madcow' where on some rows (not necessarily the height changed ones) the numbering disappears as well as all the data along that row! 

    Another issue is that only in Excel, randomly some print jobs disappear - says printing but nothing happens and to get printer to print I have to restart the print spooler.  Double sided printing in Excel also does not work.  Lexmark advise it must be a software issue with Win7/Excel!

    All of these problems are random!  I have reinstalled Win 7, repaired MS Office 2010 in case it needed it, downloaded all available updates, as well as uninstalled and reinstalled the printer!!!  Nothing seems to work!  Hope there is a solution soon!

    Tks & brgds.

    Thursday, February 24, 2011 2:02 PM
  • Chad,

    I have been having the same problem with Excel 2010.  We use spreadsheets for our estimating and I recently upgraded to 2010 from 2003.  This problem did not occur with 2003 but is now randomly occurring.  I have not been able to identify a particular activity that is triggering it.  I may make several entries in different parts of the sheet and then scroll down to another section and find this on anywhere from 1 row to a dozen rows.  I do know this only happens below where I am working.  It has never occurred above where I am working.  I do not use any images and all I am doing is entering cost and labor hours on the sheet.  I may cut and paste some rows to different locations in the spreadsheet.  I checked your suggestion above and (Cut, copy and sort...) is already turned on.  any other suggestions?

    Friday, April 15, 2011 11:58 AM
  • I have been having this same issue, I tried your solution but the box was already checked.
    Saturday, May 7, 2011 4:18 PM
  • I've got the same issue.

    Windows 2003 R2 UK server 32-bit
    Office 2010 Plus NL

    Advanced Cut, Copy, Sort option allready turned on.

    Thursday, May 12, 2011 12:02 PM
  • I'm getting the same issue as well:

     

    Windows 7 Pro; Excel 2010 (Home & Business)

    Seems to occur when working on spreadsheets that have been created or modified in Excel 2003.  No rhyme or reason to which rows are affected, but I'm seeing both the 409 height rows and the normal spaced (but unnumbered and blank) ones.  Going to the file screen and converting the file to .xlsx instead of viewing it in compatibility mode fixes everything.  But you have to do that with each file and it creates a copy instead of just fixing the file you're working on, so it's a really clumsy fix to have to do each time you get a file.

    Would love to see Microsoft fix this one since it's made an otherwise solid version of Excel very frustrating to work with.

    Thanks, and please post if anyone's found a solution.

    Wednesday, May 25, 2011 5:37 PM
  • I'M HAVING THE SAME "SYMPTOM"!!!!

    What's unique about my issue:

    #1) It manifested after about 2 months of using MS OFFICE 2010. all of a sudden prominent issue! 

    -working mostly with excel 2003 docs

    #2) It only happens with documents containing data in large number of rows. -the rows beyond (below) the visible screen (scroll down) all get this HEIGHTENED issue.

    -i have to maximize screen view and go into and auto-resize 100s of rows to remedy

    -often when i do it makes the top, uncorrupted rows all of a sudden hidden and i have to unhide

    #3) --separate symptom -- lately i open documents and the text in certain cells are invisible, and i have to autosize the row to make visible?!cell numbers are invisible too.

     

    IM SO TIRED OF THIS ****!!! :P James

    Wednesday, June 1, 2011 9:06 PM
  • Hi there!

    I am having the same problem!  Really frustrating to change the row hights every time!  I have also checked the Options Tab.  The [Cut, copy and sort inserted objects with their parent cells] was already ticked.

     

    I hope we get an answer soon!



    Wednesday, June 8, 2011 7:21 AM
  • Hello -

    Same problem here as well.  For me it happens after a save and close.  I will have gone through the doc, making sure all rows are set to 11.25 height.  Then I save and close the document.  The next morning, when I re-open it, and simply scroll down (taking NO other actions), there are rows again with height set to over 400.  I am on a trial of 2010 (needed it to test out OneNote, which I like) but I will not actually purchase 2010 until this issue is recognized and resolved by Microsoft.  It's a productivity KILLER.

    To Chad - as with other users reporting the same problem, the Cut/Copy/Paste Advanced Option is aiready set to "on."  So no help there...

     

    - Pat

    Wednesday, June 8, 2011 5:20 PM
  • We also have an issue with it resizing the rows while deleting rows but upon testing it appears that it will resize the rows of an Excel document saved to 2003 format in Excel 2010 but not Excel 2007.  It appears it has something to due with compatiblity mode.  When we saved the document to the newer format we no longer had an issues with the reiszing.  Can anyone else confirm this?

     

    Thanks.

    Wednesday, June 8, 2011 7:40 PM
  • Nevermind the compatiblity as a problem.  I went back and tested the problem on the original computer it still occured.  However, I did find a workaround.  If we do a print preview before working with the documents, they will not have the row resizing issue.  Please test this and post your responses.

     

    Thanks.

    Wednesday, June 8, 2011 8:37 PM
  • Have you tried print previewing when opening the document to see if it still has the issue?

    Wednesday, June 8, 2011 8:40 PM
  • The problem is created by the CELL ALIGNMENT functionality - The strangely heightened rows in my 2003 to 2010 spreadsheet all had varying alignments in different cells across the same row, generally tops and bottoms. When I make them all the same the row pops back to standard height. Cell wrapping is not the problem but can do a similar thing if you are not paying attention with column widths, sooo....

    1. Select the entire table or work-area or range i.e. select a1, press f8, press control/end. This will select the entire space you are currently working in. (Alternately you could select the entire sheet by clicking the little square at the corner of A and 1 but this will effect any header rows that you might want to keep specifically alligned)

    2. On the Home Toolbar choose bottom alignment, then top allignment, then bottom allignment again....viola, all strange rows should recover their standard height.

    Save, close then open to check all is hunky dory....

    • Proposed as answer by Dick Bowers Saturday, August 27, 2011 1:54 AM
    Saturday, August 27, 2011 1:51 AM
  • Chad,

    I am waiting for Microsoft to issue a patch for office which I hope will fix this problem.  I have found a workaround that works for me for the problem with the random row height changing to the maximum on some rows on worksheets while you are working on them.  Before when the rows appeared, I was going through the rows one by one and changing them back to proper height.  What I do now is save the workbook or worksheet, close it and reopen it.  The affected cells have been returned to normal on all 4 worksheets I have tried this on.  I hope this helps.


    Ken
    Wednesday, September 28, 2011 11:55 AM
  • I am waiting for Microsoft to issue a patch for office which I hope will fix this problem.  I have found a workaround that works for me for the problem with the random row height changing to the maximum on some rows on worksheets while you are working on them.  Before when the rows appeared, I was going through the rows one by one and changing them back to proper height.  What I do now is save the workbook or worksheet, close it and reopen it.  The affected cells have been returned to normal on all 4 worksheets I have tried this on.  I hope this helps.



    Ken
    Wednesday, September 28, 2011 1:58 PM
  • That seems to work also.  I find that adding the print preview to my Quick Access toolbar and print previewing it to be much faster and I can keep making changes without having to close and reopen the document constantly.
    Thursday, September 29, 2011 10:05 PM
  • hi,

    I also had the same issue, ... if in a big excel document rows where deleted, some of the rows that were off screen got a height of 405.9

    After investigation I noticed that the vertical allignment of the cells was set on "bottom" (sorry if the term Bottom is not correct I have a dutch office 2010 and in dutch it is called: onder uitlijnen) this is the picture:

    To fix it: just press control-A and change it to the default vertical alignment (upper?) or in dutch: boven uitlijnen.

    This fixed the issue for our users.

    I hope this helps ...

     

    Wednesday, October 19, 2011 7:42 AM
  • Sorry new to this technet forum, this is what I posted to the original message:

    hi,

    I also had the same issue, ... if in a big excel document rows where deleted, some of the rows that were off screen got a height of 405.9

    After investigation I noticed that the vertical allignment of the cells was set on "bottom" (sorry if the term Bottom is not correct I have a dutch office 2010 and in dutch it is called: onder uitlijnen) this is the picture:

    To fix it: just press control-A and change it to the default vertical alignment (upper?) or in dutch: boven uitlijnen.

    This fixed the issue for our users.

    I hope this helps ...

     

    Wednesday, October 19, 2011 7:43 AM
  • Good Worked

    Wednesday, August 1, 2012 6:23 AM
  • This was my problem. I thought I had "hidden" a column with a lot of text, but it turns out that I had just dragged/re-sized the column header to not show it. Re-sizing to zero isn't the same thing as hidden and will cause the row height to accommodate it.
    Friday, August 31, 2012 3:12 PM
  • Chad,

    Your solution corrected this problem.

    Thank you!

    Tuesday, October 23, 2012 4:34 PM
  • @Dick that fix worked for me - that is, I selected the rows that were of strange height, and changed the alignment as you suggested, and the rows returned to their normal size.
    Friday, October 26, 2012 6:00 PM
  • Thank you so much Bruce.  I've been having the same problem as well and my alignment was also set to bottom.  I've changed to top and that seems to have done the trick.  I never would have thought of doing that.  Still, MS needs to put in a fix - sometimes people do want their text on the bottom.  Thanks again !
    Friday, November 2, 2012 9:37 PM
  • Hi All. I've also had this problem and though I can't give a solution I do have a helpful workaround.

    This issue has cropped-up repeatedly for me when I've had two workbooks open and I've been working down and deleting selected rows in one before copying and pasting across to the other. I've found that if I start at the bottom of the source workbook and delete the rows (either singly or in blocks) I avoid the problem without the need to change any formatting.

    Friday, November 9, 2012 10:52 AM
  • worked great.  Select all, change alignment to top.  Thanks Bruce!

    Tuesday, January 1, 2013 2:10 PM
  • Yes, Bruce's solution worked for me. This is a real problem, though. Important data becomes impossible to view, and seems to have disappeared. Considering that Excel users are often recording vital information, this can be very serious. It's dismaying that this has been going on since the release of Office 2010 without a fix.
    Tuesday, February 12, 2013 12:58 AM
  • Hello,

    Please try the following to resolve the issue:
    1. Boot Excel 2010
    2. Open [Excel Options] dialog. ([File]-[Options])
    3. Select [Advanced] tab, turn on [Cut, copy and sort inserted objects with their parent cells] option. (In [Cut, copy and paste] section)

    *This will not resize rows that are currently set to 409.5 but I would like to know if this keeps rows from doing this in the future.

    *Please vote as helpful if this is resolving your issue.

    Best Regards,
    Chad


    Chad Mathiason

    Thank you so very much !!!

    Thursday, July 25, 2013 12:09 PM
  • Here is what I discovered.  If you have data rows that extend below the viewing area, and place a shape on the sheet (ie a rectangle), then save it, when you reopen, the rows below the screen viewing area will not be readable.  The row height defaults to 405.9 or whatever.  I am using Excel 1997-2003 (.xls files).  The above fix, changing the Excel options works as the fix.  Thanks for your help.
    Tuesday, August 20, 2013 9:40 PM
  • It has to do whit Excels last used Cell \ range, it expands per session, and only gets reset ones you restart Excel where it will search for last used cell on sheet.

     

    If you use vba or manualy push Down cells by useing insert cells pushdown (regardless if it moves anything Down, the scrollbar will be expanded).

    (Excel doesnt care that theres nothing in those cells, you can do this on a clean sheet whit nothing on it, just by inserting rows....)

    The fix is simply invokeing the check for last used cell or range by Excel.

    Just boot up the VBA editor and type

    Option Explicit ' This is usualy here by default

    Sub Marine() ' Sub Machinegun() Can work too, but sub marine is my favorite :o ActiveSheet.UsedRange 'This makes Excel check activesheets current used range and resets scrollbar.

    'Also noteably Excel seems to speed up whenever it has less used active rows\columns

    'regardless if anything is in use or not, im guessing it puts all "active" rows

    ' in auto calculation mode, hence slower~

    end sub



    Monday, September 2, 2013 9:54 AM
  • I've been having this problem randomly since I started using Excel 2010 about a year and a half ago. The cut/copy/paste option is set as recommended above. There are no objects embedded in the sheets in question. There is no weird cell alignment in the rows in question. There is no wrapping going on in the rows in question. The rows are never on-screen when the magic height adjustment occurs. I'll simply be scrolling down and BAM! there they are. It can be one or several. I have yet to deduce any set of actions that lead to this phenomenon. I have been a hardcore user of Excel for about 25 years now and never had this problem up until Excel 2010. I have no idea why it picks 409.5 as the row height. Hitting: Home | Format | Autofit Row Height sets the affected row back to normal, but I sure would like to see this fixed. It does not affect any of my coworkers to the best of my knowledge.
    Thursday, September 26, 2013 4:50 PM
  • I have pretty much the same experience of this issue as BarryKruse (Sep 26th Post). Hard core excel user for twenty years but only since excel 2010 do the magic rows appear at 409.5, usually three to six rows out of view until I scroll down, and nothing special about the sheet content or format or actions taken to point me in the direction of the cause.

    Its a Microsoft Mystery!

    Tuesday, October 22, 2013 9:04 PM
  • Just had a similar Excel problem with Office 2010 on Windows 2008 R2 Remote Desktop Server. The problem only affected one user, and seemed to affect .xls files but not .xlsx files.

    Fixed by resetting that users Excel settings.

    Logged in as the affected user:

    1. exit Excel
    2. run regedit.exe and navigate to the key HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Excel
    3. Rename that key to zExcel (just in case)
    4. exit regedit

    Usual cautions apply when editing the Registry (it's like heart surgery, one slip and you can kill the patient). Have a recent backup, know what you are doing, and be careful.

    Monday, February 3, 2014 1:45 AM
  • I have been working with Excel for 20years, and have been hit with this resizing of row height and also drawings or shapes, after opening an old XL97-2003 file.

    Chad's method below works!

    Please try the following to resolve the issue:
    1. Boot Excel 2010
    2. Open [Excel Options] dialog. ([File]-[Options])
    3. Select [Advanced] tab, turn on [Cut, copy and sort inserted objects with their parent cells] option. (In [Cut, copy and paste] section)

    *This will not resize rows that are currently set to 409.5 but I would like to know if this keeps rows from doing this in the future.
    1) I found that after opening the workbooks the row height and shapes are correct.

    2) Save the file, then save as to the new .xlsx format (for a macro free workbook)

    3) After reverting to former; turn OFF[Cut, copy and sort inserted objects with their parent cells] option. (In [Cut, copy and paste] section), and then opening the XL97-2003 files, the fault is still there.  For the newer xlsx files, though, the fault has gone.

    4) So yes, Chad, it does keep rows from doing this in future, if the newer file format is used.  Thanks.

    Chad's answer is "the answer"!



    Thursday, June 12, 2014 12:35 AM
  • Bingo!  Selecting the whole row and changing the vertical alignment to Top Alignment (Excel 2010 version) as Bruce79 recommended worked like a charm.
    Monday, January 11, 2016 8:07 PM
  • I had the same issue!  This worked for me!  Thank you!!  
    Wednesday, August 31, 2016 1:10 PM
  • Chad, Thank you for the response. It worked for me.

    I have provided some details and context below:

    I have been using the same file, shared between several users, for several months. We update daily and it has several buttons and macros in it. It's an Excel 97 compatible file, but I'm on Excel 2010, and the other users are on Excel 2013.

    Recently I experienced the row height error "fat rows", being resized at 409.5 row height, for no apparent reason. 

    In conjunction with this error, I started getting the "Fixed Objects will move" error and loop whenever I tried to save. To my knowledge, this was only happening in the one file. I didn't encounter this error in any other files I use in Excel. Due to the "fixed objects will move" error upon trying to save, i was never able to save, and always had to use task manager to kill Excel. 

    I don't know if any of that is relevant information, but maybe it'll help someone troubleshoot, as it seems that many people are having this issue.

    Anyway, I followed the steps you recommended and it seems to have solved the problem at least for now. Can you explain why this is related, and why this solution worked?

    Thanks,

    Brad


    • Edited by BradBakerW Tuesday, August 8, 2017 4:08 PM
    Tuesday, August 8, 2017 4:07 PM
  • We are running Office Professional Plus 2016 64bit on windows 10 enterprise v1703.  When working with older Excel 97-2003 files (xls).  We are seeing this problem - row height changing to 409.5.  None of the fixes in this thread worked so I ran Office repair on the offending client and issue is resolved.  Problem is - the issue will come back after a few days.  Constantly running Office repair is not a good solution.  So something on the client pc is getting corrupt for Excel.  We are in the process of converting the old xls files to xlsx to hopefully resolve this issue.
    Thursday, October 26, 2017 12:14 PM
  • A user complained about this issue. His rows were indeed expanding to 405.9. It turns out that he had drag-minimized a column to .06, rather than hiding it. All cells in the spreadsheet had wrap text, causing rows with data in the minimized column to expand to maximum height.  It's worth checking for minimized columns by checking for alphabetic continuity across all columns, then checking for data hiding in distant cells, before going into advanced solutions.  My user also had some data in white text, so it might be worth a double-check with select-all and formatting the font for audit.
    Wednesday, June 13, 2018 8:38 PM
  • Sorry Chad, I looked to see and found it was already turned on, the problem persists. After the row is shrunk to the correct size the data goes invisible until the now blank cell is accessed and returns to the 409.5 height. Aug '18.
    Wednesday, August 29, 2018 11:16 AM
  • Click the top left cell, above 1, left of A: this selects all cells.

    Click 'Top' in 'Alignment' click 'Bottom'

    All back to normal.

    Monday, September 10, 2018 8:33 AM
  • Seems as though the issue was caused but missing fonts for me. The document I was working on which was doing the same thing where it would change the cell height to 409.5 on opening on one PC. Turns out the PC was missing Arial Narrow font. I copied the fonts in windows/fonts from working PC to the one giving issues and works perfectly now. 

    • Proposed as answer by Rambo_Hamster42 Thursday, September 20, 2018 10:22 PM
    • Unproposed as answer by Rambo_Hamster42 Thursday, September 20, 2018 10:23 PM
    • Proposed as answer by PsychoPif Monday, September 9, 2019 6:20 PM
    Thursday, September 20, 2018 10:22 PM
  • So, I had a similar issue. There were many rows were double in height than other rows even though I went to every cell in the double height rows to see if there were any Alt/Return or spaces, etc. Sometimes I would double click to edit right in the cell and without changing anything in that cell and tab to the next cell would auto-height the row! Wow, I thought that would do it. It worked for several rows. Then found many more rows that didn't work. Then I though, hmmm, let's try this TechGuy2020! So, I selected the whole document with the little triangle thing in the left-hand corner. Then I clicked on Home/Wrap text and that fixed it. Obviously if you wanted wrapped text in things like the 1st row, you'll have to re-do that part. Otherwise that cleared up all the doubled row heights! Hope that helps you.
    Wednesday, December 5, 2018 5:25 PM
  • SOLUTION HERE!!!!  Before making changes, 

    - SELECT ALL

    - Click "Wrap text" twice.

    - All will work correctly......

    Monday, February 4, 2019 2:37 PM
  • Hello, this happened to a co-worker too. 

    Nothing suggested here fixed the issue.

    The only thing that worked is :

    1. SELECT ALL ROWS AND COLUMNS

    2. CHANGE THE STYLE (SELECT ANY STYLE) Normal for instance, it will restore all rows to a normal height, and wil be numbered again too.

    THIS HELPED ME, GIVE IT A TRY AND TELL ME,

    BEST REGARDS


    Arizona full of Beauty

    Saturday, March 23, 2019 5:12 AM
  • This worked for me; I had a column that was too "skinny" for its data, but was almost hidden.

    The MS moderator's answer didn't work for me (that box was already checked) but did work for others, so probably there are multiple causes/answers.

    Thursday, March 28, 2019 10:36 PM
  • Ha!  Using O365 in 2019, and the problem is/was still there.

    I could manually fix/change the wrong rows, but they would never saved as fixed. When I reopened, the bad rows were still there, at 409.5.

    Then I took your tip on vertical alignment. Saved. When I reopened, the bad rows were still 409.5

    Then I realized the wks was an xls (Microsoft Excel 97-2003 Worksheet).

    I fixed the bad rows using your tip, and saved them as a current flavor xlsx. So far, when I repeatedly close and reopen Excel, for xlsx, the rows are still fixed.

    Monday, June 10, 2019 7:16 PM
  • So, this was happening to my co-worker.  All of my team were working off individual sheets created from a master sheet.  Only he had this issue.  We all had the same column headings.  If I turned off wrapping in the offending row (1 in this case), it normalized the size. When I turned it back on for the row the height would expand.  Then I went cell by cell in row 1 and turned wrapping off.  1 cell caused the issue.  It just happened to be hidden.  Changing wrapping for the entire row didn't resolved the issue, but changing it for that individual cell did.  There were no unknown spaces before or after the text.  So, this is a solution without knowing what the underlying cause was.
    Friday, August 16, 2019 2:35 PM
  • Just letting you know that I had the same issue and changing the font to an installed one fixed the problem instantly.

    Monday, September 9, 2019 6:22 PM
  • This box was already checked in my excel options, but my excel sheet is exported from a software system that my firm uses, not created by cut and paste. I always thought that the exporting function is what caused the problem. It is VERY annoying! I have not found a fix except to manually adjust the row height. It seems to affect about 7 rows each time. 
    Friday, November 15, 2019 2:59 PM
  • BarryKruses's suggestion to highlight the offending Excel [2007, in my case] rows then click on Auto Fit Row Height was the solution that worked instantly for me: highlighting then setting the align to top shifted the text a little but not enough; middle and bottom align had no effect. Thanks man: Happy Christmas 2019. 
    Tuesday, December 24, 2019 7:21 PM
  • I've got a user with the same problem. Just started when she got a new PC. She can't adjust the row height because the sheet has objects on it, which don't move with the resized rows. So the resize doesn't work - get an error that the objects wouldn't fit on the sheet.

    We're on O365 and have the same version of Excel. I don't have this problem. She can open the file to view, but when she tries to edit, it gets screwy again.

    Monday, March 16, 2020 5:08 PM