none
Reporting Services Server cannot connect to the DPM Database RRS feed

  • Question

  • I am running System Center 2012 R2 DPM on a Windows Server 2012 R2 machine with SQL Server 2012 installed on the same system.  When I attempt to configure the E-mail option of a Scheduled DPM Report, I receive the following error:

    Reporting Services Server cannot connect to the DPM database.  ID: 3001

    NOTE: Options>SMTP Server and Options>Notifications have been configured and the "Send Test E-mail" function is successful.  I only receive an error


    • Edited by Robert Galvin Wednesday, November 20, 2013 8:07 PM Added ID: 3001 for more info
    Wednesday, November 20, 2013 8:06 PM

All replies

  • We have had several customers report this after installing DPM 2012 R2.

    To get past the below error while scheduling reports to be mailed.

    Reporting Services Server cannot connect to the DPM database.
    To repair the configuration, follow steps for repairing DPM from DPM Setup Help.
    ID: 3001

    Perform the following steps as necessary:

    1. Created a new local group called "DPMDBReaders$<DPMServerName>"
     2. Created a new user called, "DPMR$<DPMServerName>" and added this user to DPMDBReaders group that we created on step 1.
     3. Open SQL management studio and  add the DPMDBReaders$<DPMServerName  group to Logins under Security in SQL Management Studio.
     4. Modify the properties and under General – change the default database to the current DPMDB name.
     5. Under User Mapping – select the current DPMDB name and check the db_datareader checkbox.
     6. In SQL Management Studio, under Databases > DPMDB > Security > Users > "DPMDBReaders$<DPMServerName>", add the following missing stored procedures under Securables section:
          “Prc_MOM_Heartbeat_Get” and “prc_MOM_ProductionServer_Get”.     Click on the Grant – Execute for each one added.
     7. In SQL Reporting Services Configuration manager, under Report Manager URL - click on the link to open the portal (http://localhost/Reports)
           i. Click on the DPMReoprts_GUID to open the DPM reports.
           ii. Click on the DPMReporterDataSource
           iii. On the poperties page, enabled "Credentials stored securely in the report server" on DPMReporterDataSource configuration page and added “DPMR$<DPMServerName>” user account that we created in step 2.
           iv.  tick "Use as Windows credentials when connecting to the data source."
           v.   Click ‘Test connection’ on the same page to verify whether it can connect successfully.
     8.  In SQL Reporting configuration manager - change the Service Account to use build-in account: Network Service
     9. Reboot the DPM Server.
     10. You should then be able to schedule e-mailed reports.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.



    Thursday, November 21, 2013 12:31 AM
    Moderator
  • I have the same configuration as Robert and have also tested the SMTP setup successfully. I followed the steps you provided but I am still getting the same error.
    Wednesday, December 4, 2013 6:46 PM
  • Hello Mike,

    I ran through the steps, but when I got to step 7.v. and I clicked 'Test Connection', I received an error.  I double-checked the password and tried again with the same failure.  Is there an additional step?

    Cheers,

    Rob

    Friday, December 6, 2013 10:10 AM
  • HI,

    See what happens if you change the user name and password to that of the local administrator account. It should prompt to save password settings, say yes, then see if that test connection works - it should.  Now change it back to the DPMR$MachineName and password and see if it then works.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, December 6, 2013 3:38 PM
    Moderator