none
How to block usb masstorage device

    Question

  • 1. Windows server 2003 or 2008R2 group policy i want to block usb mass storage device only it means pendrive only not work in remaining all work in domain users only but in administrator all work. i want to work this all devices in domain users usb keyboard, mouse, printer, scanner, webcam, and including data card also its must data card work.  only pen drive not work in domain users help me from this issue i want apply this nearly 200 client pc's.

    2. windows server 2003 or 2008R2  how can i restore deleted ou  from active directory i want to restore ou from deleted list and  i know to restore single user account restore from ldp.exe  guide me

    Sunday, June 28, 2015 7:27 AM

Answers

  • You can try to edit the registry or configure the following policy setting to disable USB:

    User Configuration \ Administrative Templates \ System \ Removable Storage Access \ All Removable Storage classes: Deny all access

    You can use PowerShell command or do an authoritative restore for the deleted OU to restore it back

    Tuesday, June 30, 2015 1:16 AM
  • Hello,

    You need to apply the below mentioned GPO:

    For Computer: 

    User Configuration \ Administrative Templates \ System \ Removable Storage Access \Removable Disks: Deny Read Acces

    For user: 

    User Configuration \ Administrative Templates \ System \ Removable Storage Access \Removable Disks: Deny Read Acces

    Regards,

    Mitul aka v-2min

    Tuesday, June 30, 2015 1:59 PM

All replies

  • Enable USB Dongle (internet datacard) and block usb storage in windows domain?

    Sunday, June 28, 2015 10:29 AM
  • You can try to edit the registry or configure the following policy setting to disable USB:

    User Configuration \ Administrative Templates \ System \ Removable Storage Access \ All Removable Storage classes: Deny all access

    You can use PowerShell command or do an authoritative restore for the deleted OU to restore it back

    Tuesday, June 30, 2015 1:16 AM
  • Hello,

    You need to apply the below mentioned GPO:

    For Computer: 

    User Configuration \ Administrative Templates \ System \ Removable Storage Access \Removable Disks: Deny Read Acces

    For user: 

    User Configuration \ Administrative Templates \ System \ Removable Storage Access \Removable Disks: Deny Read Acces

    Regards,

    Mitul aka v-2min

    Tuesday, June 30, 2015 1:59 PM