locked
WSUS 6.3 is still asking for Report Viewer 2008 (which requires .NET 2.0) RRS feed

  • Question

  • PROBLEM: WSUS still requires Report Viewer 2008 to utilize reporting.  This Report Viewer version requires .NET 2.0 which is unacceptable in our production environment for security issues and the, now,  "unsupported software" problem.

    This is an issue known to Microsoft, the problem being raised in 2013.(https://social.technet.microsoft.com/Forums/en-US/f1031d4f-93c4-4508-9756-4d31a44d8da7/how-to-use-reporting-requires-report-viewer-2008-then-that-requires-net-20?forum=winserverwsus).  

    I cannot find any threads that offer a solution without using .NET 2.0

    We are using Server 2012 R2, SQL 2016 Express, and the WSUS role reports version 6.3.9600.16384.  I have tried the following Report Viewer versions:  2010, 2012, 2015.  WSUS console does not recognize any of them as being installed.  In my test enviroment I have installed .NET 2.0 and Report Viewer 2008 just to see if it worked (yes, it did work).

    I need a version of Report Viewer that runs on this system that 1) works, and 2) uses .NET 4.x

    Thanks for your guidance.

    Glenn



    • Edited by gpooleii Monday, June 19, 2017 6:08 PM
    Monday, June 19, 2017 5:56 PM

Answers

  • Hi Glenn,

    please read the following article, it will shed some light on your situation:

    https://support.microsoft.com/en-us/help/2696944/clarification-on-the-support-life-cycle-for-the-.net-framework-3.5,-th

    You can still run 2.0 and 3.0.

    Best regards,

    Andrei


    We could change the world, if God would give us the source code.

    Tuesday, June 27, 2017 9:25 PM

All replies

  • Hi gpooleii,

    Could you use .net 3.5 SP1, if yes, you may install Microsoft Report viewer 2008SP1 Redistributable:

    https://www.microsoft.com/en-sg/download/details.aspx?id=3841

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 20, 2017 9:13 AM
  • Anne, 

    In Server 2012 R2 I cannot install  .NET Framework Redistributable Package version 3.5 SP1 from the downloaded executable.  It forces me to install through Server Manager > Add Roles...  and that method must have .NET 2.0 and 3.0 checked to install.  Again, these older versions are unsupported, and having them installed violates our organizational policy.  Without this, of course, I cannot install Microsoft Report viewer 2008SP1 Redistributable

    So, using .NET 3.5 SP1 is not an option.  

    And it just begs the question, Why is WSUS reporting in 2017 only functional with deprecated software?

    Any other ideas?

    Glenn

    Tuesday, June 27, 2017 5:47 PM
  • Hi Glenn,

    please read the following article, it will shed some light on your situation:

    https://support.microsoft.com/en-us/help/2696944/clarification-on-the-support-life-cycle-for-the-.net-framework-3.5,-th

    You can still run 2.0 and 3.0.

    Best regards,

    Andrei


    We could change the world, if God would give us the source code.

    Tuesday, June 27, 2017 9:25 PM
  • Thanks Andrei, 

    That may be the answer I need.

    Regards, 

    Glenn

    Wednesday, June 28, 2017 12:38 PM
  • Hi Gelnn,

    Glad to hear you have found the answer you want, then, you may mark the useful reply as answer.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 4, 2017 2:14 AM