none
WS 2012 Eval to Licensed Reboot RRS feed

  • Question

  • I had deployed a Windows Server 2012 Datacenter Eval version to host two WS 2008 R2 SP1 virtual machines. I guess I cannot remember if I initially deployed the VMs to a Windows Server 2008 R2 + Hyper-V role or to the 2012 eval + Hyper-V... in any case... when I ran the instructions to activate the Windows Server 2012 + Hyper-V system to Retail licenses following http://technet.microsoft.com/en-us/library/jj574204.aspx, the subsequent reboot did not allow time for the virtual machines to save their state prior to shutting down the host system. The VMs both complained about unexpected shutdowns.

    The VM Settings > Management "Automatic Start Action" was set to 'Always Start' and "Automatic Stop Action" was set to 'Save', prior to 'upgrading' from Eval to Retail.

    Seems to me that the reboot process triggered by the Eval-to-licenses operation behaves differently than what I usually experience. For example: Running shutdown.exe /r /f against a Windows Server 2008 R2 SP1 hyper-v host with the Auto Start and Stop actions set accordingly works without a hitch, every time. So do restarts triggered by Windows Updates or the GUI. I can watch the VMs go into a saved state (from the hosts Hyper-V mgmt. console) prior to the host system restarting, and feel warm fuzzies when the host comes back online and the VM's logs show no indication of an unexpected shutdown. This behavior is clean, respectable, and trusted/expected.

    The behavior of Server 2012 Eval was more like "Shut down now and restart, and disregard service shutdown requirements.

    My 1st reaction to this is to always respond with an 'N' anytime a scripted or other one-off process like this asks me if it is okay to reboot my Hyper-V system; I'll run the reboot myself so I have a better sense that it will behave as I have learned to expect.

    Has something changed in the Windows Server 2012 shutdown/restart behavior, or is it DISM that is misbehaving somehow?

    Or, do the 6.1.7601.17514 integration components not play nice with WS 2012 Hyper-V?


    'Jonru' MCP

    Monday, February 4, 2013 4:37 PM