locked
Marvel Yukon Driver Problem Solved! RRS feed

  • Question

  • My Internet connection with Vista RC1 was very problematic, very slow and sites that used apsx or php would fail.  I could not access any MS help sites! 

    The good news is I located an updated driver on Marvel's web site and the problem is solved!  The driver is  yk60x86 dtd 8/7/2006.

     

     

    Monday, October 2, 2006 12:42 PM

All replies

  • I have quite the same problem (most of the sites don't load at all, except google and few others), but google is responding at top speed. For instance, my own website is really small (about 50kb), but won't load. I tried to ping most of the sites I use a lot, the ping works fine... But in IE7 or Opera the page just won't load. Amazon loads, I see the title, the layout of the page, but no image.

    I have 2 more PCs, one connected by Ethernet, the other by wifi, both works fine.

    I tried your driver, it didn't change anything for me.

    Help would be greatly appreciated (I can't even access windows update, so I'm quite sad)

    Monday, October 2, 2006 2:26 PM
  • What is your network adaptor?  Identify it through the device manager and check the manufacturer's web site for an updated Vista driver.  Are you getting any error messages? 
    Monday, October 2, 2006 6:01 PM
  • First, thank you for your quick answer, the Network Adaptator is recognized by Windows and Everest as Marvell Yukon 88E8036 PCI-E Fast Ethernet Controller, I tried different drivers, including the Yukon Windows Vista 32-bit Beta version, and now I've rolled back to Microsoft's version because it makes no difference.

    I have absolutely no error message, when I plug the ethernet cable, the "Network" icon changes to "Access: Local and Internet".

    My version of Vista is Vista Ultimate RC1 (don't know the build, but I downloaded it 2 days ago, I guess it must be the latest).

    Thanks again for taking the time, if you have more questions, please ask them, if I have to install any software on it, I can do it (I have a USB key).
    It's really annoying, I only have 3 days left to activate, I can do it by phone (I think), but if I can't use Internet, I lose so much of the fun of it... :(

    Monday, October 2, 2006 6:37 PM
  • The Marvel Vista driver should work with your adaptor, (I assume it is a built-in to the motherboard), so the next step would be to try another adaptor.  If you have a NIC card try disabling the built-in adaptor in your BIOS and adding a plug-in NIC.

    Do you have any problems accessing your local network or any shared drives?   Try opening a html file locally.

    Monday, October 2, 2006 7:04 PM
  • I forgot one really important thing: this PC is a laptop. So I can't open it (Whell, I could, physically, but I won't take the risk).

    I'll check if the local network works tomorrow, this is a good idea.

    One more thing, before I installed Vista, I ran Windows XP SP2 and the network just worked fine.

    Thanks again for helping.

    Monday, October 2, 2006 7:30 PM
  • I had the same problem, for a while there I thought the North Koreans did a DDOS on the MSN and Yahoo after anouncements buy the UN to tighten sanctions, J/K but those sites where down, I switched to my Intel adapter and everything worked like a champ very strange.
    Saturday, October 14, 2006 9:09 PM
  • That problem is specific to that adapter, I have the Marvell Yukon PCI-E Gigabit Ethertnet adapter onboard my Asus p5WD2 Premium motherboard. I could ping these websites, but they wouldent load, other sites were very slow, or would load partially and fail. It is a problwem related to the NIC drivers.
    Saturday, October 14, 2006 9:17 PM
  • ok, I gave up searching for a solution, my wifi connection works fine and that's enough for me.
    Sunday, October 15, 2006 8:23 AM
  • I have an ASUS P4P800 with built in ethernet, it comes up as:

    88E8001/8003/8010 PCI Gigabit Ethernet Controller

    Works great with RC1

     

    Sunday, October 15, 2006 9:43 PM
  • I've a Marvell Yukon PCI network card on my Mac Mini. I'm using Home Premium through BootCamp.

    The latest build 11.20.2.3 sounds a bit problematic. It worked fine until I restarted my computer. The network is not recognized with limited connectivity.
    Thursday, September 24, 2009 10:07 AM
  • Hi Kevin

    My pc config is like your config. but when I try to install marvel my pc suddenly hangs, and I can not install the driver, even I cant install Seven/Vista.

    Did you have the same problem?

    Tanx

    Thursday, February 10, 2011 6:26 AM