locked
SCCM 2012 R2 Client Doesn't Fully Install On Site Server RRS feed

  • Question

  • I'm migrating SCCM 2012 SP1 clients to a new SCCM 2012 R2 site server. They're all coming over and installing fully except for the Site Server itself. The Actions tab in Control Panel only displays 2 entries, Machine and User Policy. I've uninstalled and reinstalled several times but the result is the same. It's finding an MP and DP and the ClientIDManagerStartup.log is clean.Is there some trick to getting a client installed on a R2 Site Server?


    Orange County District Attorney

    Thursday, January 30, 2014 5:52 PM

All replies

  • When I see that happen on endpoints, I check two things.

    1. Provisioning mode
    HKLM\Software\Microsoft\CCM\CCMExec - Provisioning Mode needs to be set to false and SystemTaskExcludes need to be empty.

    2. Certificates

    3. Client is blocked in the console

    Please check that on your site server. It's a long shot since this is site server, but just take a look.

    Thursday, January 30, 2014 7:45 PM
  • There's no magic involved. Does ClientIDManagerStartup.log show that the client is registered? Do LocationServices.log and ClientLocation.log show that it found the MP (which is most likely installed on itself). Any errors in ccmmessaging.log?

    Torsten Meringer | http://www.mssccmfaq.de

    Thursday, January 30, 2014 8:28 PM
  • Thanks for the response back. Here's what I've found....

    1. Provisioning mode is set to false

    2. The client certificates are self-signed

    3. Client is not blocked in the console. The option is greyed out.

    ClientIDManagerStartup.log

    [RegTask] - On co-located client and site role. Posting async registration task.
    [RegTask] - Client is already registered. Exiting.

    ClientLocation.log

    shows it is being assigned the correct MP (itself) and the AD information is correct

    LocationServices.log

    I'm getting these interesting errors...

    Failed to send management point list Location Request Message to SMSSITESERVER.mydomain.com

    CCMMessaging.log

    Raising event:
    instance of CCM_CcmHttp_Status........
    {No reply message from Server. Server may be temporarily down or a transient network error.
    Post to http://SMSSITESERVER.mydomain.com/ccm_system/request failed with 0x8000000a.

    Finally, the CCM Notification Agent is Disabled on the client.

    I'm stumped on this one.


    Orange County District Attorney

    Thursday, January 30, 2014 9:25 PM
  • Hold on, are any other clients working fine, except the one on site server?

    Is that server assigned to correct boundary?

    Check if you can access these links:
    http://sccmserver.fqdn:80/SMS_MP/.SMS_AUT?MPCERT

    http://sccmserver.fqdn:80/SMS_MP/.SMS_AUT?MPLIST


    Thursday, January 30, 2014 9:35 PM
  • This has nothing to do with boundaries/groups.

    0x8000000a = The data necessary to complete this operation is not yet available.
    I've seen that happening in the past, but can't remember details. It was solved automatically though. See if there's something useful in ccmsetup.log and mpsetup.log.


    Torsten Meringer | http://www.mssccmfaq.de

    Thursday, January 30, 2014 9:56 PM
  • All other clients are fine, just the site server with the MP on it.

    I ran both links and I'm getting the correct .xml stuff back.


    Orange County District Attorney

    Thursday, January 30, 2014 10:01 PM
  • I checked both ccmsetup.log and mpsetup.log and their really clean. Everything looks good. I'm thinking I'll remove and then add back in the MP and see if that makes any difference.

    Orange County District Attorney

    Thursday, January 30, 2014 10:06 PM
  • I removed and reinstalled the MP but the results are still the same. I'm going to open a support case to get some help figuring this one out.

    Orange County District Attorney

    Friday, January 31, 2014 3:59 PM
  • Hi,

    Are there two adapters installed on the server? The package goes through another interface that it does not suppose to do. From the log, seems a Network Issue. Maybe you could utilize Network Monitor to check the packages when the client raises the instance trying to communicate with MP.


    Juke Chou

    TechNet Community Support


    • Edited by Juke Chou Monday, February 3, 2014 3:41 PM
    Monday, February 3, 2014 3:39 PM
  • No, just one adapter. I opened a case with Microsoft last week and they're doing their best to figure it out as well. Had them working on it for three hours Friday and still no idea. I'll post the solution when we find one.

    Orange County District Attorney

    Monday, February 3, 2014 3:44 PM