locked
STSADM - Object reference not set to instance of an object RRS feed

  • Question

  • Hi All,

    I need some help...

    I'm trying to copy an infopath form library from one site collection to another site collection on the same environment using the below stsadm to keep the metadata.

    stsadm -o gl-copylist -sourceurl "http://" -targeturl "http://" -includeusersecurity -nofilecompression

    and run into this error: "Object reference not set to instance of an object"

    The same form has been published & activated to the new site collection. 

    I've found this article and tried both using the admin and service account, which has db_owner access to the content db.

    http://praveenbattula.blogspot.com/2010/11/stsadm-object-reference-not-set-to.html

    I'm not sure what to do next.

    Any help is greatly appreciated.

    Thank you much!!!

    Thursday, October 6, 2011 9:42 PM

All replies

  • Hi,

    Turn on verbose mode of logging nad follow this process to see exactly where error comes.

    As a workaround try exporting and importing the list.

    I hope this will help you out.


    Thanks, Rahul Rashu
    Friday, October 7, 2011 5:29 PM
  • Thanks Rahuh for your help!

    I tried the export and import and it was the same way.

    Turned on the verbose logging and looked in the log... can't really get any info from the log.

    Any other ideas?

    Tuesday, October 11, 2011 9:50 PM
  • hi...

    You need permision -try do it with user system admin

    Yours,

    Roi

    my blog: http://iwillsharemypoint.blogspot.com/

    Wednesday, October 12, 2011 6:11 PM