locked
Sysprep fails for Windows 10 Preview Enterprise Client RRS feed

  • General discussion

  • Installed clean Enterprise Client inside Gen2 virtual machine on 2012R2 HyperV and trying to sysprep in order to create a template.

    Sysprep fails with error: A fatal error occurred while trying to sysprep the machine.

    Thursday, October 2, 2014 6:18 AM

All replies

  • Hi,

    have you Setup Homegroup before? Please stop Service "Windows Media Player Networkservice" and try again.

    Andi


    Ich bin x500, Ich darf das :)

    Thursday, October 2, 2014 7:54 AM
  • Hi,

    No, didn't make any config changes, only installed updates. Stopped service "Windows Media Player Network Sharing Service", the same error.


    Thursday, October 2, 2014 8:00 AM
  • Potentially stupid question - you are using the Sysprep build included in Windows 10, not one from 2012 R2, correct?
    Thursday, October 2, 2014 5:15 PM
  • Of course, running C:\windows\system32\sysprep\sysprep.exe inside VM which is Windows 10 Enterprise Preview.
    Thursday, October 2, 2014 5:20 PM
  • I'm getting the same thing.
    Thursday, October 2, 2014 5:24 PM
  • Hello,

    Do you have all the setup logs available for download?


    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, October 2, 2014 5:28 PM
  • Hi Darrell,

    Yes, I have the VM intact. Please send instructions what and how needs to be gathered.

    Thursday, October 2, 2014 5:31 PM
  • I found an error in setupact log.  The package "Microsoft.BingHealthAndFitness_3.0.4.212..." was installed for a user but not provisioned for all users.

    Then:  Failed to remove apps for the current user: 0x80073cf2

    I'm guessing this is the problem ;-).

    Thursday, October 2, 2014 5:51 PM
  • Just tested with another VM - Gen1 this time. Didn't install any updates or even reboot it, ran sysprep right after installation. Sysrep finished without errors.
    Thursday, October 2, 2014 5:57 PM
  • I ran the Powershell commands located here and now Sysprep works fine:

    https://4sysops.com/archives/how-to-remove-windows-8-apps-before-you-run-sysprep/

    Thursday, October 2, 2014 6:19 PM
  • Hello,

    All the log files from the panther folders?

    \windows\panther

    and

    \Windows\panther\sysprep


    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, October 2, 2014 7:59 PM
  • First, I want to say that I have successfully generalized an image using Sysprep and an Unattend.xml file in Windows 10.

    However, it seems to suffer from the exact same issues that Windows 8.1 had:

    • Trying to update Modern apps can break Sysprep.
    • Trying to uninstall Modern apps can break Sysprep.
    • Trying to add Modern apps can break Sysprep.
    • Trying to open some Modern apps can break Sysprep.

    What causes this?  I don't know because it is not easily repeatable.  Sometimes, doing the above will break Sysprep.  Sometimes, doing it will not break Sysprep.

    It's a mess and needs to be addressed by Microsoft.  Again, I want to repeat that this was an issue in Windows 8.1, as well.  This, unfortunately, is not new.

    Friday, October 3, 2014 12:28 AM
  • Tested SysPrep on windows 10 Technical Preview. Works just fine if done before joining the domain. Done Sysprep after installing Windows Updates, and RSAT tools, no problem. See this post for more details.


    Sam Boutros, Senior Consultant, Software Logic, KOP, PA http://superwidgets.wordpress.com (Please take a moment to Vote as Helpful and/or Mark as Answer, where applicable) _________________________________________________________________________________ Powershell: Learn it before it's an emergency http://technet.microsoft.com/en-us/scriptcenter/powershell.aspx http://technet.microsoft.com/en-us/scriptcenter/dd793612.aspx

    Friday, October 3, 2014 12:34 AM
  • Sam, that has been my experience, as well. However, it surprises me none that people are having the "A Sysprep failure occurred" because it was major issue on Windows 8.1, as well. And it was almost ALWAYS caused by the Modern apps. As I said, doing as little as opening certain apps can destroy the Sysprep process. Quite frankly, Microsoft has made Modern apps not play well with Sysprep; every little thing with the apps can make Sysprep fail.
    Friday, October 3, 2014 12:44 AM
  • Hello,

    Posting another request for logs if you are seeing this failure.

    Can we make all the logs available from the following folders?

    All the log files from the panther folders?

    \windows\panther

    and

    \Windows\panther\sysprep

    Would like to take a look at those logs?


    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, October 6, 2014 9:50 PM
  • Hi Darrell,

    In order to save time on the log file anonimization, is there a way to upload them to some private location instead of public forum?

    Tuesday, October 7, 2014 4:23 AM
  • Hello,

    Cab the files up and feel free to send them in email

    My First name and Last Name Initial at Microsoft.com for the email to send me.


    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, October 8, 2014 12:00 AM
  • In my experience Sysprep and Modern apps do not play well together. What I have found is that most of time it is due to the AppxPackage not being provisioned for all users or when removing the package it does not remove it for all users.

    I have been very successful with getting Windows 8.1 to Sysprep by removing the AppxPackages that are causing Sysprep  to fail (information is found in panther directory). Here is a KB that I found on this issue a while back. Most of the time this will resolve the issue.

    https://support.microsoft.com/kb/2769827?wa=wsignin1.0

    Personally  I tend to delete all of the AppxPackages since they will  be reinstalled when they are needed on the new image. Below is what I do before attempting to run sysprep. (This will remove all AppxPacakages for all users. If you do not want these deleted do NOT run  the command below)

    1. Login as every user that has ever logged in to the machine (Domain and local)

    2. Run Powershell as Administrator

    3. Run this command "Get-AppxPackage -AllUsers | Remove-AppxPackage"

    Once this has been run on all profiles that have logged in the machine I am able to run Sysprep with success.

    I have also followed the above steps on a couple Windows 10 VM's with success.

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, October 21, 2014 6:51 PM
  • I was having similar issue so i did multiple test on this.

    I notice i get that error if i setup operating system with a Live Account but sysprep works fine if operating system was setup wit local account.

    Sunday, November 9, 2014 7:38 PM