none
To Add email, department and title

    Question

  • Hi,

    I am not able to see email, department and title in the user datails in sharepoint level, but I have added these details in AD.

    How to add email , department , title property to the user details.

    Thanks & Regards,

    Tuesday, April 18, 2017 7:22 AM

Answers

All replies

  • Did you configure User Profile Service in your SharePoint farm.If its yes, check whether those property data available in User Profiles(Go to SharePoint Central Admin,Manage Service Applications, User Profile Services,User Profiles).In case its missing up try to do full User Profile Sync and see Whether your getting above property values...
    Tuesday, April 18, 2017 8:04 AM
  • Hi

    some properties are mapped by default

    https://technet.microsoft.com/en-us/library/hh147510.aspx

    And, properties you'me mentioned are there.

    Please check User profile sync between SP farm and AD


    Romeo Donca, Orange Romania (MCSE, MCITP, CCNA) Please Mark As Answer if my post solves your problem or Vote As Helpful if the post has been helpful for you.

    • Marked as answer by Jio333 Wednesday, April 19, 2017 12:53 PM
    Tuesday, April 18, 2017 8:23 AM
  • When I am doing manually in user profile service to particular user, It is display properties in the site  level.

    I wants to reflect all users, instead of doing one user.


    Tuesday, April 18, 2017 9:42 AM
  • Do "Start Full Synchronization" in User Profile Service Application.

    Follow below link to do...

    http://blog.sharedove.com/adisjugo/index.php/2012/07/23/setting-user-profile-synchronization-service-in-sharepoint-2013/

    • Marked as answer by Jio333 Wednesday, April 19, 2017 12:54 PM
    Tuesday, April 18, 2017 9:48 AM
  • Thanks for your reply..

    Please find below details, which i tried and error

    Try 1: Set-SPUser -Identity "i:0#.w|domain\user" -Web http://sites -title Accounts
    Try 2: Set-SPUser -Identity "i:0#.w|domain\user" -Web http://sites -SPS-JobTitle Accounts 

    Try 3: Set-SPUser -Identity "i:0#.w|domain\user" -Web http://sites -Title Accounts

    Error: Set-SPUser : A parameter cannot be found that matches parameter name 'Title'. 

    Tuesday, April 18, 2017 9:50 AM
  • There is no Title parameter for "Set-SPUser" as per MSDN Documentation Link...

    Try below script to sync users property from AD...

    $site = Get-SPSite http://your.site.collection
    $users = $site.RootWeb.Allusers
    foreach($user in $users){
      Set-SPuser -Identity $user -SyncFromAD
      write-host *
    }​

    Tuesday, April 18, 2017 10:49 AM
  • Hi,

    The Set-SPUser cmdlet doesn’t contain Title parameter: https://technet.microsoft.com/en-us/library/ff607827.aspx

    To display user details from AD, you need to sync users from AD to SharePoint user profile service application.

    Please try to start user profile sync again in CA, then user properties will be displayed correctly in SharePoint side.

    How to set up user profile sync for your reference:

    http://blog.sharedove.com/adisjugo/index.php/2012/07/23/setting-user-profile-synchronization-service-in-sharepoint-2013/

    Thanks,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, April 19, 2017 12:02 PM
    Moderator
  • Thanks for your reply.

    Now it is working..

    I was struck in, while run full synchronization and it was shows only old date not current date.

    Then i checked UPS related timer jobs and it was showing old date only.

    Then I did clearing configuration cache based on the below link.

    https://spcachecleaner.codeplex.com/

    • Marked as answer by Jio333 Wednesday, April 19, 2017 12:54 PM
    Wednesday, April 19, 2017 12:52 PM