locked
Client Push Problems RRS feed

  • Question

  • I am moving from SCCM 2007 to SCCM 2012 and I primarily use push installation for the clients.  With SCCM 2007, this process worked for the most part without issues.  However, with SCCM 2012, I am noticing some unexpected behavior - which has resulted in SCCM 2012 clients which were not targeted for the SCCM 2012 client push installation.  Here's an example of what is happening:

    - Restarted primary site server.

    - Logged in, started a command prompt and used "ipconfig /flushdns".

    - Ping a single computer (DANVERS04) to be used as a push installation target:

    - Start the Configuration Manager Console and target DANVERS04 with "Install Client".  Here is the relevant information from ccm.log:

    Execute query exec [sp_CP_GetNewPushMachines] N'CR1'~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.411+300><thread=932 (0x3A4)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097154721, 1~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.414+300><thread=932 (0x3A4)>
    Execute query exec [sp_CP_GetPushRequestMachine] 2097154721~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.529+300><thread=932 (0x3A4)>
    Successfully retrieved information for machine DANVERS04 from DB  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.530+300><thread=932 (0x3A4)>
    Execute query exec [sp_CP_GetPushRequestMachineIP] 2097154721~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.531+300><thread=932 (0x3A4)>
    Execute query exec [sp_CP_GetPushRequestMachineResource] 2097154721~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.533+300><thread=932 (0x3A4)>
    Execute query exec [sp_CP_GetPushMachineName] 2097154721~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.534+300><thread=932 (0x3A4)>
    Received request: "2097154721" for machine name: "DANVERS04" on queue: "Incoming".  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.537+300><thread=932 (0x3A4)>
    Stored request "2097154721", machine name "DANVERS04", in queue "Processing".  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.538+300><thread=932 (0x3A4)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097154721, 1~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.539+300><thread=932 (0x3A4)>
    ======>Begin Processing request: "2097154721", machine name: "DANVERS04"  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.541+300><thread=2488 (0x9B8)>
    Execute query exec [sp_IsMPAvailable] N'CR1'~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.543+300><thread=2488 (0x9B8)>
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.544+300><thread=2488 (0x9B8)>
    ---> Attempting to connect to administrative share '\\DANVERS04\admin$' using account 'DOMAIN\SCCMClient'~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:54.545+300><thread=2488 (0x9B8)>
    Submitted request successfully  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.541+300><thread=932 (0x3A4)>
    Getting a new request from queue "Incoming" after 100 millisecond delay.  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.544+300><thread=932 (0x3A4)>
    Waiting for change in directory "E:\Program Files\Microsoft Configuration Manager\inboxes\ccr.box" for queue "Incoming", (30 minute backup timeout).  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.546+300><thread=932 (0x3A4)>
    ---> WNetAddConnection2 failed (LOGON32_LOGON_NEW_CREDENTIALS) using account DOMAIN\SCCMClient (00000035)  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.803+300><thread=2488 (0x9B8)>
    ---> The device DANVERS04 does not exist on the network. Giving up~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.805+300><thread=2488 (0x9B8)>
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.806+300><thread=2488 (0x9B8)>
    ---> Attempting to connect to administrative share '\\Danvers04.DOMAIN.com\admin$' using account 'DOMAIN\SCCMClient'~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.807+300><thread=2488 (0x9B8)>
    ---> WNetAddConnection2 failed (LOGON32_LOGON_NEW_CREDENTIALS) using account DOMAIN\SCCMClient (00000035)  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.817+300><thread=2488 (0x9B8)>
    ---> The device Danvers04.DOMAIN.com does not exist on the network. Giving up~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.818+300><thread=2488 (0x9B8)>
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.819+300><thread=2488 (0x9B8)>
    ---> Attempting to connect to administrative share '\\DANVERS04\admin$' using account 'DOMAIN\SCCMClient'~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.820+300><thread=2488 (0x9B8)>
    ---> WNetAddConnection2 failed (LOGON32_LOGON_NEW_CREDENTIALS) using account DOMAIN\SCCMClient (00000035)  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.828+300><thread=2488 (0x9B8)>
    ---> The device DANVERS04 does not exist on the network. Giving up~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.830+300><thread=2488 (0x9B8)>
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.831+300><thread=2488 (0x9B8)>
    ---> Attempting to connect to administrative share '\\10.80.0.17\admin$' using account 'DOMAIN\SCCMClient'~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:56.832+300><thread=2488 (0x9B8)>
    ---> The 'best-shot' account has now succeeded 22 times and failed 14 times.  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:57.441+300><thread=2488 (0x9B8)>
    ---> Connected to administrative share on machine 10.80.0.17 using account 'DOMAIN\SCCMClient'~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:57.443+300><thread=2488 (0x9B8)>
    ---> Attempting to make IPC connection to share <\\10.80.0.17\IPC$> ~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:57.444+300><thread=2488 (0x9B8)>
    ---> Searching for SMSClientInstall.* under '\\10.80.0.17\admin$\'~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:37:57.488+300><thread=2488 (0x9B8)>
    ---> System OS version string "5.1.2600" converted to 5.10  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:38:00.537+300><thread=2488 (0x9B8)>
    ---> Service Pack version from machine "10.80.0.17" is 2  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:38:00.541+300><thread=2488 (0x9B8)>
    ---> OS is X86 bit Windows XP, Service Pack less than 3, returning as this is an unsupported OS  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:38:00.542+300><thread=2488 (0x9B8)>
    ---> Unsupported NT version "5.1.2600" on machine "10.80.0.17"  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:38:00.543+300><thread=2488 (0x9B8)>
    ERROR: Target machine (DANVERS04) must be Windows 2003 SP2 or Windows XP SP3 or newer.  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:38:00.750+300><thread=2488 (0x9B8)>
    ---> Deleting SMS Client Install Lock File '\\10.80.0.17\admin$\SMSClientInstall.CR1'~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:38:00.752+300><thread=2488 (0x9B8)>
    Execute query exec [sp_CP_SetLastErrorCode] 2097154721, 1305~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:38:00.939+300><thread=2488 (0x9B8)>
    ---> Removing request "2097154721", machine name "DANVERS04" - unsupported OS configuration.  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:38:00.942+300><thread=2488 (0x9B8)>
    Deleted request "2097154721", machine name "DANVERS04"  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:38:00.943+300><thread=2488 (0x9B8)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097154721, 3~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:38:00.944+300><thread=2488 (0x9B8)>
    Execute query exec [sp_CP_SetLatest] 2097154721, N'09/05/2012 18:38:00', 19~  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:38:00.946+300><thread=2488 (0x9B8)>
    <======End request: "2097154721", machine name: "DANVERS04".  $$<SMS_CLIENT_CONFIG_MANAGER><09-05-2012 13:38:00.949+300><thread=2488 (0x9B8)>

    According to the log above, \\DANVERS04 was not found on the network but since an IP address that it had previously used (on a DHCP based subnet of the corporate network) was responding, that system was targeted.  However, the IP address bolded above - 10.80.0.17 - belongs to another system:

    In this case, a system that I would not have targeted for SCCM 2012 client installation (because it is a Windows XP Service Pack 2 system) received an attempt and now DANVERS04 is marked as that system would have been.  I believe that the client installation should have stopped after the first "The device DANVERS does not exist on the network." rather than continuing the attempt on previously recorded IP addresses.

    Furthermore, in some cases, multiple IPs are attempted - such as for a system which is primarily VPN connection based.  This has caused at least five systems to have the SCCM client installed which were not targeted for the client.  I say "at least" five due to way the boundaries and collections have been created.  I'm sure that there are more clients which were not specifically targeted.

    This behavior did not exist in SCCM 2007 and I'm at a loss as to how to stop it now.

    Thanks in advance for any help!

    Wednesday, September 5, 2012 6:54 PM

All replies

  • Hi,

    How do your DNS setup looks like, what kind of scavenging times are you using in DNS? are you using WINS?

    I think I would create a support case around this becuase I agree it should not happen..

    Regards,
    Jörgen


    -- My System Center blog ccmexec.com -- Twitter @ccmexec

    Wednesday, September 5, 2012 7:26 PM
  • Thank you for your reply.

    As far as the network setup, I can confirm that both the SCCM 2007 server and SCCM 2012 server were/are setup identically (except for IP address) with regards to the network.

    This morning, I discovered an additional ten systems which have had the SCCM client installed successfully - which also had not been targeted for the client installation.  However, I cannot tell the exact number of failed installations without checking individual failures (too many failed clients at this point).

    Fifteen systems out of ~800 total clients (at this point) have been installed without "permission", and this primarily affects the DHCP based subnets and the VPN based clients.

    I'll be opening a support case in a bit.

    Thursday, September 6, 2012 2:21 PM
  • Hi Byron

    Did you get an answer from Microsoft support concerning this issus?

    I've had a similar incident: We pushed through the sccm 2012 mgmt console to certain clients (filtered) the new client and recognized that the client got installed onto additionally clients as well. The automatic client pusg is not enalbed. The audit log showed excalty the clients we have selected but within the SQL Table 'clientpushmachine' all clients we did not select were listed as well.

    Thanks for an answer

    Best Regards

    Wednesday, September 19, 2012 12:17 PM
  • So far I have received the following response:

    "Push does not currently validate the IP address from discovery data if connecting by name fails.  Product team will be taking another look at this."

    I would rather SCCM validate the IP address or fail the installation if connecting by name fails, rather than continuing to target other IP addresses and generating invalid, unreliable installation error codes.

    Thursday, October 4, 2012 1:23 PM