none
IIS SMTP TLS and SSL auto negotiate issues

    Question

  • I am running GFI mailessentials on a DMZ server.

    I am using IIS SMTP for this at the moment as I migrate to Exchange 2016 and re-do the server with Exchange 2016 Edge on it.

    But at this time when I enable outbound security TLS communication, all domains we communicate with that do not accept TLS start sending error:

    Message delivery to the host 'xxx.xxx.xxx.xx' failed while delivering to the remote domain 'email-xxxxx.com' for the following reason: The remote SMTP service does not support TLS.

    It seems that IIS SMTP is not auto negotiating the connection. When I enable TLS, it only uses TLS. I have tested this many different ways. Yes certificate is installed, as we have tested with 30+ different domains the difference with TLS enabled, and TLS disabled.

    Anyone run into this and know how to get this to auto-negotiate vs it just requiring TLS vs SSL.

    Thanks

    

    Monday, June 4, 2018 2:29 PM

All replies

  • Enter:

    Get-SendConnector | FL

    and post the relevant results here.  You can remove the results from irrelevant send connectors.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Monday, June 4, 2018 6:43 PM
    Moderator