none
System Center VMM 2016 error 20408 when adding virtual machine host

    Question

  • Error (20408)
    VMM could not get the specified instance Microsoft:{7172d33e-7a0b-4b32-b93b-e958f5cf7356} of class http://schemas.microsoft.com/wbem/wsman/1/wmi/root/standardcimv2/MSFT_NetAdapterRssSettingData on the server xxx. The operation failed with error NO_PARAM

    I have not found any solution to fix this error.

    Any help would be really appreciated!

    Thanks in advance


    • Edited by G-400 Friday, November 4, 2016 4:11 PM
    Friday, November 4, 2016 12:16 PM

All replies

  • Hi Sir,

    I have seen this issue in my lab when I try to add a hyper-v host which enabled two internal virtual switch .

    There are two virtual NICs in hyper-v host .

    My solution is to remove internal virtual switches only retain a phsyical NIC .

    Then it can be added into VMM 2016 .

    (Before that , I tried to run WinRM on SCVMM host to query that WMI , it gets the output correctly )

    Hope it is helpful to you .

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Sunday, November 6, 2016 2:59 PM
    Moderator
  • Hi Elton,

    Do you literally mean all the virtual network switches as seen under Virtual Switch Manager?

    Sunday, November 6, 2016 6:02 PM
  • Hi Sir,

    In my lab , I removed all of them then add the host again , it worked .

    But , there is only one physical NIC in that host .

    It seems that you have two dual port physical NICs .

    If it is possible to remove them ,please give it a try .

     

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 7, 2016 2:20 AM
    Moderator
  • Hi Sir,

    How are things going ?

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 14, 2016 2:26 AM
    Moderator
  • Hello,

    I am running into this on my lab as well. Not sure how well that will work as the SCVMM server is a VM running on said host. It would be impossible for me to add the host as the VM wouldn't have a virtual-network adapter.

    Is there another work-around? I cannot imagine that others including enterprises are going to install SCVMM and have to remove their virtual-networks as well just to get a host registered.
    Thursday, February 2, 2017 4:45 PM
  • Same problem in my production environment and still no fix found.
    Monday, March 6, 2017 11:51 AM
  • Having the same problem - any fixes found?

    Tim Starkenburg

    Friday, June 2, 2017 2:29 PM
  • Same problem occurred in an environment that was in-place upgraded from Windows Server 2012 R2 to Windows Server 2016.

    When an error occurred, executing "Get-NetAdapter | SELECT name, InterfaceGuid" on the Hyper-V host, specifying the virtual switch, and recreating the virtual switch in which the error occurred, it was confirmed that the VM host was successfully added I could do it.

    Saturday, June 17, 2017 9:07 AM
  • hi,

    same problem here:

    VMM is on last CU

    VMM is on ws2016 full patched

    hyperV host is on ws2016 full patched as well.

    any news on that issue?

    Tuesday, November 14, 2017 9:45 PM
  • I have performed below mentioned actions to resolve this issue.

    Remove  Proxy server IP address which was configured in browser.

    Restarted windows Management services on the Host.

    Wednesday, May 9, 2018 1:40 PM
  • Had an issue similar to this today. Same error ID, but different wmi error.  I had to update the VMM agent on the host.

    Open Fabric, under Servers, right click your host, and "Update Agent"

    Restarted my failed tasks and bingo.


    ZdPav

    Friday, January 11, 2019 7:55 PM
  • same happned to me with VMM 2019 i removed switch and recreated it again and worked fine

    mohamed

    Saturday, March 16, 2019 5:04 PM