locked
Shared Mailboxes don't work with Cached Mode RRS feed

  • Question

  • Environment:

    • Exchange 2016
    • Outlook 2016

    I created a shared mailbox and delegated myself permission.  The mailbox popped up in Outlook so I sent it an email.  The email didn't show up in the inbox.  I tried to send from the shared account and my inbox got the "you don't have send on behalf of" permission error.

    After a bit of research I found that turning of Cached Mode fixes the issue.  Alternatively (and more reasonable) I found that enabling the GPO for Disable shared mail folder caching also works.

    So... the question.  Is this intentional?  Is it a bug?  Is it a feature?  What is preventing Shared mailboxes from just... working?

    Monday, January 16, 2017 4:18 PM

Answers

All replies

  • When you are using Cached Exchange Mode, you also cache the Global Address Book (GAL) as an Offline Address Book (OAB). This also contains permissions. In your case, the OAB had not been updated yet either on the server, the client or both.

    For more background info, also see: https://www.howto-outlook.com/howto/oabupdate.htm



    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    • Marked as answer by SaintFrag Monday, January 16, 2017 5:10 PM
    Monday, January 16, 2017 4:44 PM
  • That makes sense.... mostly.  :)  It was over 48 hours since the permission was added, BUT I had the mailbox hidden from address lists (since it was a test mailbox).

    Thanks!

    Monday, January 16, 2017 5:10 PM
  • That makes sense.... mostly.  :)  It was over 48 hours since the permission was added, BUT I had the mailbox hidden from address lists (since it was a test mailbox).

    Ah, I've got a trick for that too ;-)
    Undeliverable error when sending on behalf of a hidden mailbox



    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    Monday, January 16, 2017 7:19 PM
  • I think I found a more... automatic method than that. Based on this Microsoft Support article, I tested the GPO option to Disable shared mail folder caching. 

    That seemed to fix the issue as well without the overhead.

    Thanks for your continued help!


    • Edited by SaintFrag Monday, January 16, 2017 7:34 PM bad bolding
    Monday, January 16, 2017 7:34 PM
  • That is indeed an alternative approach when you don't want to cache the mail folders of the shared mailbox at all. This means that you also can't work with the mailbox when you (or the servers) are offline.

    Keeping caching enabled will reduce network bandwidth and server resources and also makes the Outlook client more responsive. In general, you only want to disable caching when the shared mailbox is really large and you only have little space available on you disk and can't set any sync filters.



    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    Monday, January 16, 2017 8:37 PM