none
Windows Server 2012 "Remote Desktop licensing mode is not configured" it is and I have tried everything .

    Question

  •  I have been told it is a bug in the grace period. I have removed the key from the registry , but still no go. I know that I am not rhe only one with this issue. Has anyone been successful clearing this message ? 

    Frank E. Merkel Systems/Network Administrator Dannible & McKee LLP Syracuse, NY

    Wednesday, August 14, 2013 2:00 PM

Answers

  • Hi Frank,

    On your RD Licensing server, please make sure that you Activate it and install your purchased RDS CALs using RD Licensing Manager (licmgr.exe).  If you have not installed RD Licensing you will need to do that using Server Manager.  Please also make sure that you have Specified the correct name/IP address of your RD Licensing server.

    Also, you should point the RDS/TS server to use the RD Licensing server and select appropriate per device or per user license mode.

    Hope this helps.


    Best Regards
    Jeremy Wu

    • Marked as answer by Frank Merkel Tuesday, August 20, 2013 1:37 PM
    Friday, August 16, 2013 7:00 AM
    Moderator
  • Thank you Mr. Wu, but I had already done that , The fix was to go into Group Policy Editor and specify the name there. MicroSoft was pretty cool about this and did not charge me an incident. I did not do this because it should have written to the policy during the RDP Services config. That is what was so frustrating, that should have happened during the install....it is a bug....but it is fixed now and ready to go

     

    Frank E. Merkel Systems/Network Administrator Dannible & McKee LLP Syracuse, NY

    • Marked as answer by Frank Merkel Tuesday, August 20, 2013 1:41 PM
    Tuesday, August 20, 2013 1:35 PM

All replies

  • Hi Frank,

    On your RD Licensing server, please make sure that you Activate it and install your purchased RDS CALs using RD Licensing Manager (licmgr.exe).  If you have not installed RD Licensing you will need to do that using Server Manager.  Please also make sure that you have Specified the correct name/IP address of your RD Licensing server.

    Also, you should point the RDS/TS server to use the RD Licensing server and select appropriate per device or per user license mode.

    Hope this helps.


    Best Regards
    Jeremy Wu

    • Marked as answer by Frank Merkel Tuesday, August 20, 2013 1:37 PM
    Friday, August 16, 2013 7:00 AM
    Moderator
  • Thank you Mr. Wu, but I had already done that , The fix was to go into Group Policy Editor and specify the name there. MicroSoft was pretty cool about this and did not charge me an incident. I did not do this because it should have written to the policy during the RDP Services config. That is what was so frustrating, that should have happened during the install....it is a bug....but it is fixed now and ready to go

     

    Frank E. Merkel Systems/Network Administrator Dannible & McKee LLP Syracuse, NY

    • Marked as answer by Frank Merkel Tuesday, August 20, 2013 1:41 PM
    Tuesday, August 20, 2013 1:35 PM
  • Hi Frank,

    Thanks for the update and I am glad to hear that the issue has been resolved.

    Cheers!


    Best Regards
    Jeremy Wu

    Wednesday, August 21, 2013 8:06 AM
    Moderator
  • Hey Frank

    Could you please describe the solution to this problem more detailed? I got the same problem but couldn't find anything beside the temporary solution of deleting the registry key.

    Thanks and best regards

    Nicolaj

    Tuesday, May 20, 2014 3:25 PM
  • I'm getting the same thing.. very frustrating!!
    • Proposed as answer by vilcadude Saturday, November 15, 2014 3:38 AM
    Tuesday, May 20, 2014 4:14 PM
  • Don't you just hate it when the Asker finds a solution and doesn't let on what it was?

    KUDOS to Justin Bennett for posting this (Only a day after NicolajA and Saber Kin wanted to know

    http://justin-bennett-msjc.blogspot.com.au/2014/05/configure-server-2012-and-2012-r2-with.html

    "Update the licensing
    mode (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal
    Server\RCM\Licensing Core\LicensingMode) registry key:
    Enter 2 for per device mode or 4 for per user mode (By default it is 5 and is invalid)"

    AND

    "Add the following LicenseServers key
    (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers) and
    create the Multi_SZ String Value SpecifiedLicenseServers
    (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers\SpecifiedLicenseServers)"


    Worked for me!
    • Proposed as answer by vilcadude Saturday, November 15, 2014 3:41 AM
    • Edited by vilcadude Saturday, November 15, 2014 3:42 AM Grammar
    Saturday, November 15, 2014 3:41 AM
  • @ Frank

    Create a new policy or use Domain policy.

    Once you decide, go to Computer Configuration / Administrative Templates / Windows Components / Remote Desktop Services / Remote Desktop Session Host / Licensing

    Configure / Enable:

    1. Use the specified Remote Desktop license servers. (add you license server in "license servers to use:")

    2. Set the Remote Desktop licensing mode. (specify the licensing mode, Per user or device)

    All done!


    Tuesday, February 10, 2015 10:37 PM