none
How to configure Https in Project server 2010. RRS feed

  • Question

  • HI,

    Can i any one help me,

    How to configure Https in Project server 2010.

    My server farm is 1.Test1(App & Wfe) 2. Test2(App & Wfe) 

    Both are load balanced  wit NLB as abc.hyd.in

    DO i need to Install certificate in two servers   Test1 & Test2 or one server is enough ?

    Can any one please provide me a link to configure Https for project server 2010 for Two  Farms Servers.


    Thank You, Kumar KSV

    Thursday, September 4, 2014 6:44 AM

Answers

All replies

  • There is no special configuration for Project Server to have the IIS enabled, it follows the typical sharepoint SSL enablement, we might need some mor edetails on how your NLB is done is it hardware based, software based ? it all depends how you want to architecht the system, you can enable the Https either on NLB or WFE, again depending upon how you want to enable it, you will need to install the certificates on both WFE or on NLB

    Follow the blog below to configure the SSL:

    http://epmxperts.wordpress.com/2011/03/05/extend-same-project-web-app-instance-for-different-protocol-authentication-mechanism/

    http://blogs.msdn.com/b/sowmyancs/archive/2010/02/12/how-to-enable-ssl-on-a-sharepoint-web-application.aspx 

    http://www.sharepointconfig.com/2010/03/configuring-a-sharepoint-website-to-allow-ssl-connections/ 


    Thanks | epmXperts | http://epmxperts.wordpress.com

    • Marked as answer by kumar ksv Wednesday, October 22, 2014 9:12 AM
    Thursday, September 4, 2014 2:17 PM
    Moderator
  • EpmXperts,

    Thank you,

    I have added the URL in the AAM, in IIS i didn't binded 443 only 80 is there.

    the URL was added in the NLB by the network team.

    the certificate was wild card certificate.

    Now when i try to open the Https://abc.hyd.in/pwa from internet the site is opening with home page but if click on any link (Ex: Project center, server settings ) the url is redirecting to Http://abc.hyd.in/pwa and page is not opening

    similar issue was happened to this person (http://social.microsoft.com/Forums/en-US/bcfdd6e0-f061-412c-8e33-c0ff658008fd/project-server-with-sharepoint-2010-https-ssl-setup-issues?forum=projserv2010setup)

    How can i FIX this issue  can you Please help me.




    Thank You, Kumar KSV

    Friday, September 5, 2014 5:05 AM
  • Can you give us more details around how the Web app has been configured, was it setup for SSL while extending ? if the AAM is configured properly it should work, how was NLB was configured

    Add 443 port site binding in IIS, 443 is the SSL port, accordingly get the URL in NLB

    Let us know any other details we might be missing here and we should be able to help


    Thanks | epmXperts | http://epmxperts.wordpress.com

    Friday, September 5, 2014 12:42 PM
    Moderator
  • I didn't Extended Web application is it mandatory to extend the web application ?

    AAM: default :http://test1

            Intranet : http://abc.hyd.com

            Internet: https://abc.hyd.com

    I have added the 443 for one server Test1 still its redirecting to http.Do i need to install  & and add certificate in the second server Test2 also ?


    Thank You, Kumar KSV

    Friday, September 5, 2014 12:53 PM
  • No its not mandatory to extend but while the web app was created was the Security configuration set to SSL ? 

    try checking your configuration w.r.t. to the steps mentioned in the blog in above post and make sure all the configurations are performed accordingly


    Thanks | epmXperts | http://epmxperts.wordpress.com

    Friday, September 5, 2014 12:57 PM
    Moderator
  • When creating web application  Use Secure Sockets Layer (SSL) was set to NO Do i need to extend and make it as YES ?

    I will Check all the configurations once.

    Thank you.


    Thank You, Kumar KSV

    Friday, September 5, 2014 1:25 PM
  • Yes you would need to change it to SSL that's why its redirecting to http

    Thanks | epmXperts | http://epmxperts.wordpress.com

    Friday, September 5, 2014 1:43 PM
    Moderator
  • HI epmXperts,

    I have Extended the web application to https, but still i am facing same redirection issue Home page is opening with https:/abc.hyd.in/pwa  if i click on any link in the https: /PWA url its redirecting to Http & page cannot be found issue i am getting.

    i have found one more thing after redirecting to http://abc.hyd.com/pwa/projects.aspx  if  i change manually  the url to  https://abc.hyd.com/pwa/projects.aspx  i am getting this error "cannot communicate with the server. verify your connection and try again "


    Thank You, Kumar KSV


    • Edited by kumar ksv Monday, September 22, 2014 5:51 PM
    Monday, September 22, 2014 5:49 PM
  •  Kumar

    To update all the links, set https URL address as default in AAM configuration on web application


    Hrishi Deshpande Senior Consultant


    Monday, September 22, 2014 8:55 PM
    Moderator
  • Hrishi,

    I have replaced default AAM  with https://abc.hyd.com but no luck ,still it is redirecting to Http....

    the certificate was installed in the NLB do i need to install certificate in the sharepoint servers my farm is ( app/wfe=test1 and app/wfe=test2 load balanced with NLB).


    Thank You, Kumar KSV


    • Edited by kumar ksv Tuesday, September 23, 2014 12:37 PM
    Tuesday, September 23, 2014 4:33 AM
  • Finally i resolved this issue,

    This was an NLB issue we have installed Certificate on servers directly rather installing in NLB now  HTTPS is working fine.


    Thank You, Kumar KSV


    • Marked as answer by kumar ksv Wednesday, October 22, 2014 9:15 AM
    • Edited by kumar ksv Wednesday, October 22, 2014 9:15 AM
    Wednesday, October 22, 2014 9:15 AM