locked
Windows 2008 r2 WSUS port 8530 RRS feed

  • Question

  • WINDOWS 2008 R2

    new install of WSUS server 3.2.7600.251 want to change the port to 8530 from 80

    But when I open command prompt and run wsusutil usecustomport true.....I get error :

    C:\Program Files\Update Services\Tools>wsusutil usecustomwebsite true
    Fatal Error: Exception has been thrown by the target of an invocation.

    Sunday, March 8, 2015 1:09 AM

Answers

  • Hi,

    Did you stop the WSUS service before you change the port?

    If no, please try to stop the WSUS service with the command below first:

    • net stop wsusservice

    After change the port, run the command net start wsusservice to start he WSUS service.

    Besides, do not forget to change the WSUS GPO settings.

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Tuesday, March 10, 2015 7:37 AM

All replies

  • What membership does that account that's being used to run wsusutil have? (local admin, WSUS administrators, etc?)

    Also, is there anything else installed on that server? Any changes to IIS lately?


    If you find the answer of assistance please "Vote as Helpful" and/or "Mark as Answer", where applicable. This helps others to find solutions for there issues, and recognises contributions made to the community :)


    Monday, March 9, 2015 1:51 PM
  • This is easiest to set during the install of WSUS, you are prompted to use the default website on port 80 or create another site on pot 8530. Considering how little there is to configure within WSUS, I would recommend a uninstall / re-install using the appropriate option.
    • Proposed as answer by fairchildb Tuesday, April 4, 2017 12:33 PM
    Monday, March 9, 2015 4:02 PM
  • Hi,

    Did you stop the WSUS service before you change the port?

    If no, please try to stop the WSUS service with the command below first:

    • net stop wsusservice

    After change the port, run the command net start wsusservice to start he WSUS service.

    Besides, do not forget to change the WSUS GPO settings.

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Tuesday, March 10, 2015 7:37 AM
  • The port is changed on the wsus server 8530 - wsus shows that date/time they contacted the server.  However, when I ran CHECK ONLINE FOR UPDATES FROM WINDOWS UPDATES, there were recommended 18 updates to install on Windows 8.1 machines  and 1 Recommended update for Windows 7.

    normally I look for COMPUTERS NEEDING UPDATES ....but WSUS is not saying they need any updates.


    • Edited by cdaarnold Thursday, April 9, 2015 3:30 AM
    Thursday, April 9, 2015 3:27 AM
  • That discrepancy is usually because not all relevant "Classifications" are selected in the WSUS Options. 

    Rolf Lidvall, Swedish Radio (Ltd)

    Thursday, April 9, 2015 8:14 AM