none
Microsoft R Open and Xeon Phi coprocessor and Windows RRS feed

  • Question

  • Hi all, 
    This is likely a dumb question, but I am not a programmer. 

    I have gone through the process of purchasing and installing a Intel Xeon Phi coprocessor in my PC. I have gone through all the installation without any serious difficulties, and get to the point where it is online (status: mic0 online). So everything there seems to be good.

    Microsoft R Open does not seem to want to offload onto the Xeon Phi automatically. So I am essentially about halfway down this blog:
    http://blog.revolutionanalytics.com/2015/05/behold-the-power-of-parallel.html
    where I am supposed to set some Environment Variables. (I think and hope.)

    Question(s):
    Are the Environment Variables set on the Windows system? I.e. Windows+break --> Environment Variables (Is this right?)
    Are the Environment Variables set in R, somehow?
    Are the Environment Variables inserted into the R Open code and recompiled?

    Thank you for your time and patience,

    Charles

    Tuesday, October 18, 2016 2:06 PM

Answers

  • Environment variables should be set in Windows (Control Panel>System and Security>System-->Advanced system settings -->Environment variables; your keyboard shortcut is probably bringing up the same dialog). Environment variables can be set within R using the Sys.setenv() function, but this usage applies only to the current R session. For consistent use of your Xeon Phi, you'll want to set them in Windows.

    Hope this helps!

    Rich Calaway

    Microsoft R Release Manager

    Monday, October 24, 2016 11:55 PM

All replies

  • Environment variables should be set in Windows (Control Panel>System and Security>System-->Advanced system settings -->Environment variables; your keyboard shortcut is probably bringing up the same dialog). Environment variables can be set within R using the Sys.setenv() function, but this usage applies only to the current R session. For consistent use of your Xeon Phi, you'll want to set them in Windows.

    Hope this helps!

    Rich Calaway

    Microsoft R Release Manager

    Monday, October 24, 2016 11:55 PM
  • Hi Rich,

    I have set the environment variables in Windows. Now the automatic offload seems to be working. Thank you.

    Unfortunately, I want to  use the cores directly (Monte Carlo studies) since the MKL offload is not terribly hefty. Does anyone has any suggestions on how to get R (parallel packages)  to detect the cores on the Xeon Phi so that they can be used directly? I am all ears. 

    Thanks again,

    Charles

    Wednesday, October 26, 2016 9:17 PM
  • Objective: Run R in the Xeon Phi uOS to exploit the number of cores (and threads) directly. 

    This turns out to be much more complicated and requires that you know Linux programming and have access to appropriate compilers. This is because R needs to be recompiled for the Xeon Phi environment. 

    This is beyond my capabilities at this time, so I have abandoned this project. 

    Thank you, Rich for your earlier comment.

    Charles

    Saturday, October 29, 2016 11:48 AM