none
Does ROpen CRAN updates break current stable users? (RExcel) RRS feed

  • Question

  • Just wondering as I had RExcel working on 3.2.5 with the statcom and rcom packages and then it failed and rcom could no longer be found this was post June 22. Does CRAN stay sync'd to the user version implementation of ROpen being used?

    As R for Excel now requires 3.0.1 http://rcom.univie.ac.at/download.html . Is there a way to keep R and Excel integration tight so that it will always work? Or perchance is there a better package for R and Excel integration?

    EDIT

    Actually rcom is not available for 3.3.0 following these instructions is there anyway to get this integration working without using the CRAN R version?

    > options(install.packages.check.source = "no")
    > install.packages(c("rscproxy","rcom"),repos="http://www.autstat.com/download",lib=.Library,type="win.binary")
    trying URL 'http://www.autstat.com/download/bin/windows/contrib/3.3/rscproxy_2.1-1.zip'
    Content type 'application/zip' length 72406 bytes (70 KB)
    downloaded 70 KB
    
    package ‘rscproxy’ successfully unpacked and MD5 sums checked
    
    The downloaded binary packages are in
            C:\Users\Sayth\AppData\Local\Temp\RtmpEhwpAc\downloaded_packages
    Warning message:
    package ‘rcom’ is not available (as a binary package for R version 3.3.0) 
    




    • Edited by SaythJ Wednesday, August 3, 2016 12:56 PM
    Wednesday, August 3, 2016 12:33 PM

All replies

  • It looks like the Statconn folks didn't build a binary version of rcon for R 3.3.0, so it looks like your best bet is to wait for Microsoft R Open 3.3.1 which will be released soon.
    Wednesday, August 3, 2016 3:46 PM