none
Shared volume backup crashes DPMRA agent RRS feed

  • Question

  • Hello,

    currently a backup of one of my shared volumes on a clustered fileserver crashes the DPMRA agent and would like some pointers what could be the issue.

    I am backing up a shared volume (located in a 2012R2 Fileserver cluster) using DPM 2012R2.
    The volume is a shared VHDX, attached to 2 the 2 cluster nodes. Backup happens from with the VM.
    The cluster has 2 shared volumes: One can be backed up without issue, but the other one causes the DPMRA service to crash.

    Faulting application name: DPMRA.exe, version: 4.2.1553.0, time stamp: 0x57bade7a
    Faulting module name: FileWriterHelperPlugin.DLL, version: 4.2.1553.0, time stamp: 0x57bade78
    Exception code: 0xc0000005
    Fault offset: 0x000000000005c7c2
    Faulting process id: 0x5c0
    Faulting application start time: 0x01d2c80afd6b275c
    Faulting application path: C:\Program Files\Microsoft Data Protection Manager\DPM\bin\DPMRA.exe
    Faulting module path: C:\Program Files\Microsoft Data Protection Manager\DPM\bin\FileWriterHelperPlugin.DLL
    Report Id: 080c4b2c-3400-11e7-80d2-001dd8b71cc6
    Faulting package full name: 
    Faulting package-relative application ID:

    I checked the agent errlog, but that gave me nothing.
    Here the last few lines:

    13D0	09D4	05/08	09:39:23.848	18	dsmsendersubtaskbase.cpp(47)	[0000000000CE28C0]	EC2C7285-7C47-4C70-858A-527FC90568CA	NORMAL	CDsmSenderSubTaskBase: constructor [0000000000CE28C0] openovl[0000000000CE2A40] msgovl[0000000000CE2B40] closeovl[0000000000CE2A90]
    13D0	09D4	05/08	09:39:23.884	31	vsssnapshotrequestor.cpp(1436)		EC2C7285-7C47-4C70-858A-527FC90568CA	NORMAL	ssLocalVolumeGuid = [\\?\Volume{48dd3b5a-b233-11e6-80cb-001dd8b71cc6}\], ssClusterVolGuid=[\\?\Volume{48dd3b5a-b233-11e6-80cb-001dd8b71cc6}\]
    13D0	09D4	05/08	09:39:23.915	31	basewriterbackuphelper.cpp(370)		EC2C7285-7C47-4C70-858A-527FC90568CA	WARNING	Assertion Failure :: false
    13D0	09D4	05/08	09:39:23.922	31	basewriterbackuphelper.cpp(317)		EC2C7285-7C47-4C70-858A-527FC90568CA	WARNING	Assertion Failure :: pConfigureInfo != NULL
    13D0	09D4	05/08	09:39:23.922	18	filereplicationutils.cpp(89)	[00000000037DE990]	EC2C7285-7C47-4C70-858A-527FC90568CA	NORMAL	Hr: = [0x00000000] Get delta usn corresponding to the snapshot for VolumeName - \\?\Volume{48dd3b5a-b233-11e6-80cb-001dd8b71cc6}\
    13D0	09D4	05/08	09:39:23.932	22	watsonintegration.cpp(73)		EC2C7285-7C47-4C70-858A-527FC90568CA	NORMAL	Inside Watson Handler
    13D0	09D4	05/08	09:39:23.932	22	watsonintegration.cpp(116)		EC2C7285-7C47-4C70-858A-527FC90568CA	CRITICAL	Raising Watson for process

    I tried:

    • Consistency check
    • Removing the drive from the protection group and re-adding it
    • Restarting the server nodes of the cluster
    • Restarting DPM

    None of these steps solved the issue.

    I would very much appreciate some suggestions as to what could be causing the issue.

    Thanks in advance
    Paul


    • Edited by PauloW4 Tuesday, May 9, 2017 7:54 AM
    Tuesday, May 9, 2017 7:54 AM

All replies