locked
SMTP not working for email addresses that match local domain RRS feed

  • Question

  • Hello,

    I have installed SMTP services on a Widows 2012 R2 and it relays emails (scanner, fax, etc.) properly as long as the email's domain name does not match the local AD. For example my server is ServerName.LocalDomainName.com and I will not relay an email to email@LocalDomainName.com. The email server was internal but was uninstalled and it is now hosted at office365.

    Any suggestion will be appreciated.

    Thank You.

    Friday, November 30, 2018 10:40 PM

Answers

  • Thank you for your replies. After some trial and error the solution was to add an MX record to the local AD's DNS pointing to the office 365 servers.

    • Marked as answer by perland Saturday, December 1, 2018 4:52 AM
    Saturday, December 1, 2018 4:52 AM

All replies

  • Sounds like you might heed a split brain setup.

    https://blogs.technet.microsoft.com/teamdhcp/2015/08/31/split-brain-dns-in-active-directory-environment-using-dns-policies/

    might also reach out to smtp experts in microsoft official forums over here.

    https://forums.iis.net/

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Friday, November 30, 2018 11:52 PM
  • I would set up Email to send as your Domain you use for Office 365. MyFax@MyDomain.com would be in the from address. 

    Make sure your external DNS on your Domain is set up with a SPF record. This record sets an extra IP address that is allowed to send email to your Exchange environment. This SPF record should contain your external IP address provided by your ISP.

    https://www.godaddy.com/help/add-an-spf-record-19218

    P.S. Make sure to set your firewall to only allow outbound data from the SMTP server on port 25.
    • Proposed as answer by ComputerScott Saturday, December 1, 2018 12:19 AM
    • Edited by ComputerScott Saturday, December 1, 2018 12:35 AM
    Saturday, December 1, 2018 12:18 AM
  • Thank you for your replies. After some trial and error the solution was to add an MX record to the local AD's DNS pointing to the office 365 servers.

    • Marked as answer by perland Saturday, December 1, 2018 4:52 AM
    Saturday, December 1, 2018 4:52 AM
  • Hi,

    I am glad to hear that your issue was successfully resolved. If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Zoe


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, December 3, 2018 1:57 AM
  • Hi,

    Just to add to this is if anyone comes across the issue as i did.
    You can also add your 365 server "<domain>.mail.protection.outlook.com" into the smart host advanced section of the IIS SMTP settings (that is if you're using IIS6 as the SMTP server) - this worked for me.

    Steve


    • Edited by shiest00 Friday, October 11, 2019 1:31 PM
    Friday, October 11, 2019 1:30 PM