locked
Upgraded to windows 10 - Cannot access my NAS. RRS feed

  • Question

  • Hello.

    I have tried my best to find the answer by searching, but all the fixes that have been presented does not work.

    The problem is that I cannot access my NAS anymore.

    When I try and add a network place OR use explorer to access it I get:

    "Windows cannot access \\192.168.1.51

    Check the spelling or the name. Otherwise, there might be a problem with your network...

    Error code: 0x80004005

    Unspecified error"

    When searching for what that error code mean, it states it something with windows activation. When I check, it says "windows is activated" . Now, just for the record, I have a legit, bought copy of windows 8.


    I can ping the local IP, I have also tried and add it via its hostname, same problem.

    What I have done:

    -Added the account that I have created on the NAS to "windows credentials"

    -Disabled IPv6

    -Some site suggested that it could be an issue with PIN-login. But I dont have PIN login active and i have LOCAL account, not windows account.

    -Double checked that I have joined a workgroup and that windows share is active(it is)

    Anyone have a solution for this issue?!

    I want to be able to access my stuff without having to add a FTP network place.

    All help is very appreciated.

    UPDATE - 2015-08-04:

    Now it actually shows up in "NETWORK" in windows explorer.

    But when I try and access it I get:

    "windows cannot access \\XXXXXFS01

    Check the spelling of the name. Otherwise, there might be a problem with your network...

    Error code: 0x80070035"


    Tuesday, August 4, 2015 12:44 PM

All replies

  • 0x80004005 = access denied/insufficient rights/wrong permissions

    Would look at something blocking the way firewall or access. Try making a network map connection using different credentials. (one that have full access on the NAS)

    0x80070035 =  network path not found

    This probably means that when you go with the name it doesn't resolve to the right IP

    Tuesday, August 4, 2015 12:59 PM
  • Iam trying to connect with the admin account, cannot have more access then him :P

    I have made 0 changes to the access rights on the NAS for several weeks. This issue happend the same second windows 10 came online.

    How can I connect to it using different credentials? Im just trying to "add a network location", I dont get the option to choose a user there.

    UPDATE - 2015-08-04

    Now when I try "add a network location" I get this:

    "The folder that you entered does not appear to be valid. Please choose another"

    But it is very much valid, since I can access the very same folder via FTP


    Tuesday, August 4, 2015 1:12 PM
  • On your desktop you can either right click on my computer and chose map network drive (be sure to check the box connect using different credentials and enter the NAS credential)

    In the explorer you should have a map network drive on the menu bar on top  (be sure to check the box connect using different credentials and enter the NAS credential)

    Just asking this because some people add issue with cache credential since the upgrade.

    Tuesday, August 4, 2015 1:17 PM
  • Ah ok.

    But when I do what you said Frederick, I only get prompted with the "windows security" screen over and over, not matter what user(admin or other) it just keeps repopping and im 100% sure im typeing in the correct user and password

    UPDATE - 2015-08-04

    Now I get "The mapped network dirve could not be created because the following error has occurred:

    The file cannot be accessed by the system"

    I cannot "nslookup NASname" via cmd, should I be able to?

    Obviously I need to be able to if I add it via hostname, but if im not, it does not make any difference right?


    Tuesday, August 4, 2015 1:20 PM
  • Well to connect to my NAS at home i ad to do this.

    Connect using another credential and i enter nameofnas\username i also said reconnect at logon and save credential this way i don't get ask again. Because by default windows will pass the log on credential.

    DO you have another computer that can test the network mapping. 

    From the windows 10 station can you access the web interface of the NAS.

    Look at the NAS vendor website they might have tool to help you trouble shoot the issue.

    Tuesday, August 4, 2015 1:28 PM
  • Thats what I thought, with the nameofnas\username

    but if I cannot nslookup it, the nameofnas will just be mute?

    I can add the NAS with the FTP link, but thats an external add I guess

    Yes I can access it from another computer in the same network

    Yes I can access it via the web interface.

    So it has to be something im missing in windows. But I cannot for the life of me figure out what.

    Im still a bit stuck on the fact that I cannt resolve the name of the NAS in windows 10, that feels like it could be at least a problem.

    Tuesday, August 4, 2015 1:31 PM
  • well if you want to resolve dont know what you are using but if you have a private DNS make sure that the NAS register in the DNS if not you could simply use the famous HOST file.

    And for the credential you don't need to resolve the name of the NAS for it to work it`s what windows is passing so windows would pass nameofnas\username

    But if you want to resolve go to your host file C:\Windows\System32\drivers\etc\hosts open this with notepad (need ot be admin) and enter the IP 192.168.1.51   nameofnas

    Tuesday, August 4, 2015 1:36 PM
  • Yea added it to the host file, but I still cannot resolve the hostname of the NAS.

    But as you said, it does not matter if I add it with IP.

    This feels so weird.

    I can reach it, I can ping it. But I cannot login to it.


    Tuesday, August 4, 2015 1:45 PM
  • When I do this in CMD:

    net use \\iptonas\share01

    I get:

    "System error 1920 has occurred.

    The file cannot be accessed by the system"

    Tried to search for the answer, but cannot make heads or tail of it.

    Tuesday, August 4, 2015 2:00 PM
  • Another update.

    I cannot nslookup the NAS even though I have added it to the hosts file.

    So just to see if windows even can sense the NAS I changed the name of the NAS to something else.

    And yes, when I refresed the network in windows explorer, it updated the NAS with the new name.

    But I still cannot access it.

    Getting:

    "windows cannot access \\XXXXXFS01

    Check the spelling of the name. Otherwise, there might be a problem with your network...

    Error code: 0x80070035"

    Tuesday, August 4, 2015 2:34 PM
  • nslookup work on the DNS it doesn't work with the host file.

    So if you nslookup wihtout providing a specific DNS it will use your default one. By default it`s either the ips/google or what ever or the router you are using. These aren't aware of the NAS.

    Beside we know windows can see the NAS you said you can go to the web interface and the FTP.

    So you can stop looking for the NAS using the name if the IP work. Just need to make sure you are giving the right credential.


    Tuesday, August 4, 2015 2:37 PM
  • Nobody's said anything about a possible SMB version mismatch.  Can you update the firmware on your NAS at all?

    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.

    Tuesday, August 4, 2015 2:41 PM
  • I also just found the following three articles; if none of the above suggestions work for you, maybe these might help?

    https://social.technet.microsoft.com/Forums/en-US/65ddd7fc-2226-4f6c-8aac-e4c0c937b737/windows-10-and-smb?forum=WinServerPreview

    https://support.microsoft.com/en-us/kb/2696547

    http://blogs.technet.com/b/josebda/archive/2013/10/02/windows-server-2012-r2-which-version-of-the-smb-protocol-smb-1-0-smb-2-0-smb-2-1-smb-3-0-or-smb-3-02-you-are-using.aspx

    Good luck!


    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.

    Tuesday, August 4, 2015 2:47 PM
  • The NAS is fully updated.

    I have tried with several accounts from the NAS, I have even tried with newly created accounts. Newly created admin accounts, none admin accounts.

    Im still not allowed to log on.

    But I can logon with all the accounts, even the new ones, as long as I do it externally

    Tuesday, August 4, 2015 2:54 PM
  • Just found another thread where a user can't access his NAS supposedly after applying updates:

    https://social.technet.microsoft.com/Forums/en-US/aa5ce3c9-929a-497d-8ddc-17af132b8f98/windows-ipv4tcp-with-build-10240?forum=win10itpronetworking

    Thought it might be helpful to you.


    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.

    Wednesday, August 5, 2015 6:31 PM
  • Same exact issue here, that's what I noticed:

    - started with one of the last preview releases

    - Problem occurs after a few days after initial upgrade, when rebooting

    - Upgrade or clean install = no difference

    - Works on one machine (so far) but not others (using same shares)

    - All proposed solutions so far have had no effect (avoid PIN use, firewall, DNS, NETBIOS-over-IP, SMB version...)

    - Problem does not seem to be tied to NAS brand

    What does work however, is restoring my old Win7 disk image with Clonezilla, running Win7 and turning off the Win10 upgrade app :-( I hope MS provides an answer to this sometime in the near future or they are going to have a little problem with professional users adoption.


     

    Thursday, August 6, 2015 4:12 PM
  • Hi TryHarderFaiLess,

    Thank you for your question.

    For troubleshooting, we suggest you create a new account without administrator privilege, then delete all Window profile on Windows 10, then login with new account to check if could access NAS.

    We could update Window 10 to lasted, then run “SFC /ScanNow” to check the issue persist.

    If there are any questions regarding this issue, please be free to let me know.

    Best Regard,

    Jim


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Friday, August 7, 2015 8:32 AM
  • Hi there,

    I have read all threads. And I have exactly the same problem as you have, but I have solved it using simple way.

    Go to Setting -> Accounts -> "Sign in with a local account instead", follow the steps and sign out. The you will login with your local account and password.

    Finally you will access your NAS just like what you did on Win8 or win7.

    Cheers


    • Edited by NAN FEI Monday, August 10, 2015 2:22 PM
    • Proposed as answer by speedyjs Thursday, August 13, 2015 8:52 PM
    • Unproposed as answer by speedyjs Thursday, August 13, 2015 8:52 PM
    Monday, August 10, 2015 2:08 PM
  • The ping works, so does the NAS' own software find the NAS (in my case Buffalo NAS Navigator). But then again Windows 10 doesn't see it. Well, here is a solution which works for me (after spending many evenings trying all above mentioned solutions.

    Go to "Control Panel -> Programs"
    Select "Turn Windows features on or off" (requires admin rights)
    There you will find "SMB 1.0/CIFS File Sharing Support". Enable it!

    For some reason this was by default disabled. Once you enable it, reboot your computer and.... NAS (and probably other network drives) will be there were they belong to: File Explorer -> Network

    Good luck!

    *** It's a feature, not a bug :-D ***

    • Edited by speedyjs Thursday, August 13, 2015 9:03 PM
    • Proposed as answer by Mick Fernhout Thursday, August 4, 2016 12:56 PM
    Thursday, August 13, 2015 9:02 PM
  • In other words, it's what I said 10 days ago.  I've seen this happen with large printer/copiers too, that have the ability to 'scan to network drive'.  In those cases, it was a SMB version mismatch, which we usually try to upgrade the firmware on the copier which is why I offered my suggestion.  Sorry I wasn't able to give you the precise answer; I hope this will help others having NAS connection issues as there seems to be a lot of those after Win 10 upgrades.

    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.

    Friday, August 14, 2015 1:56 PM
  • Hi,

    I checked the SMB and it was installed, so I removed it and re-installed it but to no avail but it did get me thinking and I then went to check the network adapters properties and I noticed that my "Client for Microsoft Network" and "File and Printer Sharing for Microsoft Networks" were not selected, so I selected them.

    Once I did this, I was able to access NAS (Netgear) once again. I can only access it using the IP Address but I noticed the my "NetBIOS over TCP/IP" was set to No, so I'll enabled this and this should hopefully sort this out as well.

    Hope this helps.

    Update:

    Enabling NetBIOS over TCP/IP had no effect, so I switched it back to its original value but ended up editing the Hosts file located in c:\windows\system32\drivers\etc. Once I added the IP address of my NAS Drive and its name, it is now working using both the IP address and the Machine Name.

    • Proposed as answer by tfierens Thursday, September 10, 2015 12:18 AM
    • Edited by tfierens Thursday, September 10, 2015 12:30 AM
    Thursday, September 10, 2015 12:17 AM
  • Why is this thread marked as answered?  I have tried everything I can find on this topic and NOTHING works.  
    Wednesday, September 16, 2015 7:22 PM
  • This does not work for me.
    Wednesday, September 16, 2015 7:25 PM
  • This also does not work for me.
    Wednesday, September 16, 2015 7:26 PM
  • I tried all the stuff in this and other threads. Disabling the Firewall always worked, but I didn't think that was an ideal solution. I finally discovered that resetting WinSock worked for both machines I have now installed Win 10 on.

    Run cmd as admin: netsh winsock reset

    Hat Tip: Geeks In Phoenix

    • Proposed as answer by RichardPrz Thursday, January 25, 2018 2:31 PM
    Thursday, January 14, 2016 9:24 PM
  • Jim Xu, that is likely the worst advice I have ever seen on the Internet.  Delete everything and start over and hope it works?  Really?
    Saturday, January 30, 2016 9:00 PM
  • How can you mark this as answer when it is obviously NOT the answer?
    Saturday, January 30, 2016 9:26 PM
  • Hi All,

    The fix for me was quite simple and quick.

    Windows 10 for whatever reason changed the network location type to public, this blocked all access to the NAS drive.

    Simply changing the network location to private resolved the problem.

    Hope this helps someone else!

    Friday, April 8, 2016 8:21 AM
  • This is a pretty old post, but in case it's still not resolved, the registry hack in this forum post helped me out when my Western Digital ShareSpace NAS just disappeared one day after some Windows 10 updates.  My NAS is getting pretty old and a W10 security update apparently blocked access to it.
    Thursday, May 19, 2016 10:15 PM
  • After many days of doing everything people suggested above, the netsh winsock reset worked for me. Thank you so much Deborah.

    I think it's clear that Windows 10 is doing something different for everyone, and probably depending on when you installed/upgraded to Windows 10 and/or when you received a Windows Update, different fixes are going to be needed for everyone :\


    • Edited by h00ti3 Friday, July 15, 2016 8:47 AM Highlighting the command
    Friday, July 15, 2016 8:46 AM
  • Thanks, this resolved the same issue I had after upgrading to Win 10 Anniversary Update (August 2016 ie a year later!). Enabled the feature, restarted, and voila it works again as before!
    Thursday, August 4, 2016 12:58 PM
  • I had the same problem but I found that it was to do with network discovery. I ticked the turn on automatic setup of network-connected device.  this works. 
    Tuesday, September 20, 2016 7:08 PM
  • Windows 10 Anniversary Update

    NAS no longer accessible with map drive letters, it was accessible via IP address

    I had an issue with the network card not installing correctly (Realtek PCIe GBE Family Controller)

    Took two attempts to get the network card to install working.

    Many of the local area network card properties were not ticked for the network card.

    Ticking "Link-Layer Topology Discovery Mapper I/O Driver" - "Used to discover and locate other pc's, devices, and network infrastructure......................" allowed the NAS to be seen and be accessed from windows explorer

    Thursday, September 22, 2016 9:08 AM
  • To improve security, the ability to disable the Secure Negotiate SMB setting was intentionally removed from Windows 10 (RequireSecureNegotiate) to guard against man-in-the-middle attacks. Home NAS devices were particularly impacted by the change. Those experiencing problems immediately after upgrading from older OS version to Windows 10 could be experiencing that.

    Contact NAS device providers to see if updated firmware exists that supports Secure Negotiate.

    Related: https://msdn.microsoft.com/en-us/library/hh830477(v=vs.85).aspx

    Friday, September 23, 2016 7:24 PM
  • I had the same issue with a Buffalo Terastation. I was able to resolve the problem buy doing the following.

    Just a note in case anyone else runs into this problem. If you want to connect to a share on a Buffalo Terastation (which seems to be using Samba) from a Windows Vista installation, you need to do the following:

    ·         Run the Local Security Policy app - secpol.msc

    ·         Go to Local Policies | Security Options and choose the "Network Security: LAN Manager Authentican Level" item

    ·         Set it to "Send LM & NLTM, use NTMLv2 session if negotiated"

    And that should sort you out.[Update]For those of us unlucky enough to be running Vista Home (which doesn't come with secpol), you can do the following (thanks to Patrick in the comments for this)

    ·         Run regedit (Windows-R, 'regedit') to open the registry editor

    ·         Find key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\

    ·         Change the value for the option "LMCompatibilityLevel" from 3 to 1.

    Now you should be able to access the Terastation (you may need to reboot)

    [Update 25th August 2009]. A couple of commenter’s have been kind enough to say that this also works in Windows 7 RC and thus in Windows 7 RTM (pretty safe assumption). For what it's worth, I have a Windows 7 RC virtual machine running and I've been able to connect fine without needing to make any changes that I can remember.

    Saturday, January 7, 2017 7:20 PM
  • Tried for two days to solve the same problem

    netsh winsock reset finally resolved my issue

    Thursday, January 25, 2018 2:33 PM
  • The ping works, so does the NAS' own software find the NAS (in my case Buffalo NAS Navigator). But then again Windows 10 doesn't see it. Well, here is a solution which works for me (after spending many evenings trying all above mentioned solutions.

    Go to "Control Panel -> Programs"
    Select "Turn Windows features on or off" (requires admin rights)
    There you will find "SMB 1.0/CIFS File Sharing Support". Enable it!

    For some reason this was by default disabled. Once you enable it, reboot your computer and.... NAS (and probably other network drives) will be there were they belong to: File Explorer -> Network

    Good luck!

    *** It's a feature, not a bug :-D ***

    This fixed it for me. I tried a bunch of stuff and this was not installed on my pretty much default Win10 Pro installaltion. 

    tagremotehelp

    • Proposed as answer by Nicholas Moult Thursday, November 1, 2018 1:53 PM
    • Unproposed as answer by Nicholas Moult Thursday, November 1, 2018 1:53 PM
    Tuesday, October 23, 2018 9:02 PM
  • Hi, I have been battling with this one too.

    I have tried all the other solutions mentioned in this subject.

    What worked for me is as follows :

    Ensure that you have the NAS name defined in the hosts file in C:\Windows\System32\drivers\etc

    Ensure it is in the format NASdeviceName    IP address (as described in the host file comments)

    Ensure you can ping the NASdeviceName and you get the correct ping response.

    Then open Manage Windows Credentials (Type windows credentials in Control panel search field and select "Manage Windows Credentials".)

    If you have an entry for the NasdeviceName - ENSURE that the NAS user id is PRECEDED by the NasdeviceName\.

    So if your user name on your My Cloud device is "fred" and your NAS Device name is "MyCloud" (i.e you can ping the device MyCloud successfully) - then the username field for your NAS device in the Windows Credentials should be "MyCloud\fred".

    This worked 100% for me.

    Thursday, November 1, 2018 2:05 PM