none
DPM 2010 and SQL 2008 RRS feed

  • Question

  • I recently swaped my database from simple to full logs. Remove the protection from DPM and re-added it to do incremental backups. I now see under create recovery point my two options incremental or express. Great its working now . Lastnight I ran a reindex of my database since it hasn't been done in awhile. The transaction logs grew from 1 gig to 12. I was under the impression that incremental backups would pull the data from the transaction logs and commit it. When go to Studio manager and click tasks - shrink - file , select log I see 99% free. However after running the command the log file remains the same size. When I do a DBCC LOGINFO I get 400-500 lines, at the end of the report I see the last row with a status of '2', so there is information that is uncommited?? Why would this be going on after a incremental backup and full backup has occured? The fact that the last row has a status of '2' is why I can't shrink the logfile!

    I run incremental backups every 4 hours and a full express backup once a day. The easy way out is just to set the database back to simple and full again. I guess I really need to know why I see what I see in DBCC LOGINFO


    Thanks!

    **UPDATE

    For some unknown reason when I ran DBCC LOGINFO again the status coloum was all '0's. I was able to at that point shrink the logs. yay :)


    Saturday, October 13, 2012 1:52 PM

All replies

  • Hi Mike

    i see in your update you were able to shrink the logs, are you still experiencing problems?

    Friday, October 26, 2012 11:20 AM