none
Windows 8.1 update 1 tablets keep defaulting to desktop RRS feed

  • Question

  • Now I'll start by saying I just say Keith mention needing to copy the 6.2 unattend files to 6.3. Which I'll try doing, but won't have time until next week. Has anyone thus far imaged a tablet with 8.1u1 yet? I built all new images using the 8.1 ISO that includes update 1. I have the latest ADK installed, but I'm guessing something in MDT isn't aware of what's changed.

    As of right now, if I image a tablet it always goes back to the desktop when an app is closed even if it is not set to boot to desktop. Anyone else experience this? Next week I'll try building all new task sequences and reference images after copying all the 6.2 unattend files to 6.3

    Friday, April 18, 2014 9:28 PM

Answers

  • No GPOs are applied and this is being imaged as a normal "workgroup" tablet. After looking over it, the unattend.xml file wouldn't have been an issue as the only changes needed were already in it. I did notice two things that could be contributing factors. One I have HideShell=YES on my deployment share for creating reference images and two the reference image for tablet had the check box to boot to desktop. Although that still doesn't explain why after changing it to boot to start it still goes to the desktop after an app is closed. Anyway I found some information saying that the deployment share should be updated and rebuild the boot images after installing the ADK update. I'm going to make these changes, build some new sequences and a new image and see what happens.

    I think I may have found my answer (or rather cause): http://social.technet.microsoft.com/Forums/windows/en-US/7af9dab9-b955-4179-b79a-ff73495d17ef/forum-faq-go-to-start-screendesktop-when-closing-windows-store-app?forum=w8itprogeneral

    Actually, yup that's it. If the box is checked for "Show Windows Store apps on the taskbar" it will go back to the desktop when you close a store app.

    My Solution: Uncheck that box and then recapture the reference image. (I have a specialize image for tablets) and I'm using copy profile

    Alt Solution: Either uncheck the box manually or script a registry change.

    I tracked it down, change the 1 to a 0 
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
    "StoreAppsOnTaskbar"=dword:00000001

    • Edited by Dan_Vega Monday, April 21, 2014 3:35 PM
    • Marked as answer by Dan_Vega Monday, April 21, 2014 3:45 PM
    Monday, April 21, 2014 2:45 PM

All replies

  • Dan, as far as I know, with the new Windows 8.1 Update any touch enabled device will boot to Start while all others will boot to desktop. This is a feature of the update, not MDT.

    "If you are using a traditional, non-touch PC with Windows 8.1 Update installed, the PC will now bypass the Start screen and boot to the desktop by default. This feature can be overridden by the PC maker, and you can of course change this behavior as well."

    Do you by chance have a GPO in place to change this behavior? I have deployed it to a few Surface Pros with no issues (yet).


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Sunday, April 20, 2014 5:48 AM
  • No GPOs are applied and this is being imaged as a normal "workgroup" tablet. After looking over it, the unattend.xml file wouldn't have been an issue as the only changes needed were already in it. I did notice two things that could be contributing factors. One I have HideShell=YES on my deployment share for creating reference images and two the reference image for tablet had the check box to boot to desktop. Although that still doesn't explain why after changing it to boot to start it still goes to the desktop after an app is closed. Anyway I found some information saying that the deployment share should be updated and rebuild the boot images after installing the ADK update. I'm going to make these changes, build some new sequences and a new image and see what happens.

    I think I may have found my answer (or rather cause): http://social.technet.microsoft.com/Forums/windows/en-US/7af9dab9-b955-4179-b79a-ff73495d17ef/forum-faq-go-to-start-screendesktop-when-closing-windows-store-app?forum=w8itprogeneral

    Actually, yup that's it. If the box is checked for "Show Windows Store apps on the taskbar" it will go back to the desktop when you close a store app.

    My Solution: Uncheck that box and then recapture the reference image. (I have a specialize image for tablets) and I'm using copy profile

    Alt Solution: Either uncheck the box manually or script a registry change.

    I tracked it down, change the 1 to a 0 
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
    "StoreAppsOnTaskbar"=dword:00000001

    • Edited by Dan_Vega Monday, April 21, 2014 3:35 PM
    • Marked as answer by Dan_Vega Monday, April 21, 2014 3:45 PM
    Monday, April 21, 2014 2:45 PM