Force Reporting Services 2012 use https


  • I have recently set up a new instance of SQL Server Reporting Services. I have it running and am in the testing phase of the deploy. I have set it up to use SSL and basic Authentication. This all works. The report writer has been able to deploy reports and start testing. In this testing we discovered that the menu on the left of the report manager in the data sources or reports management window will not use https. So let me explain it more.

    If you browse to a report or data source in Report Manager then highlight and click on the down arrow and choose "Manage" you will get a page with the report's or data sources' properties. It will also have a menu on the left with items like "Subscriptions", "Dependent items", and "Security". If I click on one of these items I get a 404 page error. I can then go to the url and simply put a 's' in the http so it read https and it will work.

    Due to security requirements I have had to block all port 80 traffic, if I open port 80 it will work. It only works as http with port 80 open. The menu url never defaults to htts.

    I have set the root url to have an https at the front. This made no change.

    I tried setting the ReportServerUrl in the c:\Program Files\Microsoft SQL Server\MSRS11.MSSQLSERVER\Reporting Services\ReportServer\rsreportserver.configfile. I set it to include the https at the front as such Yes I changed the url so the Reports is the Report Manager. This broke the entire Report Manager. It would give me an error of:

    The attempt to connect to the report server failed. Check your connection information and that the report server is a compatible version.

    I have also tried to force report portal to use https by setting the secureconnectionlevel in \c:\Program Files\Microsoft SQL Server\MSRS11.MSSQLSERVER\Reporting Services\ReportServer\rsreportserver.config to 2, then to 1 and it gave me an error both times.

    The underlying connection was closed: An unexpected error occurred on a send.

    If anyone knows how to force Reporting services to use https for all urls or if I am doing something wrong please let me know.

    Friday, March 14, 2014 10:19 PM

All replies

  • URL reservations for Report Manager and the Report Server Web service are configured independently. If you want to also configure Report Manager access through an SSL-encrypted channel, continue with the following steps:

    1. Click Report Manager URL.

    2. Click Advanced.

    3. In Multiple SSL Identities for Report Manager, click Add.

    4. Select the certificate, click OK, and then click Apply.

    5. Click the URL to verify it works.


    Regards, RSingh

    Saturday, March 15, 2014 4:31 AM
  • It sounds to me like you have configured SSRS with both HTTP and HTTPS (SSL).  If you did a standard install a record is created for HTTP in both the web service URL and report manager URL.  If you can access both is sounds like you added the HTTPS without removing the HTTP.  Open "Reporting Services Configuration Manager" and go to the "Web Service URL" and "Report Manager URL" tabs on the left and click "Advanced" and select the entries you have under "Multiple Identities for ..."  This will then limit it to just HTTPS...
    Monday, March 17, 2014 4:37 PM
  • You are right JJordheim. I did set it up with HTTP and HTTPS. I then removed the HTTP from the Report Manager URL in the "Advanced". I tried to remove the HTTP from the Web Service URL. If I remove the HTTP and only have the HTTPS I receive the following error. "The underlying connection was closed: An unexpected error occurred on a send." I have not been able to find a fix for this error.

    Just an FYI we are using RSWindowsBasic as the authentication type and I have tried it with SecureConnectionLevel set to 0 and 2. Saw these as possible solutions on the web but they did not work.

    • Edited by Diskokid Tuesday, March 18, 2014 4:47 PM
    Tuesday, March 18, 2014 4:28 PM
  • @Diskokid I have exactly the same problem, did you find a solution yet?

    -edit- _remove the HTTP from the Web Service URL_

    That did it for me. I got an error at first but it turned out that the certificate was wrong. The machine was named ABACUS but could be reached using I renamed the machine REPORTS, requested a certificate  and used that certificate to set up SSL and used the following url  as a guide to check all.

    • Edited by Henrov Monday, June 23, 2014 7:26 AM found solution
    Monday, June 23, 2014 7:18 AM