locked
ProClarity client error in module PVCL7.bpl RRS feed

  • Question

  • We were adding members to a filter list in the client, and received:

    "An error occurred in the application:  Access violation at address 04B547B4 in module 'PVCL7.bpl'.  Read of address 00000004"

    Has anybody seen this before?  Does anyone have any tips on additional debugging we can do to figure this one out?

    Thanks in advance!

    Cheers,
    Ron
    Friday, October 3, 2008 2:23 PM

Answers

  • Hello keruibo,

     

    Have you attempted uninstalling / reinstalling the Professional client on one of the machines to test whether that fixes it?  I've seen these .bpl errors appear if client machines are running low on memory.  That might be something you could check as well.

     

    Regarding hotfixes; the Professional hotfix updates the files for both Web Pro and Desktop Pro. 

     

    Regards,

    Amanda 

    Thursday, October 9, 2008 10:39 PM

All replies

  • Hello Ron,

     

    Are you using a custom add-in?  If so, do you have another dev machine you can test on to see if the problem is environmental?

     

    Regards,

    Amanda

     

    Tuesday, October 7, 2008 11:29 PM
  • I have the same problem at a customer location.  The server is patched to build 2214.  The clients are running web pro on XP.  Web pro was installed after the PAS patch was applied.  Not all clients have this issue, but it's still a problem.  No custom add-ins, just out of the box Web Pro.

     

    In this customer's case, the report is that they will "select anywhere in the grid, then click on the file menu, and get the error".  The error text is:

    "An error occured in the Application: Access violation at address 076E6028 in module 'PVCL7.bpl'. Read of address 00000004"

     

    I can pass along a screen print via e-mail if it would be helpful.

     

    One thing that occurs to me is that there are patches for PAS, patches for Desktop Pro, but no patches specifically called out for the web pro after it's installed on clients (that I know of).  Could there be any issues on a web pro client that would be resolved by patching...and if so how to do it (install the desktop pro patch?)

     

    Wednesday, October 8, 2008 1:51 PM
  • Hello keruibo,

     

    Have you attempted uninstalling / reinstalling the Professional client on one of the machines to test whether that fixes it?  I've seen these .bpl errors appear if client machines are running low on memory.  That might be something you could check as well.

     

    Regarding hotfixes; the Professional hotfix updates the files for both Web Pro and Desktop Pro. 

     

    Regards,

    Amanda 

    Thursday, October 9, 2008 10:39 PM
  • Amanda,

    Thanks for your reply!  I'll give that a try asap.  Thanks for the info on the hotfixes this is also very helpful to get confirmed.

    Best regards,
    Rob Kerr


    -----
    http://blog.robkerr.com
    Thursday, October 9, 2008 11:03 PM
  • svetliofotis

    Monday, October 20, 2008 2:28 PM
  • Thanks, Amanda.  The Desktop Pro hotfix resolved the problem I was having with Web Pro.

     

    Monday, October 20, 2008 3:59 PM