Unable to configure Reporting Services 2012 after using 'netsh http delete urlacl' command and .EXE file also.


  • One of my servers quit responding during some troubleshooting of another issue and when I try to reconfigure it I am receiving Results as follows:

    Reserving url http://+:80
    The URL has already been reserved.

    It appears to me that there is something with the Virtual Directory that is not allowing me to use it or overwrite it.  If I change the name or the port the new configuration works fine, however this is part of a scale-out test environment and I need to keep the virutal directory names the same.

    I have uninstalled and reinstalled SSRS in an attempt to resolve, but that did nothing to this issue.
    I have used 'netsh http delete  urlacl' command and deleted saved urls also but still am facing issue.

    How can I manually list, delete, or edit  Virtual Directories in SSRS 2012? 

    Sunday, July 13, 2014 10:53 AM

All replies

  • Hi Syed,

    Based on my research, the issue can be caused by the default values for Report Server Web Service and Report Manager has already been reserved. In order to trouble shoot this issue, please refer to the following steps:

    1. To check this issue, we can run the following command in the command windows:
      netsh http show urlacl | find "Report"
    2. It should returns the reserved URL as below:
      Reserved URL            : http://+:80/ReportServer/
      Reserved URL            : http://+:80/Reports/
    3. Then we can delete the reserved URLs with the command below and recreate them to fix this issue:
      netsh http delete urlacl http://+:80/ReportServer/
      netsh http delete urlacl http://+:80/Reports/


    Hope this helps.

    Katherine Xiong

    Katherine Xiong
    TechNet Community Support

    Monday, July 14, 2014 8:59 AM
  • Dear Katherine,

    Thanks for sharing this beautiful information. 

    I have already tried the above mentioned scripts and deleted the reserved URL's (both Reports & Reportserver) but again I'm finding the same error.

    Reserving url http://+:80
    The URL has already been reserved.

    And now I'm not finding the url's related to this reportserver in reserved URL's but still in web service url it is throwing the same error.

    Please suggest.


    Syed Osman.

    Tuesday, July 15, 2014 7:39 AM